Message Filter to REMOVE Encryption Keyword from SubjectLine

Unanswered Question
Feb 19th, 2009
User Badges:

Hello, I am trying to write a message filter that will encrypt and remove our Encryption Subject keyword and leave the topical subject in place. So far, i have had no luck removing and encrytping messages. Our subject line keyword is TestIEA2009

Here is the message filter that was written:

encrypt-and-edit-subject:

if ((sendergroup == "RELAYLIST") AND (subject == '(?i)\\[TestIEA2009\\]'))
{

edit-header-text('subject', '(?i)\\[TestIEA2009\\]', '');

insert-header('X-Envelope-Encrypt', 'Yes');

}
}

I recieve the encrypted message but it still has the keywork in the subject.

Any Help is appreciated!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Rayman_Jr Fri, 02/20/2009 - 07:46
User Badges:

I have exactly the same challenge ! Any advice would be highly appreciated.

kyerramr Fri, 02/20/2009 - 08:46
User Badges:

This filter of your's works perfectly fine, except the end flower bracket.

Working filter

encrypt-and-edit-subject:
if ((sendergroup == "RELAYLIST") AND (subject == '(?i)\\[TestIEA2009\\]'))
{
edit-header-text('subject', '(?i)\\[TestIEA2009\\]', '');
insert-header('X-Envelope-Encrypt', 'Yes');
}

-Kishore

jf0x Tue, 02/24/2009 - 16:32
User Badges:

Thanks for the help Kishore. I have corrected the Message Filter but I still have the same issue.

When a message is composed we are using the subject 'TestIEA2009 Then the Email Subject Here' (minus the quotes)

The encryption is still applied but the message filter doesn't strip the TestIEA2009 from the recipients email message.

What am I missing?

jf0x Thu, 03/05/2009 - 17:32
User Badges:

OK. Finally got it working. Here is the resolution.

The message filter is correct. Place this on the C-Series.

encrypt-and-edit-subject:
if ((sendergroup == "RELAY_LIST") AND (subject == '(?i)TestIEA2009'))
{
edit-header-text('subject', '(?i)TestIEA2009', '');
insert-header('X-Envelope-Encrypt', 'Yes');
}

Then create a new Outgoing Content Filter as follows:

Test_IEA: if (header("X-Envelope-Encrypt"))
{ encrypt ("Presidio_IEA_High", "$Subject"); }

Thanks,
Jason

dtabbert82_ironport Tue, 07/28/2009 - 20:53
User Badges:

I can't seem to get the last peice to work where I'm trying to insert the header. I have the code just like is posted but it still doesn't work? Any thoughts on what I might have configured wrong?

kluu_ironport Thu, 07/30/2009 - 17:14
User Badges:

When you try to implement the following filters,

encrypt-and-edit-subject: 
if ((sendergroup == "RELAY_LIST") AND (subject == '(?i)TestIEA2009'))
{
edit-header-text('subject', '(?i)TestIEA2009', '');
insert-header('X-Envelope-Encrypt', 'Yes');
}

Then create a new Outgoing Content Filter as follows:

Test_IEA: if (header("X-Envelope-Encrypt"))
{ encrypt ("Presidio_IEA_High", "$Subject"); }



do you match the IF condition, but for whatever reason, the insert-header() action doesn't insert the custom header?

I would recommend that you go to the "Administration > Trace" section and simulate the message that would in theory match those conditions. The trace tool is a way convenient to test your filters and then observing all the rules/actions that match and are applied to the message.

If you can test the Trace tool and paste back in the Trace results from the GUI or give a screenshot of it, it would be helpful.

I can't seem to get the last peice to work where I'm trying to insert the header.  I have the code just like is posted but it still doesn't work?  Any thoughts on what I might have configured wrong?

Actions

This Discussion