BGP Traffic 6 Mbps (URGENT)

Answered Question
Feb 19th, 2009
User Badges:

Hi,


One of my customer is facing strange issue.Total BW of the link is 20 Mbps 1:4,Customer is using full BGP route from service provider.Below is the config customer is having....As per customer BGP itself is taking 6 Mbps .....



router bgp 16838

no synchronization

bgp log-neighbor-changes

bgp dampening

network XX.XX.XX.XX mask 255.255.254.0

network XX.XX.XX.XX

network XX.XX.XX.XX

neighbor ibgp peer-group

neighbor ibgp remote-as 16838

neighbor ibgp update-source Loopback0

neighbor ibgp version 4

neighbor ibgp prefix-list default out

neighbor XX.XX.XX.XX remote-as 16838

neighbor XX.XX.XX.XX update-source Loopback0

neighbor XX.XX.XX.XX version 4

neighbor XX.XX.XX.XX peer-group ibgp

neighbor XX.XX.XX.XX default-originate

neighbor XX.XX.XX.XX peer-group ibgp

neighbor XX.XX.XX.XX default-originate

neighbor XX.XX.XX.XX remote-as 16838

neighbor XX.XX.XX.XX description Arbor

neighbor XX.XX.XX.XX password 7 012112560D4A1C3B2C

neighbor XX.XX.XX.XX update-source Loopback0

neighbor XX.XX.XX.XX remote-as 9498

neighbor XX.XX.XX.XX ebgp-multihop 255

neighbor XX.XX.XX.XX version 4

neighbor XX.XX.XX.XX route-map backup out

neighbor XX.XX.XX.XX filter-list 5 out

route-map backup permit 10

match ip address prefix-list corp

set as-path prepend 16838 16838 16838

!

route-map backup permit 20

!

route-map static-ospf permit 10

match ip address 175

!

route-map BRN1 permit 10

match ip address prefix-list VRSN

set as-path prepend 16838 16838 16838


We had given the suggestion to create route map to stop stop bgp



route-map NONE deny 10


router bgp xyz

neighbour xx.yy.zz.aa route-map NONE in neighbour xx.yy.zz.aa route-map NONE out


ujil


Correct Answer by Giuseppe Larosa about 8 years 2 months ago

Hello Ujil,

modify the configuration on your side to send them only the default route and ask them to verify again BGP BW usage on the link.

A change on their side doesn't stop your router from sending routes to them on the session.


Their router can be out of memory and so it is not able to load all the BGP routes and the process of learning is never ending.

Other possible issues can be IOS dependent: some days ago someone by error sent out a too long AS path advertisement that caused BGP session to reset continously on routers with rather old ios.

See the thread about long AS paths


OR also before sending only the default route


Have th customer check with

sh ip bgp summary on their side:

the time the session is up the number of prefixes learned from you


from your side you can check with the same command if the session is stable or it is often reset.


Hope to help

Giuseppe



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Giuseppe Larosa Thu, 02/19/2009 - 23:22
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Ujil,

modify the configuration on your side to send them only the default route and ask them to verify again BGP BW usage on the link.

A change on their side doesn't stop your router from sending routes to them on the session.


Their router can be out of memory and so it is not able to load all the BGP routes and the process of learning is never ending.

Other possible issues can be IOS dependent: some days ago someone by error sent out a too long AS path advertisement that caused BGP session to reset continously on routers with rather old ios.

See the thread about long AS paths


OR also before sending only the default route


Have th customer check with

sh ip bgp summary on their side:

the time the session is up the number of prefixes learned from you


from your side you can check with the same command if the session is stable or it is often reset.


Hope to help

Giuseppe



bagvanliju Thu, 02/19/2009 - 23:32
User Badges:

Hi Giuseppe ,


All are in Bridge ..discussing the same ..Will update you the status later..thanks for the quick responce ..


ujil

bagvanliju Fri, 02/20/2009 - 02:38
User Badges:

Hi Giuseppe,


the issue is now seems to be resolved there was some customer end issue the same got resolved when customer has change the config ...we hve requested customer customer to share the same.No changed done from Service provider end.


Thanks for the timly help


ujil

Actions

This Discussion