Busy tone out from FXO

Unanswered Question
Feb 20th, 2009
User Badges:

Hi,


I've a trouble to generate a busy-tone out from a FXO interface.


If a PSTN user calls the FXO number and the related internal number is busy on calls ( i configured a connection plar on the FXO ) , the PSTN caller does not receive the busy tone.


Any suggest ?


Many thanks


Luigi

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.7 (3 ratings)
Loading.
LUIGI PIETRONAVE Fri, 02/20/2009 - 02:41
User Badges:

Hi Paolo,


Thank You very much for the quick reply. Do You have some sample configuration ?


Regards and many thanks


Luigi

paolo bevilacqua Fri, 02/20/2009 - 03:05
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, config examples are in the script itself.

paolo bevilacqua Fri, 02/20/2009 - 05:01
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

You are welcome. Please rate useful posts with the scrollbox below.

LUIGI PIETRONAVE Mon, 02/23/2009 - 06:10
User Badges:

Hi Paolo,


just to be sure I've well understood: my situation is to have a VG with several FXO port connected to PSTN and the gateway is an H.323 gtw connected to a ccm 4.3.


If I want to send each fxo to different internal IP-Phone, and considering that I see the CALLED NUMBER empty ( with debug vpm signal ) , i can just use the connection plar ?


Still many thanks


Luigi

paolo bevilacqua Mon, 02/23/2009 - 06:14
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Yes. I suggest connection plar opx, so that the FXO port answers only when the IP phone answers.

LUIGI PIETRONAVE Mon, 02/23/2009 - 06:21
User Badges:

Thanks for the useful quick reply.


Can You explain better how to configure the busyout with script ? To be clear, the problem it isn't about your explaination but about my poor understanding of scripts.


In my case the call-flow is:

- call to 12345 ( public number of pots )

- forward to 75999 ( via connection plar )


Regards and thanks


Luigi

paolo bevilacqua Mon, 02/23/2009 - 08:51
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


under the voip DP for 75999, put max-conn 1.

Create another voip DP, again destination-pattern 75999, but preference 2. Configure the service there. However, that could not cove the case when 75999 is on an internal call.


The alternative, would be setting trigger-busy 1 for 75999, set CFB to say, 75900, route-pattern 75900 back to GW, configure the script in there with DP voip, incoming called-number 75900.

Actions

This Discussion