CCME and CUE problem

Unanswered Question
Feb 20th, 2009

Hello,

We are experiencing problems with single CCME and CUE configuration.

We have one H.323 voip trunk to local ISP with audio codec of G711alaw. Unfortunately our CUE uses G711ulaw, so incoming calls to CUE are dropped with cause code 41 (or 65 - Bearer capability not implemented). I made some test and with G711ulaw end-to-end everything is OK.

Our ISP cannot provide us Voip service using G711ulaw, so I tried to configure local transcoding.

Using show dspfarm all I can see that transcoding profile is UP and ASSOSIATED.

But incoming calls don't use this transcoding resource, so they are still dropped.

Any suggestion to resolve this issue?

Does Unity Express support G711alaw?

Thank you

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sistefanov Fri, 02/20/2009 - 06:38

Thank you for the fast answer!

Here you can see requested information:

dspfarm

dsp services dspfarm

telephony-service ccm-compatible

tftp-server flash:dsp41.1-1-3-30.sbn

tftp-server flash:dsp11.1-1-3-30.sbn

dspfarm profile 1 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729br8

codec g729r8

maximum sessions 6

associate application SCCP

telephony-service

load 7961 SCCP41.8-0-4SR2S

load 7911 SCCP11.8-0-4SR2S

max-ephones 96

max-dn 96 no-reg primary

ip source-address x.x.x.x port 2000

timeouts interdigit 7

system message XXX

sdspfarm units 1

sdspfarm transcode sessions 3

sdspfarm tag 1 mtp00070e72baf0

time-zone 28

time-format 24

date-format dd-mm-yy

dialplan-pattern 1 XXXXX extension-length 5 extension-pattern XXXX

voicemail XXXX

max-conferences 8 gain -6

moh music-on-hold.au

web admin system name XXXX password XXXX

dn-webedit

time-webedit

transfer-system full-consult

transfer-pattern .T

secondary-dialtone 0

create cnf-files version-stamp 7960 Sep 24 2008 16:48:05

Thank you,

Svilen

Nicholas Matthews Fri, 02/20/2009 - 08:20

Hi Svilen,

can you do a 'debug voip dialpeer', figure out your incoming and outgoing dial peers, and post those and your IOS version?

-nick

sistefanov Fri, 02/20/2009 - 08:34

Thank you again :-)

Please find requested information attached to this post.

Incoming dial-peer 1:

dial-peer voice 1 voip

description incomming from ISP

translation-profile incoming ISP-IN

voice-class codec 1

voice-class h323 1

incoming called-number 0243419T

dtmf-relay rtp-nte cisco-rtp h245-alphanumeric

fax protocol pass-through g711alaw

Attachment: 
Nicholas Matthews Fri, 02/20/2009 - 08:44

Try taking the voice-class codec off, and either setting a hard g711alaw or g729r8. There were some IOS versions that had problems with that configuration.

-nick

sistefanov Fri, 02/20/2009 - 08:47

Unfortunately it doesn't work again with g711alaw set up on incoming dial-peer:

dial-peer voice 1 voip

description incomming from ISP

translation-profile incoming ISP-IN

voice-class h323 1

incoming called-number 0243419T

dtmf-relay rtp-nte cisco-rtp h245-alphanumeric

codec g711alaw

fax protocol pass-through g711alaw

Thank you,

Svilen

sistefanov Fri, 02/20/2009 - 08:52

dial-peer voice 50090 voip

description to VoiceMail pilot

translation-profile outgoing voicemail

destination-pattern 5009.

session protocol sipv2

session target ipv4:x.x.x.x

dtmf-relay sip-notify rtp-nte sip-kpml

codec g711ulaw

no vad

Nicholas Matthews Fri, 02/20/2009 - 09:03

Configuration looks like it should work, you can try a 'no sccp' 'sccp' to reset the transcoder.

sistefanov Fri, 02/20/2009 - 09:08

Thank you,

I tried to reset sccp, but calls are still dropped.

As I said early, transcoding resource is registered/associated and I beleive it is working (at this time I can't test it).

thierry.berwart_2 Fri, 08/07/2009 - 01:48

Hi,

I want to do more or less the same thing ...

Did you finally succeed to configure your router/transcoder ?

Thanks you in advance,

Thierry

VoipRocks Fri, 08/07/2009 - 06:45

I have observed that to allow transcoding between H323 to H323, you may have to configure the following.

voice service voip

allow-connections h323 to h323

You may also have to hairpin the calls via a loopback address.

HTH

TF

Actions

This Discussion