CALL FORWARDING TO PSTN FAILS

Unanswered Question
Feb 20th, 2009

I am using an E1 isdn pri line for my ccme but call forwarding to a PSTN number fails if the call to be forwarded originates from the PSTN.

When i activate call-forward all, callers from PSTN gets a fast busy tone instead of being redirected to the PSTN number the call has been forwarded to.


When i call the same extension from another internal extension, the call forward is successful.


help please

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
ronalddiane Fri, 02/20/2009 - 07:59

I'd want to know if you define the call-forward pattern in telephony-service mode. If you've not done yet, please do it now.

conf t

telephony-service

call-forward pattern .T

Paolo Bevilacqua Fri, 02/20/2009 - 08:01

Ronalddiane, if the OP had not configured a correct transfer-pattern already, also forwarding for internal calls would not work, instead it does.

syedarif25 Wed, 02/25/2009 - 22:24

Hi


I have a similar problem , where the call forward works from the internal number and it dones not work from the external number, the debug ISDN q931 shows " Incomplete number "


Good CALL


Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x89

Exclusive, B1

Progress Ind i = 0x8183 - Origination address is non-ISDN

Calling Party Number i = 0x0080, '205788388'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, '0611818625'

Plan:Unknown, Type:Unknown


BAD CALL:


Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x89

Exclusive, B1

Progress Ind i = 0x8283 - Origination address is non-ISDN

Calling Party Number i = 0x00A3, '205788388'

Plan:Unknown, Type:Unknown

Called Party Number i = 0xA1, '0611818625'

Plan:ISDN, Type:National

Sending Complete

004493: Feb 26 06:01:24.020: ISDN BR0/0/1 Q931: RX <- STATUS pd = 8 callref = 0x92

Cause i = 0x82E41E - Invalid information element contents

Call State i = 0x01

004494: Feb 26 06:01:24.096: ISDN BR0/0/1 Q931: RX <- CALL_PROC pd = 8 callref = 0x92

Channel ID i = 0x89

Exclusive, B1

004495: Feb 26 06:01:24.816: ISDN BR0/0/1 Q931: RX <- DISCONNECT pd = 8 callref = 0x92

Cause i = 0x879C - Invalid number format (incomplete number)


Any help will be greatful !


Thanks


ARIF

SYMON-PHARES Wed, 02/25/2009 - 22:36

Someone somewhere must have solved this problem, help out, its running out of hand please.

Paolo Bevilacqua Thu, 02/26/2009 - 01:12

Symon: you have not sent the "debug isdn q931" that had been asket. You cannot be helped if you do not send it.


Arif: try

interface bri x/y/z/

isdn map address . plan unknown type unknown

syedarif25 Thu, 02/26/2009 - 03:34

Hi,


Thanks for the reply and the suggession, it did not help , i have attached the config of cme and the log when i enable CFD and when i call the phone directly. ( debug isdn q931 & debug voice ccapi inout)


Request you to verify and let me know if you find some issue in the configuration.


Do you think this would be problem with the telecom provider ?


Thanks again & await for you reply.


ARIF




Paolo Bevilacqua Thu, 02/26/2009 - 04:00

Command is:

isdn map address . plan unknown type unknown


not


isdn map address plan plan unknown type unknown

symonphares Thu, 02/26/2009 - 07:49

Hi all the good people, see attached the output for debug isdn q931 from my ccme router when i make a call to a number with cfa activated.


Would appreciate any suggestion leading to the correct solution of the problems.


Thanks in advance.






Paolo Bevilacqua Thu, 02/26/2009 - 08:51

Which exact IOS are you using?

Please take another trace enabling also "debug voice ccapi default"

syedarif25 Fri, 02/27/2009 - 02:34

Hi bevilacqua


The CFD challenge has been fixed now after applying the command on the BRI interface


Thanks for your prompt support and right solution.


ARIF



syedarif25 Fri, 02/27/2009 - 03:41

Hi,


I have one more clarifcation with regards to the CFD.


How can i enable CFD to the Secondary number alone ( DID NUmber ), indeed i have tried using the command on ephone-dn "no foward local calls" , if i do this , then extenal call forward is working fine, but if call the phone on the internal number from internal phone , it gives fast busy tone.


Please help, and let me know how can setup the CFD only on the external number.


ARIF

Paolo Bevilacqua Fri, 02/27/2009 - 04:14

Which exact IOS are you using ? Maybe there is a bug that prevents "no forward local calls" to work as supposed.


However, you can configure a workaround:

Create an additional ephone-dn with the external number only and associate to another button on phone, also remove external number from primary-dn.

To CFA calls to the external number, press line button corresponding to external number, then press call forward softkey and enter number.


syedarif25 Fri, 02/27/2009 - 06:31

Hi,


I am running ios Version 12.4(20)T.


Good work around, in my case i have the second line occupied with the a shared line, so i can not configure the secondary phone the way you have mentioned.


Any other work around will help me ?


ARIF

Paolo Bevilacqua Fri, 02/27/2009 - 08:29

You can try 12.4(20)T2, configure the shared lin in overlay on the first button, or use a six buttons phone.

Actions

This Discussion