Reverse telnet to Cisco router async serial port unstable

Answered Question
Feb 20th, 2009

I have a 3640 Cisco router that is connected to an EF Johnson communication device's console port. The router is connected using a serial port (NM-4A/S) and Cisco RS232 serial cable.

I have configured the router's serial port to async mode (physical-layer async) and set the async line to -

transport input telnet

transport output telnet

speed 2400

stopbits 1

Using the configuration above, I manage to reverse telnet to the serial port and access to the EF Johnson's console port login prompt. I could perform some basic functions once login but when I tried to perform a file upload (into the EF Johnson device), it failed halfway.

The file uploading works fine if I connect to the EF Johnson device through a modem dial-up line. I connect a modem to the device and another modem to my PC. From my PC, I initiates a dial-up to the EF Johnson modem and logs in. The modem connection is established using 9600bps, 8 databits, 1 stopbit and no parity.

Need all the help I can get.

Thank you.

I have this problem too.
0 votes
Correct Answer by Paolo Bevilacqua about 7 years 9 months ago

That is what I was indicating you before.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
pllim Fri, 02/20/2009 - 07:35

I am assuming the port base number is the port number used with the reverse telnet. I have tried with ports 2001 (2610 router) and 2097 (3640 router).

Not sure what is the flow control used by the device. The device is very old (more than 15 years). I am using a DOS based software called TCOMM or TBASE to perform the modem dial-up connection to the device. I can probably try to use hyperterminal with different flow control and dial into the device to see which one works well.

Paolo Bevilacqua Fri, 02/20/2009 - 07:41

Raw telnet base port (2000) it's ok.

Just try hw of sw flowcontrol under line and you should be ok.

Also, what do you mean by upload, just pasting a large chunk of text into telnet client ?

pllim Fri, 02/20/2009 - 07:57

When I login to the device console port, either through a modem dial-up or a reverse telnet (without modem), I can perform an upload of a data (text) file into the device. There is an option on the device that prompts for the location of the file.

The data file is stored in my PC.

Paolo Bevilacqua Fri, 02/20/2009 - 08:05

So it's just a text upload, not an async file transfer protocol. Should work fine once you set flow control.

pllim Fri, 02/20/2009 - 20:01

I made a mistake. The file is not a text file. Its a binary file.

I noticed that when I start the file upload process, the device displays that it is using xmodem protocol.

I have tried both flowcontrol (software and hardware) and the same problem appears.

Paolo Bevilacqua Sat, 02/21/2009 - 02:44

Are you selecting xmodem with your terminal program ? For example, with Hyperterminal that is done with the Transfer menu.

pllim Sun, 02/22/2009 - 01:11

The xmodem protocol is not selected using my terminal program.

A message 'xmodem protocol' is display when I select the EF Johnson device's Upload Option (after logging in).

The Upload Option then prompts for a file to be uploaded. I will enter the name of the data file and press Enter to continue.

I don't think I will be able to use Hyperterminal since the Upload Option is expecting a file name input using the keyboard.

Any other ideas?

Paolo Bevilacqua Sun, 02/22/2009 - 02:15

Hi,

likely the terminal program you're using has automatic transfer start. Try hyperterminal, after you enter the filename in device menu, start xmodem (you will have to select the file again), using the Transfer Menu.

pllim Sun, 02/22/2009 - 03:51

I don't think the terminal program (TCOMM software) is using automatic transfer start.

The TCOMM program can perform file upload using xmodem when EF Johnson device is connected to PC through modems. TCOMM is running on the PC.

However, when the EF Johnson device is connected to router serial port, and PC is connected to the router console port,

the TCOMM software fails to upload file.

Not sure if the hyperterminal method will work. Will try it out.

I was thinking of trying to use the "escapable" 8-bit mode by using the TCP port 4000 + n. Do you think this will help?

Paolo Bevilacqua Sun, 02/22/2009 - 04:08

My suggestion to use hyperterminal it's because it lets you use telnet directly from the PC, eliminating the need of having a async connection in the PC.

If you don't execute anything on TCOMM after entering the filename in remote system, it has autostart. I don't know however how do you select the local filename,

In any case you should actually try a base port of 4000 or 6000 for binary transfer, I had forgot that. www.cisco.com/en/US/docs/ios/12_3t/dial/command/reference/dia_p1gt.html table 19.

pllim Sun, 02/22/2009 - 22:01

Ok, I have tried to use hyperterminal but still doesn't work. Here's what I have done.

1. Connect PC (IP 10.80.1.1) to router Ethernet0/0 (IP 10.80.1.2)

2. From PC, hyperterminal using TCP/IP to 10.80.1.2 using port 23.

3. Login to the router.

4. Telnet using loopback address 20.1.1.1 and port 2001.

5. Login to EF Johnson device.

6. Select File Upload option.

7. Select hyperterminal file transfer option with xmodem as the protocol.

8. File transfer process starts but stops at packet number 4. It looks like it stops sending. After about a minute, the file transfer window disappears. Any idea what happen?

When TCOMM File Upload option is selected, I need to press the PageUp key on the keyboard. I found out the PageUp key is meant to start an xmodem file transfer process. It prompts for a file when the PageUp key is pressed.

pllim Sun, 02/22/2009 - 22:39

I think I got it working now. Still use hyperterminal. Here's the steps.

1. Connect PC (IP 10.80.1.1) to router Ethernet0/0 (IP 10.80.1.2)

2. From PC, hyperterminal using TCP/IP to 10.80.1.2 using port 2001.

3. Login to EF Johnson device.

4. Select File Upload option.

5. Select hyperterminal file transfer option with xmodem as the protocol.

6. File transfer completes successfully.

Actions

This Discussion