topology services map lms 2.6

Unanswered Question
Feb 20th, 2009

there are few devices on topology services do not have any link with their neighbor how ever when I go device center LMS detected and display there cdp neighbor. what's the reason those device sitting without link(neighbor) on topology services. thanks in advance.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Joe Clarke Fri, 02/20/2009 - 21:27

Is the neighbor also managed by Campus Manager, and showing up on the map?

eliaspaulos Mon, 02/23/2009 - 06:50

yes, the neighbor is on campus manager and showing up on the map connecting with rest of devices.

Joe Clarke Mon, 02/23/2009 - 09:42

Does the neighbor show the proper CDP neighbors in Device Center? This could be a case where CDP only shows correctly on one end of the link.

eliaspaulos Mon, 02/23/2009 - 10:39

yes, both sides showing the proper neighbor correctly on device center.showing switch "A" neighbor for router "B" also router "B" showing switch "a" as neighbor on device center. actually these switch have more than 6 other neighbor all showing correctly on device center. only on topology services sitting without any connection.

Joe Clarke Mon, 02/23/2009 - 11:36

Depending on whether or not this was an upgrade, and when you last reinitialized the ANI database, this may be a problem left over from a previous version. If you've reinitialized your ANI database since installing 4.0.11, then you're probably safe there, and should open a TAC service request so they can do some log file analysis. I won't be able to look at any logs in detail until next week.

If you haven't reinitialized your ANI database since upgrading to 4.0.11, you might consider doing that, then running a new Data Collection to see if the links appear. To reinitialize the ANI database, run:

NMSROOT/bin/perl NMSROOT/bin/ dsn=ani dmprefix=ANI

eliaspaulos Mon, 02/23/2009 - 12:22

thank you so much Joe, yes my database re-initialized 2 month after CM upgrade. I am going to open TAC case as your suggestion.

KAROLY KOHEGYI Tue, 02/16/2010 - 06:04


I got same problem with layer 2 topology map and do not want to reinitialize the ani database.

The redraw the full map is unfriendly process considering that it has more 500 devices.

does the TAC give any solution for the missing link problem.



This Discussion