Routing Question

Unanswered Question
Feb 20th, 2009
User Badges:

I am working in Netsim, and have 4 routers. I am trying to get RIP working.


Router 1= corp router = s0/0 10.1.1.1, s0/1 10.1.2.1, s0/2 10.1.3.1

Router 2= branch router s0/0 10.1.1.2, e1/0 10.1.5.1, e1/1 10.1.6.1

Router 3= branch router s0/0 10.1.2.2, e1/0 10.1.7.1, e1/1 10.1.8.1

Router 4= branch router s0/0 10.1.3.2


I used the following commands on all routers:


rip router

network 10.0.0.0


When I do a sh ip route...no rip routes.


Below are two excerpts:


Corp router:

interface Serial0/0

ip address 10.1.1.1 255.255.255.0

no ip directed-broadcast

clock rate 64000

!

interface Serial0/1

ip address 10.1.2.1 255.255.255.0

no ip directed-broadcast

clock rate 64000


!

router rip

network 10.0.0.0


Gateway of last resort is not set


10.0.0.0/24 is subnetted, 4 subnets

C 10.1.1.0 is directly connected, Serial0/0

C 10.1.4.0 is directly connected, Serial0/3

C 10.1.2.0 is directly connected, Serial0/1

C 10.1.3.0 is directly connected, Serial0/2


Branch router1:


interface Serial0/0

ip address 10.1.1.2 255.255.255.0

no ip directed-broadcast

!


!

interface Ethernet1/0

ip address 10.1.5.1 255.255.255.0

no ip directed-broadcast

!

interface Ethernet1/1

ip address 10.1.6.1 255.255.255.0

no ip directed-broadcast


router rip

network 10.0.0.0


10.0.0.0/24 is subnetted, 4 subnets

C 10.1.5.0 is directly connected, Ethernet1/0

C 10.1.6.0 is directly connected, Ethernet1/1

C 10.1.1.0 is directly connected, Serial0/0

C 10.1.4.0 is directly connected, Serial0/1




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Edison Ortiz Fri, 02/20/2009 - 13:26
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

You are experiencing the split-horizon rule.


All the subnets you mentioned are the same in their classful nature so the router won't accept advertisement it already knows about.


If you can fix this problem by going with version 2 under RIP and enable no auto-summary


__


Edison.

CriscoSystems Fri, 02/20/2009 - 13:26
User Badges:
  • Bronze, 100 points or more

You need to configure "version 2" in router configuration mode.


RIP version 1 doesn't support variable-length subnet masking. The RIP process on each of your routers is therefore only reporting network 10.0.0.0. Since each router already has this network, with a)longer masks/prefixes and b)lower administrative distance (directly connected vs RIP); they won't place any of RIP's info into their routing tables.


Set each one up for RIPv2 and you should be in better shape.


(please remember to rate helpful posts)


Richard Burts Fri, 02/20/2009 - 13:57
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Edison


I do not see how you analyze this as a split horizon issue. In the original post it is pretty clear that the Branch router is connected via its serial to the Corp router. And the Branch router has 2 subnets on its Ethernet interfaces that match the RIP network statement. So how does split horizon prevent the Branch from advertising its Ethernet subnets over the serial interface?


Seth


How do you analyze this as a variable length subnet issue. In the original post it is pretty clear that all subnets are 255.255.255.0. All are the same length and not variable.


I am not clear what the problem is, but I do not believe that it is either split horizon or VLSM.


I would like to see a more complete configuration of these router to try to identify what the issue is. I would also like to see the output of show cdp neighbor detail to verify that the routers are connected as the original post suggests that they are. And the output of show ip protocol would also be helpful.


HTH


Rick

CriscoSystems Fri, 02/20/2009 - 14:07
User Badges:
  • Bronze, 100 points or more

Hmmm, yes I suppose they are all 24-bit masks. I shoulda looked more closely at the configs.


But you are right, we need more info on the configs as well as on the layer 2 state of things.


oneirishpollack Fri, 02/20/2009 - 14:42
User Badges:

Ok guys, here is the config from the Corp router and one of the branch routers. You are correct there is two subnets off the branch router (10.1.5.0/24, 10.1.6.0/24).


Please note this is in Netsim.


************************

Corp router

**********************

corprouter#sh run

Building configuration...


!

Version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname corprouter

!

!

!

!

ip subnet-zero

!

!

!

!

!

!

!

!

!

interface Serial0/0

ip address 10.1.1.1 255.255.255.0

no ip directed-broadcast

clock rate 64000

!

interface Serial0/1

ip address 10.1.2.1 255.255.255.0

no ip directed-broadcast

clock rate 64000

!

interface Serial0/2

ip address 10.1.3.1 255.255.255.0

no ip directed-broadcast

clock rate 64000

!

interface Serial0/3

ip address 10.1.4.1 255.255.255.0

no ip directed-broadcast

clock rate 64000

!

interface Ethernet1/0

no ip address

no ip directed-broadcast

shutdown

!

interface Ethernet1/1

no ip address

no ip directed-broadcast

shutdown

!

interface Ethernet1/2

no ip address

no ip directed-broadcast

shutdown

!

interface Ethernet1/3

no ip address

no ip directed-broadcast

shutdown

!

!

router rip

network 10.0.0.0

!

!

!

ip classless

no ip http server

!

!

!

!

!

line con 0

transport input none

line aux 0

line vty 0 4

!

no scheduler allocate

end


*********************

BRANCH ROUTER

*********************


Router#SH RUN

Building configuration...


!

Version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

!

!

!

ip subnet-zero

!

!

!

!

!

!

!

!

!

interface Serial0/0

ip address 10.1.1.2 255.255.255.0

no ip directed-broadcast

!

interface Serial0/1

ip address 10.1.4.2 255.255.255.0

no ip directed-broadcast

!

interface Serial0/2

no ip address

no ip directed-broadcast

shutdown

!

interface Serial0/3

no ip address

no ip directed-broadcast

shutdown

!

interface Ethernet1/0

ip address 10.1.5.1 255.255.255.0

no ip directed-broadcast

!

interface Ethernet1/1

ip address 10.1.6.1 255.255.255.0

no ip directed-broadcast

!

interface Ethernet1/2

no ip address

no ip directed-broadcast

shutdown

!

interface Ethernet1/3

no ip address

no ip directed-broadcast

shutdown

!

!

router rip

network 10.0.0.0

!

!

!

ip classless

no ip http server

!

!

!

!

!

line con 0

transport input none

line aux 0

line vty 0 4

!

no scheduler allocate

end


________________________________

From the Corp router I can ping:

10.1.1.2


From the branch router I can ping:

10.1.1.1

10.1.5.1

10.1.6.1

10.1.5.11 (one of the PC's)

________________________


******************

CORP ROUTER

******************


corprouter#SH IP ROUTE

Gateway of last resort is not set


10.0.0.0/24 is subnetted, 4 subnets

C 10.1.1.0 is directly connected, Serial0/0

C 10.1.4.0 is directly connected, Serial0/3

C 10.1.2.0 is directly connected, Serial0/1

C 10.1.3.0 is directly connected, Serial0/2


**********************

BRANCH ROUTER

**********************


Router#sh ip route


Gateway of last resort is not set


10.0.0.0/24 is subnetted, 4 subnets

C 10.1.5.0 is directly connected, Ethernet1/0

C 10.1.6.0 is directly connected, Ethernet1/1

C 10.1.1.0 is directly connected, Serial0/0

C 10.1.4.0 is directly connected, Serial0/1






CriscoSystems Fri, 02/20/2009 - 17:56
User Badges:
  • Bronze, 100 points or more

But from the corp router you can't ping 10.1.2.1 or 10.1.3.1?


So far you've only verified layer 2 connectivity to Router 2. What about the other branch routers?


Can you give us the output of "show ip rip database" on the corp router?


oneirishpollack Fri, 02/20/2009 - 18:29
User Badges:

Yes. I can ping all the branch routers from the corp router.


I cannot however ping any networks connected via the branch routers.


"sh ip rip database" is not available in netsim.


If I add a static route to 10.1.5.1 on the corp router. They are able to ping each other.






Richard Burts Fri, 02/20/2009 - 18:34
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

The configs as posted look ok and I would expect RIP to be advertising the subnets. If the route tables are not showing that I wonder if there is some aspect of netsim that we are encountering. Perhaps the output of show ip interface brief and the output of show ip protocol might shed some light on this.


HTH


Rick

oneirishpollack Fri, 02/20/2009 - 20:57
User Badges:

Here is the output. - Thanks for your help.


**************

Corp Router

**************


Interface IP-Address OK? Method Status Protocol

Serial0/0 10.1.1.1 YES unset up up

Serial0/1 10.1.2.1 YES unset up up

Serial0/2 10.1.3.1 YES unset up up

Serial0/3 10.1.4.1 YES unset up up

Ethernet1/0 unassigned YES unset administratively down down

Ethernet1/1 unassigned YES unset administratively down down

Ethernet1/2 unassigned YES unset administratively down down

Ethernet1/3 unassigned YES unset administratively down down


Routing Protocol is "rip"

Sending updates every 30 seconds, next due in 28 seconds

Invalid after 180 seconds, hold down 180, flushed after 240

Outgoing update filter list for all interfaces is

Incoming update filter list for all interfaces is

Redistributing: rip

Default version control: send version 1, receive any version

Interface Send Recv Key-chain

Serial0/0 1 1 2

Serial0/1 1 1 2

Serial0/2 1 1 2

Serial0/3 1 1 2

Routing for Networks:

10.0.0.0

Routing Information Sources:

10.1.2.2 120 00:00:03

10.1.1.2 120 00:00:015

Distance: (default is 120)


***************

Branch Router

***************


Router#sh ip int brief

Interface IP-Address OK? Method Status Protocol

Serial0/0 10.1.2.2 YES unset up up

Serial0/1 unassigned YES unset administratively down down

Serial0/2 unassigned YES unset administratively down down

Serial0/3 unassigned YES unset administratively down down

Ethernet1/0 10.1.7.1 YES unset up up

Ethernet1/1 10.1.8.1 YES unset up up

Ethernet1/2 unassigned YES unset administratively down down

Ethernet1/3 unassigned YES unset administratively down down


Router#sh ip protocol

Routing Protocol is "rip"

Sending updates every 30 seconds, next due in 29 seconds

Invalid after 180 seconds, hold down 180, flushed after 240

Outgoing update filter list for all interfaces is

Incoming update filter list for all interfaces is

Redistributing: rip

Default version control: send version 1, receive any version

Interface Send Recv Key-chain

Serial0/0 1 1 2

Ethernet1/0 1 1 2

Ethernet1/1 1 1 2

Routing for Networks:

10.0.0.0

Routing Information Sources:

10.1.2.1 120 00:00:06

Distance: (default is 120)


johnlloyd_13 Fri, 02/20/2009 - 21:46
User Badges:
  • Blue, 1500 points or more

could you try to issue the no auto-summary command under the rip process on each router?


router(config)#router rip

router(config-router)#no auto-summary


by default, rip will summarize networks to its classful boundary. in your config, the 10.0.0.0 network would be advertised using a subnet mask of 255.0.0.0. this goes against your config on each router interface which has a subnet mask of 255.255.255.0. give it a try.

CriscoSystems Sat, 02/21/2009 - 10:52
User Badges:
  • Bronze, 100 points or more

John, I also thought that was the problem, till rburts pointed out that all routers have the same subnet mask. RIPv1 effectively supports a non-classful mask as long as the mask is the same length on all interfaces.


I recreated the op's issue in my lab, with actual 2500 routers, and the 24-bit Ethernet subnets (loopbacks in my lab) were reported to a RIP neighbor, over a separate point-to-point link, just fine. I confirmed both routers were running RIP verion 1.


So it really does look more like a netsim issue than a configuration one.


Richard Burts Sat, 02/21/2009 - 08:21
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Thanks for the additional information. I do not see anything in it that really points to what the problem is. I do see something that I believe is significant. From the output of show ip protocol from the Corp router:

Routing Information Sources:

10.1.2.2 120 00:00:03

10.1.1.2 120 00:00:015

This indicates that it has received a RIP update from the branch router at 10.1.1.2. If it has received a RIP update then why are there no RIP routes in its routing table?


I do note that the branch router does not report receiving a RIP update from the Corp router.


I am not familiar with netsim and how it deals with certain aspects of routing but I am coming to feel that we are dealing with some problem in netsim rather than a problem with the config.


HTH


Rick

oneirishpollack Sat, 02/21/2009 - 13:35
User Badges:

Thanks for verifying that. I didn't see anything wrong based on my limited knowledge, but wanted to double-check with some of you pros.


This site is just incredible.


Thanks again for all of your time and effort.


K

Actions

This Discussion