Callback scenario - agent not hearing "callback initiate" prompt

Unanswered Question
Feb 22nd, 2009

Hello. Please see attached scripts.

these scripts work together to facilitate callback handling.

By using session mapping, the two are linked by :

callback.aef - Menu step that plays prompt ("Enter 1 for callback") repeatedly until agent is available. (This is what the agent should hear when selected and presented call)

callbackQueuing.aef - Queueing retrieves Session data and sets Enterprise data for agent selected by Select Resource step.

The problem that I am experiencing is that if the agent answers too soon, the agent does not hear the prompt. But if the agent waits for the 3rd ring, the prompt is heard, 1 can be pressed to initiate callback.

If have tried several things and was hoping to receive suggestions on what to try. The problem does not seem to be correctable before an agent is selected. I have added delay steps in various places to determine this. The problem seems to be a session mapping of some kind. I have tried to have the Select reource step NOT connect once an agent is selected, add a delay and then connect, but no difference is observed. the agent must still wait before third ring for things to sync.

Thanks,

Eddie

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
avassi003 Thu, 03/05/2009 - 21:48

Hello,

I stumbled on your post and probably you got it working by now, but here's my 2 cents anyway. Try using the Get Digit String step, right after the WAIT FOR DIGIT label, and populate a new String variable (e.g. anyKey)

Get Digit String Properties:

General Tab: contact_OutcallToCSQ result Digit String anyKey

Prompt: play any stand by music file prompt

Filter: Change the Input Length to 1 and choose None for Terminating and Cancel Digits

Move your Menu (contact_OutcallToCSQ,p_InitiateCallBack step under the successful branch of the Get Digit String.

For the Timeout and Unsuccessful braches of the Get Digit String Go To WAIT FOR DIGIT label

I didn't have time to test, but anyway let me know how you got around this since it's an interesting question I try and play around with it more. Thanks.

edguidry Fri, 03/06/2009 - 10:26

Thanks for the feedback.

This turned out to be caused by Multicast MOH. Not only was it causing this delay but it was also preventing at time a Queued Callback from being taken off of Hold. I just disabled Multicast MOH last night and it immediately corrected these problems.

Eddie

edguidry Fri, 03/06/2009 - 10:28

Also, regarding the Unable to Unhold queued call issue, you must set the Agent line configuration and the CTI ports to 2/1 for the Max Calls/Busy Trigger. Otherwise, you will have this intermittent issue.

Actions

This Discussion