Presence not coming...Plz help

Unanswered Question
Feb 22nd, 2009

The error is Presence:Failed to connect,invalid credentials

The screenshot is attached herewith

Please suggest some troubleshooting steps

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Tommer Catlin Tue, 02/24/2009 - 13:48

Make sure you have everything configured correctly.

What do your troubleshooter say on the server, any issues there such as the SIP Publish, CTIgw, etc?

What version CUPS are you on?

On CUCM, did you associated the Line Appearance to the user name? Device with username, SUBSCRIBE CSS configured on User and Device?

Application users configured correctly?

Nicolas Mansour Mon, 03/02/2009 - 12:42

Here are the steps to create a user:


Got to “System”->”Licensing”->”Capabilities Assignment(s)”

Search for User XXX(example)

Enable CUP and CUPC and than save


Device-> phone or Device settings-> Device Profile( for Extension mobility)

Search for Phone XXX and Enter Directory Number

Scroll down and click on Associated End Users.. Select User XXX and then Add Selected


Device->Phone -> Add New … Choose phone type Cisco Unified Personal Communication and then Next

Device name: UPC+”USERNAME” in our example UPCXXX

Device Security profile and Media Resource Group list we select the appropriate

SIP profile: Standard SIP Profile


Then Click on Add a New DN( directory number)

Directory number-> Enter User XXX's DN

Scroll down….Associate End users


User Management -> End users

Device Associations-> Controlled Devices-> Device Association

Primary extension

Permissions Information : Add to user group: Select Standard CTI enabled

If you still have problems after these steps, do tell... (I've suffered enough with CUP to know how it feels ;) )

Eldho E Kuriakose Mon, 03/02/2009 - 12:46

thaks for your reply

The presence is now comming...but i can only message to the other user..When I double click the call is not going

ie in presence the phone no: is not there...I am not integrated presence with LDAP

Any idea???

Tommer Catlin Mon, 03/02/2009 - 17:56

Did you add in the phone's mac address to the CTiGW application account to control this phone? Also, is the user you logged in with have CTI Enabled for security?

gogasca Tue, 03/03/2009 - 00:25

thats the problem, phone will not be displayed unless u integrate cups with ldap. cupc doesnt have a way to obtain info from user, normal dialing should work though (using dialpad)

Eldho E Kuriakose Tue, 03/03/2009 - 11:54

Can I integrate it with callmanger LDAP

Callmanager userdatabase is also LDAP right??

Is there any way...

Tommer Catlin Tue, 03/03/2009 - 14:03

It is not LDAP compliant. Basically, you should be able to use Remote Call Control with CUPC, but you will not see presence of other users. The reason being is that CUPS needs to have a common LDAP directory for lookup and reference. Also, do not add your account to the "Buddy List" it will only cause you issues.


This Discussion