Firmware problem on MCS-7835-I2 after CUCM7.0(2) Upgrade

Unanswered Question
Feb 23rd, 2009


I have upgraded from CUCM7.0(1) to 7.0(2) on an IBM x3650 server (equivalent to the MCS-7835-I2).

The upgrade installed ok but when I booted to the new version the server failed with the message below:

The following failure is presented after flashing the ServeRAID 8K controller firmware version 15411, or below, followed by a system reboot after the expected ServeRAID code has been installed:

Adaptec RAID BIOS V5.2-0 [Build 15411] (c) 1998-2006 Adaptec, Inc. All Rights Reserved.

<<< Press <Ctrl><A> for IBM ServeRAID Configuration Utility! >>>

Waiting for Controller to Start....Controller not started Controller #00 : IBM ServeRAID 8k-l at PCI Bus :04, Dev :00, Func :00

Waiting for Controller to Start....Controller not started TBBU is in recovery mode but version are not matching.

The current version is B1542 but we need B1541 to recover the tbbu.

Please update to version B1541 and reboot the system.

I am trying to get the B1541 firmware from IBM (5 days and counting) but would be interested if anyone else has seen this problem.

I did not use the FWUCD-2.1.1-I.iso CD to upgrade the server firmware before I installed the 7.0(2) upgrade. I guess this might be where I went wrong?

Does anyone know how to recover from this situation? I cannot boot from the Cisco server firmware CD as the CD drive is inoperable.

I am hoping to get the B1541 firmware from IBM which should hopefully get the ServeRAID controller and CD working. I will then try applying the firmware updates from the Cisco firmware CD.

Any advice would be welcome.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
James Hawkins Mon, 02/23/2009 - 03:54

Hi David,

Thanks for the reply.

I have tried reflashing the RAID adapter with Firmware 15421 as suggested but just get the same message as contained in my original post.

I also tried Firmware 15420 which was included on the CD supplied with the server but get a similar message stating:

The current version is B1540 but we need B1541 to recover the tbbu.

wiluszm Fri, 05/08/2009 - 05:21

Did you ever get a fix for this? Our publisher did this last night and now won't boot.

James Hawkins Fri, 05/08/2009 - 06:43


I logged a TAC case and the recommended fix was to boot from the System Recovery disk and use the tool on there to force the server to switch partitions. I did it and it worked - hope it works for you too.


This Discussion