Problems with WRVS4400N V1.1.03

Unanswered Question
Feb 23rd, 2009

Hi all,

Just experiencing a problem with the WRVS4400N, which I see several others have also encountered, as posted on the Linksys support site.

Wireless LAN users become unable to connect to anything through the router, i.e. no conectivity to either LAN ports or the WAN port. The wireless LAN itself appears to be up, and I have good signal, but cannot ping or make other connections to devices on other ports.

Is there any solution to this?

Many thanks in advance!


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)


This is a known issue and was reported to Linksys as far back as October 2007.

Essentially the root cause of the problem is that DHCP does not work for wireless clients if there are no LAN clients.

So there are 2 ways to workaround the problem.

1.     Plug a client into the LAN port.  This turns on DHCP for the wireless clients and all should be OK.

2.     Give your wireless clients fixed IP addresses in the range of the router subnet default 192.168.1.x

Hope this helps.


plawer123 Fri, 03/27/2009 - 17:14

I've tried the new 1.1.13 firmware on my router, but have downgraded to my previous firmware. With 1.1.13 I get a DNS error when visiting something like in my browser. Doing a lookup returns an IP, so it seems like something in the router is filtering the web content in a way it shouldn't.

noziwatele Mon, 03/30/2009 - 21:03


I've also upgraded using this new firmware, but the WLAN problem still occurs!

Please let me know if there is any diagnostic information that I can supply to help resolve this problem.



Hello all,

I have made the update to firmware 1.1.13 and now I do have serious problems with my WLAN-Clients.

Simple things like DNS-Resolving is not working anymore :(

The firewall was temporary disabled but still no resolving form my WLAN-Clients. From LAN Clients I did not have these problemes.

I think I have to downgrade the firmware again but I am not sure if downgrade is supported or not.

Is there a timeframe, when the next firmware will be released?

Can I simply flash to the old firmware again?

I know my VPN-Clients will not work with firmware 1.1.03 but I only have the choice between two problems!

Hopfully there will be a solution soon.



ntarazi Thu, 04/02/2009 - 12:21
In order for  the new firmware to take full effect on the new features and the bug fixes ,you need  to do a complete reset by holding in the reset button on the back of the router for 10-15 seconds, or  by using the Restore Factory default settings button within the Administration  section of the WebGUI.  This new firmware does fix a lot of issues and one off them is the DHCP  over WLAN issue. Please see release note for full  details.

Thanks for your response ntarazi.

I have done some more testing. It is working fine when I disable the IPS-Feature.My WLAN-Clients can connect without any limitations to the internet so far.

That leaves me a little bit confused.

I thought IPS will protect my internal network from the external network.

Is WLAN some kind of external network in the default configuration of firmware 1.1.13?

IPS was always active with firmware 1.1.08 and IPS-definition 1.33. I tested firmware 1.1.13 with IPS-definition 1.33, 1.38 (included in fw 1.1.13) and 1.40. everytime the same problem. To disable IPS is the only way to get things working.

Ofcourse this is a lack of security for me, so I would like to have IPS up and running together with my WLAN-Clients.

Any Ideas???



ntarazi Tue, 04/07/2009 - 13:32

Please contact  escalation support team to get help with troubleshooting this  issue.
If the NAT on the ADSL modem has been disabled then  there should have no problem accessing the  remote LAN.
It's very  difficult to troubleshoot an issue like this on this forum

Thanks for your Support :-)

The Small Business Support gave me the following steps to go and until now everything is working.

1.) Reset the router to factory defaults with the button on the back of the router

2.) Flash the Firmware again

3.) Reset the router to factory defaults with the button on the back of the router

4.) Test network connectivity with the defaults

5.) Test network connectivity with own networksettings

This works now since 2009-04-07.

I hope these steps may help someone with similar problems.



plawer123 Thu, 04/09/2009 - 08:41

I tried to do the same as MadX, and so far so good.

The only extra thing I needed to do was to add forwarders in my BIND configuration. This wasn't neccessary with 1.1.08 or 1.1.03 for me.

Hi all,

after 2 days and 6h my squeezebox lost the connection again :(

same procedure:

- internal communication works fine

- external communication works not

I just saved the IPS settings (without changes!) and instantly the connection was there again.

Sadly I can't troubleshoot from the squeezebox and there are no logfiles from this device


I think the supportteam can't really do troubleshooting without more information from the device :(



noziwatele Tue, 06/23/2009 - 23:15

Hi all,

Any news on this problem? I'm still on 1.1.13 and the wireless problem still occurs. I'm now the only wireless user in the office, everyone else has gone back to cables.. But I experience this problem frequently. Disconnecting the wireless LAN (from the client) and reconnecting usually resolves the problem temporarily.

Using the same client at home, with a Linksys WRT54GL I have never experienced this issue.



Te-Kai Liu Wed, 06/24/2009 - 04:06

>But I experience this problem frequently. Disconnecting the wireless LAN (from the client) and reconnecting usually resolves the problem temporarily.

What client card are you using? Do you have the latest driver for the client card?

noziwatele Thu, 07/09/2009 - 20:22

I'm using a recent model Macbook Pro with all drivers up-to-date. This problem has never occurred anywhere else. Using a Linksys WRT54G at home with no problem whatsoever.




This Discussion

Related Content