Prepend digit to missed Calls

Unanswered Question
Feb 23rd, 2009
User Badges:

Hi,


My carrier is sending me numbers without the leading area code digits.

This is causing issues when I dial out & also when I use applications like Callconnector etc


How do I ensure that all my missed calls have the full number including area code.


Thanks

Luke

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Harper Tue, 02/24/2009 - 01:43
User Badges:
  • Cisco Employee,

Well, if the carrier is really sending you all calls without the area code, then there is nothing you can do.  How do you distinguish between calls coming from the same phone number in different states (We are talking about the calling number here, aren't we)?


However, this does seem a bit unlikely.  It seems more likely that the carrier is not presenting the full number when the calling number's area code matches your area code.  If so, then we can create or modify a translation rule to cover this situation if necessary.


Can you confirm whether this behaviour occurs on *all* calls, or just those from the same area code?


Cheers,

Dave.

luklambe Tue, 02/24/2009 - 14:43
User Badges:

Thanks Mysterious Stranger.


I'm looking for the leading 0 on the area code / mobile number.

I can do this with a voice translation profile but looking to see if theres any CCA or easier way.


45778: .Feb 24 06:56:26.830: ISDN BR0/3/1 Q931: RX <- SETUP pd = 8 callref = 0x1F
    Sending Complete
    Bearer Capability i = 0x8090A3
        Standard = CCITT
        Transfer Capability = Speech 
        Transfer Mode = Circuit
        Transfer Rate = 64 kbit/s
    Channel ID i = 0x81
        Preferred, B1
    Calling Party Number i = 0x2181, '413000000'
        Plan:ISDN, Type:National
    Called Party Number i = 0xC1, '82380000'
        Plan:ISDN, Type:Subscriber(local)
    High Layer Compat i = 0x9181

Eivind Jonassen Tue, 02/24/2009 - 16:37
User Badges:
  • Silver, 250 points or more

Hi,


This feature is not supported in CCA (yet). You have to create a voice translation profile for incoming dial-peer.


Regards

Eivind

JOHN NIKOLATOS Wed, 02/25/2009 - 18:57
User Badges:
  • Bronze, 100 points or more

Luke - the call connector has it's own settings that may not be playing nicely here..  make sure your settings under your modem for local area codes and 10 digit dialing are all set.  Call Connector uses those settings and not the CME settings.   Like everyone else says here, you need to set up a Translation profile in CME for 10 digit dialing.   I have done this at a few install sites and it works well.  The UC500 is a very powerful unit, the only real way to configure it is using the CLI at this point.  The configuration assisant is helpful at the start and saves you a few hours of configurations but to really make this product shine you have to get your hands dirty with CLI.

luklambe Sun, 03/29/2009 - 22:47
User Badges:

FYI Mission Accomplished I have 0 added to the incoming calls.


Here is the config I used for reference

Note: Only add the lines in bold ... your dial peers should already exist.


Regards,

Luke







voice  translation profile ADD_ZERO
translate  calling 2345

voice  translation-rule 2345
rule  1 // /0\1/
 


dial-peer  voice 3000 pots

translation-profile  incoming ADD_ZERO

incoming  called-number 8640050[1-7]

direct-inward-dial

no  sip-register

no  digit-strip

port 0/1/0


dial-peer  voice 3001 pots

translation-profile  incoming ADD_ZERO

incoming  called-number 8640050[1-7]

direct-inward-dial

no  sip-register

no  digit-strip

port 0/1/1


dial-peer  voice 3002 pots

translation-profile  incoming ADD_ZERO

incoming  called-number 8640050[1-7]

direct-inward-dial

no  sip-register

no  digit-strip

port 0/3/0


dial-peer  voice 3003 pots

translation-profile  incoming ADD_ZERO

incoming  called-number 8640050[1-7]

direct-inward-dial

no  sip-register

no  digit-strip

port 0/3/1