Class Path

Unanswered Question
Feb 24th, 2009
User Badges:

I am developing a interface between the IVR and an application server. I created a custom class that uses proprietary files to communicate with the application server. That is working pretty well. I then added my custom class in UCCX, that worked well. My problem is that UCCX doesn't know where to look for the proprietary files (a jar file) so it's raising an error that the class isn't found. (In windows this is done using the environment variables CLASS PATH).

Where can we modify the default class path of the UCCX so that it points to that jar file?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
villarrealed Tue, 02/24/2009 - 09:10
User Badges:
  • Bronze, 100 points or more

I'll assume that you are using a 5.x or higher version of UCCX.


Upload the jar or class files to the classpath folder using the document management page of appadmin. You can then go to the custom file configuration section in appadmin and move the period(.) from Available to the Selected section.

Nicolas Mansour Tue, 02/24/2009 - 09:16
User Badges:

Hi there,

Thanks for the reply.

I already done that but in vain.

Could it be that the jar file was compiled with a JDK newer than the one used with UCCX?


sferland Tue, 02/24/2009 - 10:39
User Badges:
  • Bronze, 100 points or more

Yes, you need to be sure that the jar file you're using as been compiled to the one used in UCCX. (probably 1.4.2)


I ran into the same problem trying to use an Open Source library. I had to check back on the web site in order to download the 1.4 version.

Actions

This Discussion