UnityMsgStoreSvc & UnityAdmin accounts migrating from 2003 to 2007

Unanswered Question
Feb 24th, 2009

We are running Unity Unified Messaging 5.01 and our exchange group is in the process of migrating our environment from exchange 2003 to exchange 2007. Does anyone no of any issues with or precautions that should be taken when migrating the UnityMsgStoreSvc & UnityAdmin accounts?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
jasondrisc Tue, 05/05/2009 - 12:25

Hello, we have a lab environment setup with Unity 5/W2k3 with failover, original partner Exch 2003. Preparing for upgrade to Exch 2007 in production. I applied the latest ES and followed the procedure: Upgrading Exchange 2000 or 2003 to Exchange 2007 (Cisco Unity 5.x with Failover Configured).

Here's what I'm hung up on, I follow the steps on the primary and the steps procede to the letter. When I follow the steps on the secondary and run the msg store config wizard it does not pause at 'Step 15 On the Run Scripts on the Partner Exchange 2007...', instead the msg store config wizard continues and completes without error.

I performed multiple tests with subscribers in both Exch 03 and 07, all appears to be functioning as it should. I just want to make sure I didn't miss something and set myself up for disaster in the production environment.

I would appreciate any feedback on this.



Bradford Magnani Tue, 05/05/2009 - 12:44

If the wizard does not prompt you to run the script, then it already sees those accounts as existing.


Tommer Catlin Tue, 05/05/2009 - 14:03

on the secondary server it should not really pause because it sees that the service mailboxes have already been created on the Exchange 2007 server. Because you ran the script on Exchange 2007 *already* from the Primary wizard setup, there is no need to re-run the script after the failover is added.

make sense?

jasondrisc Tue, 05/05/2009 - 18:28

Hello and thank you for the feedback.

Your replies make sense and I understand what you're saying. Like I said, I wanted to make sure I wasn't missing something in the procedure or maybe misread something. The steps I mentioned are specifically under the secondary server section, so I was spinning my wheels a bit, figured better safe then sorry.



Tommer Catlin Tue, 02/24/2009 - 10:33

You actually do not have to move it yourself. If you install 2007, then re-run the Permissions wizard and the Message Store Wizard, the a "magic" Exchange 2007 script will appear on the desktop of Unity. Instructions are to copy this file to exchange execute the powershell script. This script will move the correct accounts to where they should be in 2007, etc. The actual accounts above, only need to be setup in Exchange 2007 as listed in the other posters link for setting up Exchange 2007 and Unity.

I would create a new test account on Exchange 2007 and verify it works with Unity 5.0. MWI, TUI, etc. Once this is done, you know Exchange 2007 and Unity 5.0 are working correctly.

Once you have this all done, you should be able migrate a Subscribes Mailbox from 2003 to 2007, then retest Unity.

Take precautions and follow the instructions. I would advise you backup you unity, patch unity and look for any ES that you may need. We have had Unity Servers in 5.0 get corrupted MAPI issues. (1 maybe 2 servers did) Some odd things can happen that TAC could not explain. Once the MAPI is bad, message delivery goes haywire, but unity seems to operate fine, MWIs are off, etc.

Good luck!


This Discussion