Lost ringtones after upgrading to new 7.0.2

Unanswered Question
Feb 24th, 2009

My customer lost all but two ringtones on the ip phones after we upgraded to 7.0.2. Any ideas of how to get all of the ringtones back to the ip phones?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
5lchaffin Tue, 02/24/2009 - 19:53

The ringtones and files are all on the flash and below is the config from the flash. Ring tones still will not show up even after reset of phones. I tried to drag and drop a new ringtone in to the CCA but it wodl not take a raw file for some reason?

tftp-server flash:/ringtones/Analog1.raw
tftp-server flash:/ringtones/Analog2.raw
tftp-server flash:/ringtones/AreYouThere.raw
tftp-server flash:/ringtones/AreYouThereF.raw
tftp-server flash:/ringtones/Bass.raw
tftp-server flash:/ringtones/CallBack.raw
tftp-server flash:/ringtones/Chime.raw
tftp-server flash:/ringtones/Classic1.raw
tftp-server flash:/ringtones/Classic2.raw
tftp-server flash:/ringtones/ClockShop.raw
tftp-server flash:/ringtones/DistinctiveRingList.xml
tftp-server flash:/ringtones/Drums1.raw
tftp-server flash:/ringtones/Drums2.raw
tftp-server flash:/ringtones/FilmScore.raw
tftp-server flash:/ringtones/HarpSynth.raw
tftp-server flash:/ringtones/Jamaica.raw
tftp-server flash:/ringtones/KotoEffect.raw
tftp-server flash:/ringtones/MusicBox.raw
tftp-server flash:/ringtones/Piano1.raw
tftp-server flash:/ringtones/Piano2.raw
tftp-server flash:/ringtones/Pop.raw
tftp-server flash:/ringtones/Pulse1.raw
tftp-server flash:/ringtones/Ring1.raw
tftp-server flash:/ringtones/Ring2.raw
tftp-server flash:/ringtones/Ring3.raw
tftp-server flash:/ringtones/Ring4.raw
tftp-server flash:/ringtones/Ring5.raw
tftp-server flash:/ringtones/Ring6.raw
tftp-server flash:/ringtones/Ring7.raw
tftp-server flash:/ringtones/RingList.xml
tftp-server flash:/ringtones/Sax1.raw
tftp-server flash:/ringtones/Sax2.raw
tftp-server flash:/ringtones/Vibe.raw
!
control-plane

5lchaffin Wed, 02/25/2009 - 10:28

all of the files are there on the flash, still not working. I tried to drag and drop files in the CCA just to put new ones on but said it would not allow that file type. It is the raw file type for the ring tones and xml for the file. Any other ideas?

Douglas Smith Wed, 02/25/2009 - 14:12

Larry,

Just to verify were both ring list files working before the upgrade to 7.0.2, and are you using CCA1.9? Finally can you send me a copy of your ringList.xml, DistinctiveRingList.xml files so I can see that the structure looks correct.

Regards,

Douglas Smith

5lchaffin Wed, 02/25/2009 - 16:19

This is what the customer just sent.

but still only seeing “Chirp1” and “Chirp2” as the available ringers.

JOHN NIKOLATOS Wed, 02/25/2009 - 18:43

Larry,

I would just perform the IOS upgrade again and just do the CME portion.  It will replace everything, TFTP the correct files up and replace them and also setup the correct XML files.

Did you try

"create CNF-files" command under the "telephony Service" portion of the CLI?

Then type "reset" under "telephony service" and it will reset all of the phones.

tell me if that works.

Eivind Jonassen Thu, 02/26/2009 - 12:03

Maybe I´m totally wrong, but have you tried tftp-server flash:/ringtones/Ring1.raw alias Ring1.raw ???

Regards

Eivind

Douglas Smith Thu, 02/26/2009 - 08:21

Larry,

I'm able to reproduce the problem and I'm working to find the resolution, I'll post as soon as possible.

Regards,

Douglas Smith

5lchaffin Thu, 02/26/2009 - 09:14

The customer is also having issues with the ip 7935 conf phone after the upgrade. After one call you cannot use the hold, transfer or any other button or function after anwserign the call. So they cannot make and conf calls with it. I have reset it, checked the load and version and they are right. So we have this issue also after the upgrade. Ther buttons are very hard to use when dialing also, if you take more than on second to hit a number while dialing it dials the number.

can you look at this issue with the 7936 also?

Douglas Smith Thu, 02/26/2009 - 11:16

Larry,

Regarding the problem your having with the 7935/36 phone buttons I see a similar post titled UC520 and Cisco 7937 Conference Phone is this a new problem or are you still working on the same issue? If its the same issue I'd like to add any new details to the original post.

In my lab I see the 7936 phone running load cmterm_7936.3-3-15-0.bin working with no trouble. Please verify the load your using by using the following commands

On the 7936 select the menu button -> scroll down to Admin setup -> hit select button on right -> enter passcode  **#  is default ->  system info -> App load ID

also you can verify the load on the UC using the below commands.

Verify the 7936 load is on flash  ( I was able to drag and drop this file using CCA)

UC520#dir *7936*

   41  -rw-     1763446  Dec 23 2008 11:51:40 -08:00  cmterm_7936.3-3-15-0.bin

Verify the tftp is set for the correct load

UC520#show run | include 7936
tftp-server flash:cmterm_7936.3-3-15-0.bin
load 7936 cmterm_7936.3-3-15-0
type 7936

Verify the load is downloaded when the 7936 is reset.

UC520#debug tftp packets

     Dont forget to  #undebug all   when finished!

The log will show something similar to this

Feb 26 20:04:00.714: %IPPHONE-6-REG_ALARM: 22:Name=SEP0004f2e3dd1e Load=cmterm_7936.3-3-15-0 Last=Reset-Reset


Regards,

Douglas Smith

5lchaffin Sat, 03/14/2009 - 05:43

I opened a Cisco tac case SR 610919031, the customer has issues when he call parks a call on the 7936. No call park number shows up, also he has an issue with transfer. If you transfer to a wrong number you get a busy signal. Then when you hit resume call it drop the call. You cannot bring the call back. The 7936 is running the latest code.

Hello Mr. Chaffin,

I just wanted to let you know that I already contacted the escalation point in order to consult this issue with them basically because everything on the debug seems to be normal. I recreate the issue on my lab and got the exact same result as the  original issue. As soon as they contact me back I'll get back to you.

Best regards.

Mario Abarca

Multi Voice Services

Cisco TAC Engineer

Marcos Hernandez Sat, 03/14/2009 - 09:37

Larry,

This is the way to proceed here. I was unable to find outstanding bugs for this issue. Maybe the TAC engineer will have better luck, or will create a new software defect to track your problem. I'll keep an eye on the case.

Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

Douglas Smith Thu, 02/26/2009 - 10:44

Larry,

In my investigation I have seen two cases where the RingList.xml file cannot be used and my phone shows only Chirp1 & Chirp 2 rings available. First RingList file is corrupt, after I went to the phone GUI  and selected (User Preferences -> Rings -> Line 1 default ring) there I see only the Chirp ring tones and a message that the RingList.xml file is bad. I used a tftp server, like tftp desktop or pumpkin, to manually tftp the RingList.xml and DistinctiveRingList.xml file to the UC520. Please be sure CCA is closed before you start the tftp server as CCA has its own tftp server and will interfere. The second case I found was using a customized RingList.xml where an error in the syntax created a problem and again only the Chirp ring tones were seen.

Please manually tftp the RingList.xml and DistinctiveRingList.xml files and reset the phones. I loaded the exact file you attached earlier with no problems so I expect this is the case where the file is corrupt in flash.

To see what files are being hit by tftp when the phone is reset or when attempting to change the ring tone run the command #debug tftp packets

Just dont forget to  #undebug all when your done.

you should see a log similar to this:

Feb 26 17:31:28.743: TFTP: Looking for ringlist.xml
Feb 26 17:31:28.855: TFTP: Opened flash:RingList.xml, fd 10, size 3001 for process 172

Regards,

Douglas Smith

5lchaffin Thu, 02/26/2009 - 12:02

in my post here I say that I am runnign the new uc520 pack with the new ios, yes I am having the issues even with the new version of software.

larry

Douglas Smith Fri, 02/27/2009 - 11:05

Eivind,

You are correct, the config was missing the alias on all the loads and the ringlists as well.

Thanks for your input,

Regards,

Douglas Smith

spollock Wed, 04/01/2009 - 21:30

I am unclear, did you get this to work?

What was your fix?

Douglas Smith Thu, 04/02/2009 - 08:56

Spollock,

We did get the ringtones to work by making the tftp-server lines look like the fllowing:  tftp-server flash:/ringtones/Ring1.raw alias Ring1.raw

Regards,

Douglas Smith

spollock Thu, 04/02/2009 - 19:20

Doug, many thanks fo course.

My config looks like this:

ftp-server flash:CP7902080001SCCP051117A.sbin

tftp-server flash:apps11.1-1-2-26.sbn

tftp-server flash:cnu11.3-1-2-26.sbn

tftp-server flash:cvm11sccp.8-0-2-25.sbn

tftp-server flash:dsp11.1-1-2-26.sbn

tftp-server flash:jar11sccp.8-0-2-25.sbn

tftp-server flash:SCCP11.8-0-3S.loads

tftp-server flash:term06.default.loads

tftp-server flash:term11.default.loads

tftp-server flash:S00104000100.sbn

tftp-server flash:cmterm_7936.3-3-5-0.bin

tftp-server flash:P0030702T023.loads

tftp-server flash:P0030702T023.sbn

tftp-server flash:P0030702T023.sb2

tftp-server flash:P0030702T023.bin

tftp-server flash:cmterm-7941-7961-sccp.7.0.3.tar

tftp-server flash:cnu41.2-7-6-26.sbn

tftp-server flash:CVM41.2-0-2-26.sbn

tftp-server flash:Jar41.2-9-2-26.sbn

tftp-server flash:TERM41.7-0-3-0S.loads

tftp-server flash:term41.default.loads

tftp-server flash:term61.default.loads

tftp-server flash:cnu70.2-7-6-26.sbn

tftp-server flash:CVM70.2-0-2-26.sbn

tftp-server flash:Jar70.2-9-2-26.sbn

tftp-server flash:TERM70.7-0-3-0S.loads

tftp-server flash:term70.default.loads

tftp-server flash:term71.default.loads

tftp-server flash:apps31.8-1-0-89.sbn

tftp-server flash:cnu31.8-1-0-89.sbn

tftp-server flash:cvm31sccp.8-1-0-90.sbn

tftp-server flash:dsp31.8-1-0-89.sbn

tftp-server flash:jar31sccp.8-1-0-90.sbn

tftp-server flash:SCCP31.8-1-1SR2S.loads

tftp-server flash:term31.default.loads

tftp-server flash:APPS-1.0.1.SBN

tftp-server flash:CP7921G-1.0.1.LOADS

tftp-server flash:GUI-1.0.1.SBN

tftp-server flash:SYS-1.0.1.SBN



Are you saying add an alias command for every line?

Also, none of the ringtones are listed.  Should I add the ringtone files, one per line as well?

what about the .XML files?

thanks again

Steven Smith Fri, 04/03/2009 - 07:44

The file locations on flash need to coordinate with what the phones are looking for.  If a phone is looking RingList.xml, and the file is in /phones/ringtones/RingList.xml, you will need to alias it.  The tftp server command says what file to serve, and the location of that file.  If the phone is expecting the file in a different location on flash, you alias it.

Also, all of your ringtones and the ring list file need to have tftp server commands.  That is likely your problem.  Upload a show run and a dir flash: (as attachments) and we can get this solved quickly.

Thanks

spollock Fri, 04/03/2009 - 17:43

show run and dir flash attached

Cowacella#more RingList.xml

       

                Analog 1

                Analog1.raw

       

       

                Bass

                Bass.raw

       

       

                Chime

                Chime.raw

       

       

                Jamaica

                Jamaica.raw

       

       

                Pop

                Pop.raw

       



Cowacella#more DistinctiveRingList.xml

       

                Analog 1

                Analog1.raw

       

       

                Bass

                Bass.raw

       

       

                Chime

                Chime.raw

       

       

                Jamaica

                Jamaica.raw

       

       

                Pop

                Pop.raw

       

Cowacella#



Attachment: 
Steven Smith Mon, 04/06/2009 - 07:54

You are missing several TFTP server commands.

tftp-server flash:RingList.xml

tftp-server flash:DistinctiveRingList.xml

You will also need similar commands for the .raw files.

tftp-server flash:Analog1.raw

tftp-server flash:Bass.raw

etc etc

That should fix your problem.

spollock Tue, 04/07/2009 - 15:01

Steve you say:

you are missing several TFTP server commands.

tftp-server flash:RingList.xml

tftp-server flash:DistinctiveRingList.xml

You will also need similar commands for the .raw files.

tftp-server flash:Analog1.raw

tftp-server flash:Bass.raw

etc etc

That should fix your problem.

=====================================
Does this mean that they also should be alias'd as well?
What about all the phone load files?  Do they need alias?
How about RingList.xml ?  alias?
tx


Steven Smith Wed, 04/08/2009 - 07:25

You would only need to alias if the files were located somewhere else on flash.

Say you have a phone load name called phoneload.sbin.  And you put it on your flash at flash:/phones/myphoneloads/phoneload.sbin.

When the phone looks for the file, it doesn't look in that directory, it just looks for the file on flash (flash:/phoneload.sbin).

In that case, you would use the alias command, because the phone is looking for the file in a different location.  It is only when the phone is looking for a file in a different location that you need to use the alias command.  For the case that I presented, here would be the tftp server command.

tftp-server flash:/phones/myphoneloads/phoneload.sbin alias phoneload.sbin

Actions

This Discussion