CUPS 6.0.5 Exchange 2007 calendar integration

Unanswered Question
Feb 24th, 2009

I have a customer with UCMBE 6.1.3 with CUPS 6.0.5 trying to connect to an Exchange 2007 server for calendar. Normal presence status information and IM is all working. The problem is with calendar status not appearing in the CUPC. The cert is installed and passes the troubleshooter.

The Exchange server is 2007 but is in mixed mode with 2003 due to a requirement for BES to work. I'm told FBA is disabled. I know I've read that 2007/2003 in mixed mode with FBA won't work, but I think 2007/2003 without FBA is supposed to work.

My user account can open other calendars and we've verified all the permissions from the Cisco documentation. Looking at trace logs it seems like CUPS is connecting to exchange but isn't seeing what it thinks it should.

Is the link Cisco provides in the older 2003 documentation (connecting to /exchange/user/calendar) supposed to work for 2007?

From what I understand in 2007 they've changed to /owa instead of /exchange, but /exchange is supposed to redirect to /owa for backwards compatibility. But /exchange for me isn't doing that.

There is something I'm missing here but am out of ideas at the moment.

Thanks,

Mike

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Tommer Catlin Tue, 02/24/2009 - 13:17

Are you sure CUPS/CUCM can resolve the name on the cert correctly? Open up CLI and ping the cert name. IE mail.exchange.com (or whatever the cert name is)

Michael Gross Tue, 02/24/2009 - 13:20

Thanks for the reply. Yes, both UCM and CUPS can ping the exchange server by name. I just tested again on both servers to verify the fact.

Tommer Catlin Tue, 02/24/2009 - 13:34

Did you change the server name in CUPS after install? Sometimes this screws up the server in the CERT sections.

Also, do you have the incoming/outgoing ACL set to all?

htluo Tue, 02/24/2009 - 15:11

To troubleshoot the problem, we need Presence Engine logs (in detailed). Try the following:

1) Set Presence Engine tracing to detailed.

2) Restart Presence Engine.

3) Log into CUPC

4) Get presence engine logs and upload here.

Michael

http://htluo.blogspot.com/

Michael Gross Tue, 02/24/2009 - 17:51

I did change the server name in server configuration after the install from just the hostname to the fqdn (cups.customerdomain.com). I don't think this is causing the problem, or at least I haven't seen indication of that in any logs.

Yes, I set incoming and outgoing ACL to all.

Attached are traces I gathered with Presence Engine trace set to detailed.

I ordered your book yesterday Michael. I'm looking forward to it. I like the blog too. Keep up the good work.

Thanks,

Mike

Attachment: 
htluo Wed, 02/25/2009 - 05:51
Michael Gross Wed, 02/25/2009 - 06:01

I did a mass replace on the trace files of the actual domain name to customerdomain.com to keep a little privacy. But es2.customerdomain.com is the name of the exchange 2007 server, not the name of the domain of the users.

Yes, I can modify the Mail ID field. I'm guessing that needs to match the exchange mail ID. The UCM is Business Edition so it's not sync'd with ldap. The CUPS is integrated with ldap. I have the user ID on UCM matching the AD/LDAP as is required.

I'll give that a shot and test.

Thanks!

Mike

htluo Wed, 02/25/2009 - 06:39

You don't have to modify the "Mail ID" field in CUCM. It should work by default.

I would recommend you disable/enable calendar from CUPC to refresh the configuration:

1) Go to CUPC > File > Preference > Status.

2) Uncheck "Show me as in a meeting". Save.

3) Exit and re-launch CUPC to make sure it was unchecked.

4) Make that option checked.

5) Exit and re-launch CUPC to make sure it was check.

Test and collect logs again.

Michael

Michael Gross Thu, 02/26/2009 - 13:48

Thanks. Although I guess it isn't necessary, I did modify the mail ID to match the actual mail ID of the user in exchange and it didn't have any better result.

I had the user follow your instructions for unchecking, exiting, checking, exiting, and I am still not getting meeting info. The logs are looking a little different, but something still isn't right. Attached are trace logs.

Thanks!

Mike

Attachment: 
htluo Fri, 02/27/2009 - 05:46

Go to CUPS command line and run the command below:

run sql select * from PEResourceProfile where selectorid like '%dthorne%'

Post the screen output here.

Thanks!

Michael

Michael Gross Fri, 02/27/2009 - 06:04

I ran it against jlawless as that's the person I've been putting in a meeting and observing.

admin:run sql select * from PEResourceProfile where selectorid like '%jlawless%'

pkid iuid fkpepackage ikperesourceprofile tkperesourceauth tkperesourcetype tkpedefaultstatus_watcher watcheruriaclid tkpeauthpolicy_watcher fkenduser tkpedefaultstatus_winfo tkpeauthpolicy_presentity tkpeauthpolicy_winfo presentityuriaclid winfouriaclid selectorid fkpefilterinfo listid sourceid fkpedefaultdocument tkperesourceprofile ipid workhoursid devicelistid

==================================== ==== ==================================== ==================================== ================ ================ ========================= =============== ====================== ==================================== ======================= ========================= ==================== ================== ============= ======================================= ============== ====== ======== =================== =================== ==== =========== ============

1e9d6a98-e2f5-4969-b050-e2143f12f983 1143 17eb946a-75a2-4af4-a99a-079cb54c3a9f 1e9d6a98-e2f5-4969-b050-e2143f12f983 1 3 0 NULL 1 1bbc9b40-df0f-745a-d3f3-833461c9c1cb 0 1 1 NULL NULL sip:[email protected] NULL -1 -1 NULL 4 104 -1 -1

admin:

Thanks!

Mike

htluo Fri, 02/27/2009 - 08:07

I couldn't find any certificate transaction in the logs.

As requested couple days ago, could you do the following?

1) Set Presence Engine tracing to detailed.

2) Restart Presence Engine.

3) Log into CUPC

4) Get presence engine logs and upload here.

When you get the presence engine logs, make sure it covers the time you restarted the engine.

Thanks!

Michael

Michael Gross Fri, 02/27/2009 - 12:12

Attached are more logs. Looks like log 128 has the certificate loading. I was provided access into the exchange server and found FBA is enabled on the 2007 server but not on the 2003 server. Is this sounding like a problem with mixed mode and FBA? It isn't following the same pattern as the example of a problem with FBA in "Deploying Cisco Unified Presence" which shows a "Login Timeout" error.

The IIS logs on the server are showing this:

2009-02-27 18:19:36 W3SVC1 172.20.44.14 SUBSCRIBE /exchange/dthorne/calendar - 443 - 172.30.1.11 - 404 0 0

2009-02-27 18:19:36 W3SVC1 172.20.44.14 SUBSCRIBE /exchange/jlawless/calendar - 443 - 172.30.1.11 - 404 0 0

So it seems like cups is hitting exchange without a domain name in the url. I'm attaching a screenshot of the exchange owa authentication config. I had the customer change the setting to "User name only" and it didn't help either.

I found a program called DAV Explorer that seems like it should work to test WebDAV in this sort of situation. What I found is that if I point to the 2003 server (ES1) it tells me to redirect to ES2. When I hit it at ES2 I get the Login Timeout message which I assume does mean it's a webdav issue. Screenshots are in the attachment.

Thanks,

Mike Gross

Attachment: 
htluo Fri, 02/27/2009 - 12:52

Exchange authentication and mailbox are two different things.

If the Exchange server expected mailbox in [email protected] format, you may try this:

1) Go to CUCM Admin > User Management > End User. Search for user jlawless.

2) Make the Mail ID look like this: [email protected]

3) On CUPS server > Serviceability, restart "Cisco UP Sync Agent" service.

4) On CUPC, uncheck and check the "show me as in-a-meeting" setting.

5) Run SQL command to verify the email ID has been updated:

run sql select selectorid from PEResourceProfile where selectorid like '%jlawless%'

6) Test the calendar feature and get PE logs again.

Michael

Michael Gross Mon, 03/02/2009 - 08:32

Thanks. I had set the Mail ID to [email protected] in the UCM End User confguration back when you first mentioned Mail ID, so the last logs already have that setting.

But this is what I see when I run the sql command in CUPS:

admin:run sql select selectorid from PEResourceProfile where selectorid like '%jlawless%'

selectorid

=======================================

sip:[email protected]

admin:

Is this normal or should it show up as [email protected]?

Thanks,

Mike

htluo Mon, 03/02/2009 - 08:46

That means the CUPS database has NOT been updated yet. Follow instructions below to force update:

1) Go to CUCM Admin > User Management > End User. Search for user jlawless.

2) Make the Mail ID look like this: [email protected]

3) On CUPS server > Serviceability, restart "Cisco UP Sync Agent" service.

4) On CUPC, uncheck and check the "show me as in-a-meeting" setting.

5) Run SQL command to verify the email ID has been updated:

run sql select selectorid from PEResourceProfile where selectorid like '%jlawless%'

6) Test the calendar feature and get PE logs again.

Michael

Michael Gross Tue, 03/03/2009 - 07:01

I did this and the sql query still shows [email protected]. The SyncAgent logs show the update, so I'm not sure why it would still show the wrong address.

2009-03-03 09:43:45,489 DEBUG [pool-1-thread-1] sync.AxlClient - ------------update enduser set nickname='', ocsprimaryuseraddress='', mailid='[email protected]', passwordreverse='', tkuserlocale='1', manager='', status='1', department='', lastname='Lawless', userid='jlawless', middlename='', tkuserprofile='1', firstname='Justin' where pkid='1bbc9b40-df0f-745a-d3f3-833461c9c1cb';

admin:run sql select selectorid from PEResourceProfile where selectorid like '%jlawless%'

selectorid

=======================================

sip:[email protected]

admin:

Thanks!

Mike

htluo Tue, 03/03/2009 - 07:31

Try step 4 one more time:

4) On CUPC, uncheck and check the "show me as in-a-meeting" setting.

This should update the CUPS database.

Michael

d.hillman Tue, 03/31/2009 - 14:01

Where did you guys go from here? I have very similar issue.

Michael Gross Tue, 03/31/2009 - 14:32

I have an open case with TAC on the issue. At this point I'm just waiting for my upgrade media to 7. The TAC is thinking I'm hitting a bug that was supposed to be fixed in version 6.0.5. Hopefully it is really fixed in 7.

Good luck with your issue.

htluo Tue, 03/31/2009 - 16:48

That's the way it is.

The SIP SUBSCRIPTION would be in format of "[email protected]".

For example, if mail ID is [email protected] and proxydomain is acme.com, the subscription would be like this: [email protected]@calendar.acme.com.

This is normal.

Michael

http://htluo.blogspot.com/

d.hillman Tue, 03/31/2009 - 19:08

AD Integrated with CM Integrated with CUPS

Mail ID in AD "[email protected]"

CM "[email protected]"

Presense Database "[email protected]@calendar.domain.com"

CCM Trace [email protected]? What gives?

From: [email protected]>;tag=99e78f1c

Also any insight on the below error?

ERROR <--ScalarUserForeignResource::createForeignResourceRecord non-calendar resource hostname starts with 'calendar.': calendar.domain.com

|

03/31/2009 21:27:59.956 EPE|system.pe.mvc 2099886 DEBUG resource not found

|

03/31/2009 21:27:59.956 EPE|system.pe.mvc 2099886 DEBUG Leaving ScalarUserForeignResource::attach

|

03/31/2009 21:27:59.956 EPE|system.pe.mvc 2099886 ERROR Failed to attach view 3

|

03/31/2009 21:27:59.956 EPE|system.pe.mvc 2099886 DEBUG Subscription::attachToView: Leaving

|

03/31/2009 21:27:59.956 EPE|system.pe.mvc 2099886 DEBUG SubActive::attach: Leaving

guilhem.perez Thu, 04/15/2010 - 09:55

Hi,

I'm meeting a similar issue (CUPS 7 with Exchange 2007)

ERROR ScalarUserForeignResource - No calendar folder found for sip:XXXXXXXXXXX

Did you solve your issue.

Thank you

Best regards

Actions

This Discussion