Third-party Sip Device Registration Rejected

Unanswered Question
Feb 24th, 2009

I am trying to set up a third party Sip phone on call manager 6.x. it looks like the phone is talking to call manager because I am getting a Registration Rejected error in call manager but i don't konw how to firure out why it's being rejected. Is there any log files that i can look at?

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Steffen.Baier Wed, 02/25/2009 - 04:35

If you have sufficient licenses I test it on a 5.1 and you had to make sure when the 3rd Party Sip Device was added as a device the Owner User ID and the Digest User ID had to be added.

Have you created a User within CCM for this SIP Device?

The PIN in the User field is the Auth Password for the SIP Client.

What SIP Device do you try to add?

jacobmunson Fri, 02/27/2009 - 07:47

from what I can tell I have everything set up right. As far as I know for Call manager 6.x the licensees is just the DLUs. I am trying to set it up with a SIP phone app on my iPhone. The app is called Siphon.

Steffen.Baier Fri, 02/27/2009 - 08:01

Try to setup X-Lite on a PC and run Wireshark in order to trace to see if you can check the SIP Traffic in order to determine what is wrong.

I did it the following way on 5.1:

Create a User on Call Manager and give it for example the DDI as a name.

Give it a Pin

Give it a password

Then create the SIP Device with the MAC of the PC(if you use X-lite to test. If not of course the MAC of the Iphone)

Make sure that the Owner User ID is selected with the User you created above. The same again with the Digest User must be the same as above.

The only thing in X-Lite I had to add was the IP Address of the CCM and then I added the Username,User ID as the same thing I named the User in CCM and the AuthPassword is the Password in the CCM User Field (not the PIN)

Hope that helps


jacobmunson Mon, 03/02/2009 - 11:45

Where do you set the IP Address for CCM in X-Lite? Is that the STIUN Server?

Steffen.Baier Mon, 03/02/2009 - 12:02


display name can be ignored and is only shown on outgoing/incoming calls.

Domain and Domain Proxy are the IP of the Call Manager.

Nothing else needs to be set.


jacobmunson Sun, 03/08/2009 - 17:48

hmmI am getting a registration error 403 - forbidden on the x-lite phone and in call manager for registration it is saying rejected. Here is what I have set up.

We are using LDAP to sync users from our AD. So for this I am just using my end user. I have added a Third-party SIP Device (Basic) and given it the mac address of my wireless card. (even though i am connecting through a VPN now) I set the device pool, CSS, etc and added line. I created a SIP Device Security Profile with digest authentication enabled and applied it to the sip device. Then associated the Sip device to my end user.

Then in x-lite I created a sip account and put in my username and password. put the ip address for our call manager in the Domain field. I have left everything else as is.

I have tried using the end user pin and digest credentials as well in x-lite but when i do that i get a 404 error - not found. So I am guessing that's not right.

Anyone have any ideas what to try next?

Steffen.Baier Mon, 03/09/2009 - 03:06


I used to look after a 4.1.3 CCM with ActiveDirectory for the users.

In the esection (i can only check 5.1 CCM) were you assign the User's to your AD accounts you normally have a PIN Field. This PIN is the Password in X-Lite.

The User ID is the Authorization User Name. The name should be the name you been giving the profile.

Make sure that you set the Owner User ID and the Digest User to the user you have created from your Active Directory. This is very important as this assignment is not mandatory in Call Manager and can be easily forgotten.


jacobmunson Mon, 03/09/2009 - 06:46

I did miss the Owner User ID thank you for pointing that out. However even with that I am still getting the same errors. 403 - Forbidden when using the AD password and 404 - Not Found when using the pin and it's still saying registration Rejected in call manager. :(

Steffen.Baier Mon, 03/09/2009 - 07:16


is there a way you could upload some screenshots?

Use to host or attach to the forum here.

I just checked it again and the Authorization Username and User Name in XLite for the SIP Device must be the Line 1 Extension that you have assigned to the End User.

Only the PIN from the End User is important.

If above is not done you get the 404 Error.



Steffen.Baier Mon, 03/09/2009 - 07:55


as you painted over it I could not see your Line [1] Name.

This is usually the DDI and that number (or if you added it as a name) needs to be the X-Lite username and Authorization user name.

You can just tick the domain instead of the Proxy.


jacobmunson Mon, 03/16/2009 - 16:12

Well I finally figured out where to put what info in x-lite to get it to register. But now when I place a call as soon as it tries to connect it drops. I have made sure that an MRGL is assigned that has transcoding resources. But that didn't seem to be the problem. Any ideas?


This Discussion