ospf mtu-ignore enabled - what are the risks?

Answered Question
Feb 25th, 2009

Hi OSPF gurus,

1) Say I have 2 neighbours on 1GE, where "A" has MTU 9000 and "B" has MTU 1600, is the risk of mtu-ignore being enabled (so OSPF goes State=FULL) that if "A" has a large LSDB it's DBD pkts might be greater than 1600 bytes and "A" will think it doesn't have to fragment & "B" will drop the DBD?

2) If I have the same huge LSDB and DBD but MTU 1500 both sides does this work because the interfaces know to fragment?

Thanks very much for any clarification.

ps: This is between Cisco c6509 and Nortel 8600. With Nortel 8600 the only size that DBD MTU checking can work at is 1500. If Cisco isn't set to MTU 1500 Nortel must have mtu-ignore enabled.

I'm planning to have Nortel & Cisco MTU 1950 (the Nortel default) and hence must enable mtu-ignore.

Thanks

I have this problem too.
0 votes
Correct Answer by Laurent Aubert about 7 years 9 months ago

Hi,

1) It will happen also with data traffic

2) The router will generate several DBD packets with max size = interface IP MTU

This command was initially added to support OSPF adj between routers on different L2 networks (FDDI/ethernet for example). The switch took care about fragmentation if required.

Now, this command could be useful if you want to have an adj over GRE tunnel for example.

The important point is you have the same MTU on all devices sharing the same L2 segment so what you want to do is correct

HTH

Laurent.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Laurent Aubert Wed, 02/25/2009 - 19:59

Hi,

1) It will happen also with data traffic

2) The router will generate several DBD packets with max size = interface IP MTU

This command was initially added to support OSPF adj between routers on different L2 networks (FDDI/ethernet for example). The switch took care about fragmentation if required.

Now, this command could be useful if you want to have an adj over GRE tunnel for example.

The important point is you have the same MTU on all devices sharing the same L2 segment so what you want to do is correct

HTH

Laurent.

I am having the same issue between Cisco 6509's and 3845 connected to a Nortel Passport 8600. From time to time when we have large LSA floods, the cisco's take down the ospf neighbor adj due to too many retransmissions. The nortel has an MTU of 1950 and the cisco is at 1500. What is the final suggestion here? Make the cisco match 1950 mtu on its physical interface? It is my understanding that the nortel will not use more than 1500 for routing protocols which makes me believe there is a match. I do have an option on the nortel to change to 1522, I am wondering if that will work because it looks like even if you could make them match, nortel and cisco do not see the MTU setting (ie 1500) the same way due to CRC being included/not included.

Thanks

Actions

This Discussion