7935 Configuring IP

Unanswered Question
Feb 25th, 2009

I have a 7935 that is stuck at configuring IP. We do have the Option 150 set, the phone is in the correct VLAN also. We tried several known good ports and it still does not go beyond configuring ip. We even did a reset on the phone. However, after waiting for more then 15 min of the phone "Rebooting" we unplugged it to try and get it to boot back up. Comes back at the configuring IP. Any ideas / suggestions? We also created a new ephone in the CME, but that did not help either. Any ideas / help would be appreciated.

Thank You

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
rob.huffman Wed, 02/25/2009 - 07:16

Hi Lindsey,

I would have a look at your switchport config. Because the 7935 does not recognize the Voice Vlan command you must use (not Trunked-Switchport);

switchport mode access

switchport access vlan xxx (where xxx is your voice vlan)

Hope this helps!


lsnapp72 Wed, 02/25/2009 - 07:47

Hi Rob

Currently my switchport is configured:

switchport access vlan (data vlan #)

switchport voice vlan 840 (voice vlan)

I can change and add the switchport mode access.

However, it was working last week and believe it or not, we have not changed anything. This is at a remote location.

Thanks for the tip! We will give it a shot.



lsnapp72 Wed, 02/25/2009 - 10:22

Hello Rob

Thanks for the tip, however it did not work for us. The phone stayed in the configuring IP mode.

Any other tips / tricks / ideas?


rob.huffman Thu, 02/26/2009 - 06:43

Hi Lindsey,

Sorry to hear that :( Are you sure you don't have any routing issues??

IP Helper address??


lsnapp72 Thu, 02/26/2009 - 08:06

Hi Rob

I am having the same issue with a 7961 and 7940 as well. I have several other phones working ok. Also, we brought these phones back to our headquarters and plugged them in and they worked fine.

Maybe this will help. Snapshot of one of my switchports:

interface FastEthernet0/17

switchport access vlan 84

switchport mode access

switchport voice vlan 840

srr-queue bandwidth share 1 25 70 5

srr-queue bandwidth shape 3 0 0 0

priority-queue out

spanning-tree portfast

service-policy input IPPHONE+PC-BASIC

Thank You


david-lima Thu, 02/26/2009 - 12:58

Hi guys, I was having the same issue,

1. As Rob said, the most important point, verify network conectivity, if it is possible change the phone with other that is working fine to check the results.

2. I reset the phone to a factory defaults.


3. Try to configure a static IP, MASK, DEFGateway and TFTP. (If using DHCP)

Hope this help


lsnapp72 Thu, 02/26/2009 - 15:15

Here is what fixed the issue:

1. I changed the switchport setting per Rob's recommendations.

2. On the 7935 I also found that the cable from the phone to the "triangle box" was also slightly damaged. Tab was broken.

Both caused the problem.

Thank you for your help and response. Now to try and figure out why this started all of a sudden?

rob.huffman Fri, 02/27/2009 - 06:15

Hi Lindsey,

Glad to hear you got this working, nice work! +5 points for kindly posting back with your resolution :)



PS: Great tips David! +5 points for your continued help here as well.


This Discussion