Bootloader Upgrade

Unanswered Question
Feb 25th, 2009


I have recently followed the Cisco instructions and successfully upgraded my 2106 Wireless LAN Controller software to using the cli. However, the instructions also recommend upgrading the bootloader software. That is proving difficult, any time a try to do this it says I'm successfil but the version still remains. Can anyone help me?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
jeff.kish Wed, 02/25/2009 - 08:51

The bootloader is never the same version as the controller software version, so you might be at the highest version allowed for your software. I advise sticking to the bootloader that comes with the software rather than trying to upgrade it after a software upgrade.

RVirdi Thu, 02/26/2009 - 01:32

Thanks for the information.

Considering I have just upgraded to a 5.2 version of software and I'm told bootloader goes up to 4.2, I was assuming that I could upload 4.2 bootloader without problems. What could be the issues if bootloader isn't upgraded?

Leo Laohoo Wed, 02/25/2009 - 17:27

The last "true" bootload is the The rest are all ER: Emergency Release (patches).

"Unlike previous ER images, a new bootloader file is not loaded when you install the ER.aes file. This is true for all controllers. The ER.aes file is the last ER file to contain a bootloader. If you want the latest bootloader, install the ER.aes file. If you want to obtain the fix for CSCsd52483, also install the ER.aes file."

Hope this helps.

RVirdi Thu, 02/26/2009 - 01:30

Thanks for the information.

I have tried to install ER.aes, but although the process said it worked, it as still version Why do you think this is? I get no failure message.

Stephen Rodriguez Thu, 02/26/2009 - 17:02

Boot loader on the 2106 is not field upgradeable. So long as you load the ER image, to get the enhancements to the emergency repair image you are fine.



RVirdi Fri, 02/27/2009 - 01:27

Thanks Steve. Is this the case for the 4400s as well?

Stephen Rodriguez Fri, 02/27/2009 - 07:37

the 4400 boot loader is upgradeable.

!! Be aware, that all ER images do not necessarily have a new boot image!! For example, you were running, and you loaded the ER images. This would show you a boot loader of Now you upgrade to 5.2, and load the ER. This only upgrades the ER, and not the bootloader. You would still see a boot loader of




This Discussion