Click to Call will not pick up my devices

Unanswered Question
Feb 25th, 2009
User Badges:

Hello everyone. I recently installed click to call on my pc. I also ensured the CCMIP service and the webdialer service is enabled. My problem is when I open the click to call, it does not list any phones to control. I am on Call Manager 6.1.2. I have the Cisco IP communicator as well as the CUPC 7 client installed on my pc. The CUPC 7 client can control my phones. Could this possibly have something to do with the service address in the Click to Call preferences? Any help would be greatly appreciated.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Hythim Ali El Hadad Sat, 02/28/2009 - 15:29
User Badges:
  • Silver, 250 points or more

Hi Jone,

Only for a note:

Cisco Unified Personal Communicator is not currently supported with Click to Call

Also Cisco IP Communicator v 2.1(3) or higher is supported. Cisco IP Communicator is supported in SCCP and SIP mode

For your problem i gues it may be due to a firewall existance or aproxy that direct your traffic

So you can check the following 2-points:

1.If a firewall exists between Cisco Unified Communications Manager and the client PC, your end user may not be able to use Click to Call.

Click to Call sends request messages to Cisco Unified Communications Manager over HTTPS using port number 8443. Therefore you need to configure the firewall or router to allow message requests and responses between Click to Call and Cisco Unified Communications Manager over HTTPS using port number 8443.

2. If your organization routes HTTP traffic via proxy servers to access the internet, you must add an exception for the internal HTTPS traffic sent from the Click to Call application to the Cisco Unified Communications Manager server.

So either add an exception for the IP address and port number of the Cisco Unified Communications Manager, or use the server name that is already covered by an exception. An example of th e full exception rule is https://:8443.

Wish this be helpful

joneschw1 Sun, 03/01/2009 - 12:52
User Badges:

Thanks for replying. Actually, I do not have any firewall or any proxy service between the call manager and the end users. DO you have any other suggestions?

Hythim Ali El Hadad Sun, 03/01/2009 - 14:56
User Badges:
  • Silver, 250 points or more

Hi Jone,

Only for confirmation,

In the Device Association section, verify the correct devices are listed in the Controlled Devices window.

If yes.

please also verify and refresh the phone preferences in the Phones screen of the Click to Call Preferences.

Awaiting for your feedback

joneschw1 Mon, 03/02/2009 - 09:42
User Badges:

That is my problem. There are no phones listed in the controlled devices window of the click to call. In call manager, I do have phones listed in device association. These phones definitely work. When I open IP communicator, the phone works and reflects status of my desk phone that also works. Any help you have would be greatly appreciated.

joneschw1 Wed, 03/31/2010 - 08:31
User Badges:

No I did not.  Are you experiencing the same problem?

safety2008 Wed, 03/31/2010 - 08:32
User Badges:

yes, no devices to be found.

strange, seemed straight forward..

Aaron Harrison Wed, 03/31/2010 - 08:37
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi All

It's probably worth starting by testing the WebDialer - log into CCMUser, and try dialing someone by clicking their number in the directory search.


safety2008 Wed, 03/31/2010 - 10:00
User Badges:

hey arron,

thanks for reply, using the ccm destop i can dial from directory. is that the address that should be put in the click to call for call manager??

Aaron Harrison Wed, 03/31/2010 - 10:09
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015


Well - that would prove that your users are properly configured and associated, and that webdialer works.

If I recall correctly, you should point the app at the server you have activated WebDialer on.

If it doesn't work, disable your proxy settings in IE (uncheck all options in Tools/Internet Options/Connections/LAN Settings.../) then restart the Click2Call widget or your PC, and try again.



Please rate helpful posts...

agonza07 Mon, 08/23/2010 - 13:46
User Badges:

I need to further test this out, but version 8 did the same thing to me.

I finally decided to associate the first 25 devices I saw on the user, and try the program again. I then saw an option on the "Phones" tab in Click to Call and checked the box that said I'm a mobility user.

When I checked the devices it had that mobility phone, so I checked it. Then I closed out the program and started it again. This time it picked up all the phones I had configured. In CCM I removed the extra phones, and so far it's been working good.

Weird thing is that I was actually testing this out on two computers, as soon as one recognized the phone the other one did too. Makes me think it was a CCM issue...

Like I said, I need to further test this out and see if I can reproduce the problem/solution... but just wanted to post this out in case it works for someone...


This Discussion