NME-16ES-1G-P Etherswitch Gig Port Won't Switch?

Answered Question
Feb 25th, 2009
User Badges:

I was hoping to be able to connect the Etherswitch to another switch via the gig port. But if I try to turn it into a switchport and/or a trunk port I am told this is not possible. I don't see anything in the doc http://www.cisco.com/en/US/products/hw/modules/ps2797/products_configuration_example09186a0080810449.shtml

..about how to make use of the gig port on the outside of the module. Any way to permit this? Or can it only serve as a router port or other? Thanks.


interface GigabitEthernet1/0/1

no switchport

ip address 10.1.1.1 255.255.255.252

spanning-tree portfast


PoE2811(config-if)#switchport mode trunk

Command rejected: Gi1/0/1 not a switching port.


PoE2811(config-if)#switchport trunk encap dot1q

Command rejected: Gi1/0/1 not a switching port.



Correct Answer by Edison Ortiz about 8 years 3 months ago

How about typing switchport under G1/0/1 before setting the interface to trunk?


__


Edison.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Leo Laohoo Wed, 02/25/2009 - 17:08
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Try the following sequence:


int g 1/0/1

no switchport

switchport trunk encap dot

switchport mode trunk

end


Hope this helps.

mmedwid Wed, 02/25/2009 - 17:19
User Badges:

Thanks for the reply. But same result:


PoE2811(config-if)#int gig 1/0/1

PoE2811(config-if)#no switchport

PoE2811(config-if)#switchport trunk encap dot

Command rejected: Gi1/0/1 not a switching port.

PoE2811(config-if)#switchport mode trunk

Command rejected: Gi1/0/1 not a switching port.

PoE2811(config-if)#


Correct Answer
Edison Ortiz Wed, 02/25/2009 - 17:18
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

How about typing switchport under G1/0/1 before setting the interface to trunk?


__


Edison.

mmedwid Wed, 02/25/2009 - 17:21
User Badges:

Cool - there we go:


PoE2811(config-if)#int gig 1/0/1

PoE2811(config-if)#switchport

PoE2811(config-if)#switchport trunk encap dot

PoE2811(config-if)#switchport mode trunk


PoE2811(config-if)#do show run int gig 1/0/1

Building configuration...


Current configuration : 123 bytes

!

interface GigabitEthernet1/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast


Edison Ortiz Thu, 02/26/2009 - 06:06
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Glad my suggestion worked, make sure to rate helpful posts.


__


Edison.

Actions

This Discussion