ospf redistribution

Answered Question
Feb 26th, 2009

Hi...

I have 3 devices-A,B,C.

A&B are already running ospf.C is to be enabled with ospf.Herein i'am little confused with redistribution being done on A and the configs.

Attached are the existing configs of all 3 devices with important information.

Also,i am not sure..y only 4 routes are tagged in device A and redistributed to ospf.

Device B has a FastEthernet0/0/1 which has to put in ospf along with the respective/correct interface from Dev C.

Would it be ok if i jst put fa1/0/1 on Dev C and fa0/0/1 on dev B to a new ospf area or will i require any further redistribution or filtering.

Please help me get the correct config for deviceC.

Pls reply asap.Thanks!

Correct Answer by adamclarkuk_2 about 7 years 11 months ago

Hi mate

Paste your config in for the 2 devices.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (3 ratings)
Loading.
adamclarkuk_2 Thu, 02/26/2009 - 02:40

Hi

You are right, you will need to put fa1/0/1 into the OSPF process on Dev C and Fa0/0/1 on Dev B. This will form an OSPF adjacency will will start to pass routing updates.

As you already have a static route on Dev A and B for 10.96.0.0 /16, you don't have to add that network to OSPF on Dev C ( unless you want to, then you can remove the static routes).

Also, on Dev A, A better/tidier way of advertising default is with the default-information originate instead of the command :-

network 0.0.0.0 255.255.255.255 area 0 statement

suthomas1 Thu, 02/26/2009 - 03:00

thanks for replyin..so jst gettin ospf enabled on C like:

router ospf 58

network 10.96.0.2 area 100

& network 10.96.0.1 area 100(on B)

would suffice here..no need to worry abt anything further to be redistributed/filtered on C?

also, dev B has this route ip route 10.16.0.0 255.255.0.0 10.16.1.30, den why is dev A again redistributing it in ospf with tag.

ip route 10.16.0.0 255.255.0.0 10.16.1.58 tag 43

wouldnt it cause confusion as to which route is better?

adamclarkuk_2 Thu, 02/26/2009 - 03:15

I not sure why you have so many area's unless you plan to summarize.

Dev B

router ospf 58

network 10.96.0.0 0.0.0.3 area 100

Dev C config

router ospf 58

network 10.96.0.0 0.0.0.3 area 100

( and if you want network 10.96.40.9 )

network 10.96.40.0 0.0.0.255 area 100

(I have chosen a 0.0.0.255 as I don't know your subnet mask for the network)

I cannot tell you if filtering and redistribution is needed as you have not said what you need to happen, ie You don't want network x to make it to router x or I need to make sure network x does get to router x.

If looks like you have multiple exit points for 10.16.0.0 /16, so you need to decide which you want to use as primary and adjust accordingly, as of now it's a closest wins situation.

The static routes will beat the OSPF learned routes as the prefix is the same but the AD's will be different ( static is 1 OSPF is 110).

suthomas1 Fri, 02/27/2009 - 08:05

Thanks for your reply.what if we need to have the Dev C also come under backbone area 0.How will be the config for this case.Since Dev C at present doesnt have anyother link coming to it except the one directly from Router B.Router B is hooked to Dev A.Pls suggest?

adamclarkuk_2 Fri, 02/27/2009 - 08:12

Your right, I got so caught up with why you need multi areas I forgot about Area 0. You will need to virtaul Link from Dev C into Dev A for this to work, or if you do not need multiple areas, (which in a network your size you dont), then I would collapse all the routers into area 0.

Let me know if you need help setting it up, here is a link for you to read

http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a00801ec9ee.shtml')">http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a00801ec9ee.shtml

suthomas1 Fri, 02/27/2009 - 08:32

because from what i understand, in future if any additional segment is connected to Dev C..it must be fused together n accessible.currently its only link is via B.Pls do help in setting this up, if u can.

Could it have any issues on operation of Dev A due to any route looping or other probs if we are pull dev C also to backbone area.

also..would it mean that all 3 routers would only run area 0.

thanks in advance!

adamclarkuk_2 Fri, 02/27/2009 - 08:36

I would recommend putting all the routers in area 0 as virtual links will bring more complexity than you need with a 3 router setup.

If you do want/have to use virtual links I will happily give you an example config using your setup.

suthomas1 Fri, 02/27/2009 - 08:43

that would be really helpful...

there are some other devices which are currently not running ospf but are connected via provider links to the Dev A,which i guess would be later on made to run ospf.

adamclarkuk_2 Sat, 02/28/2009 - 08:03

Hi

I will need to put this into a lab so I will need your complete configs (minus sensitive IP's and passwords), or I can build a similar network with bogus IP's, which would you prefer.

suthomas1 Sat, 02/28/2009 - 09:16

no worries...you can use the same ones as mine..jst want this config seen.Will b waiting for your reply..

also am i correct if i say that this should need a virtual link?

Thanks buddy..

adamclarkuk_2 Sat, 02/28/2009 - 13:56

Hi

I must be suffering from a lack of sleep, we don't need a virtual link at all as area 0 already extends to Dev B all we need to do is put the interface that connects Dev_B to Dev C into area 0 and bam, all done

Dev B

router ospf 58

network 10.96.0.0 0.0.0.3 area 0

Dev C config

router ospf 58

network 10.96.0.0 0.0.0.3 area 0

( and if you want network 10.96.40.9 )

network 10.96.40.0 0.0.0.255 area 0

(I have chosen a 0.0.0.255 as I don't know your subnet mask for the network)

Also, check you have the interface that connects Dev A - B in area 0 as well.

Sorry to mess you around :-s

Just in case you are intrested, here is a nice link to a simple Virtual Link config example

hxxp://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a0...

suthomas1 Sun, 03/01/2009 - 06:17

Hi..thanks for this help!

got a bit more stuff, i am having reachability issues with one of the devices from device B.

Refer the attached file(Dev C_1) which has been added with required info.

Looking fwd to ur help!

thanks!!!

Attachment: 
suthomas1 Wed, 03/04/2009 - 00:14

hey thanks!it was a gateway config probs..its solved..

thanks for your help with both cases!

Actions

This Discussion