Calendar Integration with CUPC 7 and Exchange 2003

Unanswered Question
Feb 26th, 2009

Dear all,

I'm currently trying to integrate the calendar feature. I followed the description on and also the steps in Michael Luos book.

The Presence Server shows me the following message in System Troubleshooter:

"The Microsoft Exchange Certificate file is either not currently loaded or there is a subject CN (Common Name) mimatch. This Certificate is required so that CUP and Exchange can communicate in a secure manner."

The Outlook gateway is configured with the Presence gateway value "". The certificate is issued from a root CA installed on a local win2008 machine for The SSL connection the OWA is working fine. I can log in and I can see the calendar, as well as appointments configured in Outlook 2007.

The RTMT shows the following in the last sdi trace file:

02/26/2009 12:07:03.099 EPE| 2044834 DEBUG <--OwaBackendAdapter.clearCalendar sip:[email protected]


02/26/2009 12:07:03.100 EPE| 2044834 DEBUG <--CalendarSubscription::scheduleRefresh - refresh interval: 960


02/26/2009 12:07:03.100 EPE| 2044834 DEBUG <--CalendarSubscription::initiateRecovery: SUBSCRIBE


02/26/2009 12:07:03.100 EPE| 2044834 DEBUG <--CalendarSubscription::notifySingle


02/26/2009 12:07:03.100 EPE| 2044834 DEBUG <--QMS::SUBSCRIBE

I'm not quite sure what else I can do. The Calendar function is enabled for the user, the client status is shown correctly, the status changes correctly if I go off hook on the desk phone.

Any help is much appreciated.

Many thanks,


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
htluo Thu, 02/26/2009 - 06:12

could you do the following?

1) Make sure "Presence Engine" trace level is set to "detailed"

2) Restart "Presence Engine" service

3) Log into CUPC

4) Use RTMT collect Presence Engine logs.

upload logs here.



BlackAvenger Thu, 02/26/2009 - 07:16

Hey Michael,

please find attached the trace log from CUPS 7. Please note that I only could change the trace level to error. There is no detailed trace level available in the drop-down menu. Hope the log is still comprehensive enough

Many Thanks,


BlackAvenger Thu, 02/26/2009 - 08:45

Hey Michael,

yeah found that as well in the IIS logs.

1. is the domain I'm using

2. is the FQHN for the exchange server

3. email domain ist as well


Hope that helps,


BlackAvenger Thu, 02/26/2009 - 10:26

Yes I can login to the OWA with the credentials for this user. I can even access the Calendar function. I'm wondering a bit why the Presence Server shows a certification mismatch ...

htluo Thu, 02/26/2009 - 17:26

Do you have SP1 (or above) installed on Exchange 2003? If not, you'll get "404 resource not found" message.


BlackAvenger Fri, 02/27/2009 - 00:15

SP1 for Exchange or for Windows 2003? Thanks Michael will check this later today.


BlackAvenger Fri, 02/27/2009 - 01:46

Hey Michael,

thats great it is working now. I upgraded Exchange to Service Pack 2, which solved the problem.

Thanks for your help and best regards,


MICHAEL CARTER Tue, 01/26/2010 - 07:13

Hi Michael,

I have the same error message as this previous post...  I'm using an Exchange 2007 and CUPS 7.0(5), and I can't see the calendar entries/status on my CUPC.


01/26/2010 14:58:08.178 EPE| 1885334 ERROR Exchange Server Transaction Failed: SUBSCRIBE sip:[email protected]@SRVCASHT01CUPS:443 404 Not Found - clear calendar information

1) what is

- this is the email domain

2) what is SRVCASHT01CUPS?

- exchange server that runs a secondary website running owa, this has the certificate with the CA bit set

3) what is your email domain on Exchange?


4) what is the proxy domain in CUPS (System > Service Parameters > SIP Proxy)


I can log into the OWA with [email protected], and not with [email protected]

Is this a know issue - is there a fix for the issue?

Yours sincerely,


htluo Tue, 01/26/2010 - 09:15

You said "I can log into the OWA with [email protected], and not with [email protected]".  That explained the "404 Not Found" message.  Because CUPS was trying to get the calendar information for  [email protected] and it's not found.

CUPS use the "Mail ID" field from CUCM.  See if you can get the CUCM mail ID field to  [email protected]



This Discussion