WS-C2960G-48TC-L won't connect at full/100

Unanswered Question
Feb 26th, 2009

Gi0/44 of our WS-C2960G-48TC-L is connected to Fa0/2 of our ISP's 2950-12 switch.

According to our ISP, the Fa0/2 is set to Full/100.

Set our Gi0/44 to Full/100 = not connected

Set our Gi0/44 to Auto/Auto = half/10 but occasional amber blinking LED. Transmit packet errors.

Set our Gi0/44 to half/10 = half/10 but occasional amber blinking LED. Transmit packet errors.

Anyone know what the issue might be?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
support.edm Thu, 02/26/2009 - 07:30

CGI-COLOC-BELL-S1(config)#int gi0/42

CGI-COLOC-BELL-S1(config-if)#speed nonegotiate

^

% Invalid input detected at '^' marker.

CGI-COLOC-BELL-S1(config-if)#speed ?

10 Force 10 Mbps operation

100 Force 100 Mbps operation

1000 Force 1000 Mbps operation

auto Enable AUTO speed configuration

^^^^^^^^^^^^^

There isn't an option for nonegotiate.

It's X-over between the 2 ports.

support.edm Thu, 02/26/2009 - 07:35

So straight through should enable me to have a connection after i set my gi0/44 to full/100?

As you can tell, my knowledge in x-over vs straight through is in a grey area. My understanding is to connect between 2 cisco switches, I need an x-over no matterwhat?

support.edm Thu, 02/26/2009 - 07:45

Although the change would only take 1-2 min, can't do it now because of the impact and implications on the 24/7 web services and such. I'd have to schedule an outage with all stakeholders

Mohamad Qayoom Thu, 02/26/2009 - 07:49

Well, generally you use cross-over when you connect similar devices. And straight-through when connecting different devices.

But, once I had to use straight through cable to connect a 2960 and 4506 because of auto-MDIX.

Edison Ortiz Thu, 02/26/2009 - 07:52

I suggest replacing the cross-over cable with another cross-over cable.

If you go with straight-through cable, you won't be able to force speed/duplex settings on switch-to-switch links as you are disabling auto-mdix.

Please refer to the portion of the documentation:

http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_46_se/configuration/guide/swint.html#wp1193977

HTH,

__

Edison.

glen.grant Thu, 02/26/2009 - 09:03

The rule is if you use a straight thru then you have to use auto mdix which "requires" the port speed and duplex to be set as auto otherwise it will show down/down . If you use a crossover then you can hardcode because the switch does not have to negotiate which pairs to use for transmit and recieve.

Leo Laohoo Thu, 02/26/2009 - 14:33

Straight-through or Cross-over it won't make a difference. All ports on the 2960 switch are MDI/MDIX capable (sh interface cap).

I've seen this situation before all the time and this is partly caused by the speed auto-negotiation issues of either the local or remote appliance.

In most of the cases, when I hard-code the speed/duplex settings, I don't get any link. But auto/auto and I get auto-negotiated to 10/half. The cause was the service provider NOT hard-coding/forcing their appliance's speed/duplex setting.

Hope this helps.

Edison Ortiz Fri, 02/27/2009 - 06:44

Straight-through or Cross-over it won't make a difference.

I'm sorry, on this case it does. Please take a moment and read the link I posted on this thread.

__

Edison.

mlund Fri, 02/27/2009 - 00:28

Hi

To me it looks like the provider has full/10 not full/100.

To get a link up you always have to use the same speed. When link is up then the duplex question begin, is it full or half. If you set it to full and the other end is half, then you start to get runts and crc errors. If you set half and the other end is full you are getting late collisions and excessive collisions. With half - half you get collisions, this is a normal behavior. With full - full no errors should appear.

devices connected with

10 - 10 link up

10 - 100 link down

100 - 100 link up

auto - 10/half 10/half - 10/half

auto - 10/full 10/half - 10/full

auto - 100/half 100/half - 100/half

auto - 100/full 100/half - 100/full

Take a call to the provider and ask them to check there speed settings.

/Mikael

Actions

This Discussion