Voice VLans.. trunk and access modes..

Unanswered Question
Feb 26th, 2009

Hey guys..

We have got some 2950s and 3500s switches which have got IP phones plugged in and are working fine. Ports are currently configured as trunks and voice traffic has been put into the separate voice vlan 222.. IP phones and the end PCs are correctly picking up their associated VLans..

I have just tried to put the ports into access mode and respecify the voice vlan as follows..

int fa 0/4

switchport mode access

switchport voice vlan 222

** we dont use any additional prioritization for voice on the LAN..

Anyway, once I make the change, the end PC picks up the correct native access VLan and works fine..

However, tHe IP phone loses registration with the call manager and just cycles on Configuring IP.. On full factory reset it appears that it now cannot pick up any IP address at all, so Im guessing the switch does not recognise the phone device at all and doesnt issue the correct voice Vlan ( 222 )..

As soon as I put the port back into trunk mode, everything is happy and the phone and pc pick up their correct vlans..

This is happening with both our 2950s and 3500s..

Has anyone had this problem or have any suggestions ??.. Probably something really simple I have forgotten !.

Thanks in advance...

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
rob.huffman Thu, 02/26/2009 - 09:13

Hi Jon,

This is a Cisco "best practice" on the older 3500XL Switches (like the 3550).

The switchport mode trunk method was the only way to go, but on all newer versions (like the 2960/2970/3750)the need for Switchport mode Trunk is not necessary..

I do know that it is unnecessary to configure the switchport in Trunk mode because when you use the Voice VLAN (with a native vlan) command a "special" dot1q trunk is automatically setup. The reasons I have seen to support this setup are many and vary from minimizing Trunking overhead to ease of configuration and everything in between :)

Here is one of the better threads I have ever read on this issue (with some Tac links as well). There are some great answers from Mahesh,Paolo Sankar and others here.

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=IP%20Telephony&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.1ddd5905/14#selected_message

You will also see in this thread that Ulrich has discovered a "fix" for this using a newer IOS;

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=Video%20over%20IP&topicID=.ee6c82f&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.2cbe84cc/1#selected_message

Hope this helps!

Rob

jonmo2578 Thu, 02/26/2009 - 09:49

Cheers Rob..

Very useful links..

I think it is looking like an IOS issue then, as we have got an old one on the swtich.. Was hoping there was some sort of work around but looks like a newer box is the better option..

Cheers

Jon.

Actions

This Discussion