LMS 3.1 daemon manager registry buffer error.

Answered Question
Feb 26th, 2009

Hello,

After a forced reboot in a Unix server, running solaris 10 and LMS 3.1.

/etc/init.d/dmgtd start, doesn't start and the dmgtd.log file shows me this :

Feb 26 15:33:14 cw1 dmgt[793]: [ID 155437 local0.warning] #2059:TYPE=WARNING:Internal Error: The daemon manager has an invalid registry buffer %\342

\343\317\323. Call your technical support representative for assistance.

Feb 26 15:33:14 cw1 dmgt[793]: [ID 631803 local0.warning] #2085:TYPE=WARNING:Internal Error: Invalid entry in registry file on line 24. The reason i

s Internal Error: The Daemon Manager could not register the application. Please refer to the man pages and user guide, or call your technical repres

entative for information on how to register an application with Daemon Manager.%\342\343\317\323.

~

Any ideas.

Thanks.

Patrick Vignaud.

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 7 years 11 months ago

No. There is nothing you can do within LMS that would cause this corruption.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
pvignaud Thu, 02/26/2009 - 15:51

Hi,

I think that you find the problem :

See what I've :

cw1:/opt/CSCOpx/objects/dmgt #ls -l

total 868

-rw-r----- 1 casuser casusers 8524 Feb 23 19:03 _nsdb_root

-rw-r----- 1 casuser casusers 13725 Feb 26 17:09 dmgtd.conf

-rw-r----- 1 casuser casusers 13725 Feb 26 11:40 dmgtd.conf.backup

-rw-r----- 1 casuser casusers 13725 Feb 26 15:58 dmgtd.conf.bak

-rwxr-x--- 1 casuser casusers 316032 Jun 15 2008 dmgtd.sol

-rwxr-x--- 2 casuser casusers 60660 Jun 15 2008 pdcmd.sol

drwxr-xr-x 2 casuser casusers 512 Feb 23 19:13 ready

-rw------- 1 casuser casusers 1876 Feb 25 23:55 sadiags.xml

If I check the dmgtd.conf file, strange things (errors) in it.

The .backup seems to be correct.

I send you three similar files that I've.

Do you've an idea, on what has been done for scrapping the file like this.

It's only a conf file. A reboot, doesn't have to corrupt these files ?

Could you explain what ?

Thanks.

Patrick.

Attachment: 
Joe Clarke Thu, 02/26/2009 - 15:59

The file is certainly corrupt. The .backup file looks safe provided this server really doesn't have DFM, Campus Manager, or IPM installed on it. Replace dmgtd.conf with dmgtd.conf.backup, then restart dmgtd.

Based on the type of corruption, it good be that someone catted a PDF file onto this file, or you may have a bad hard disk. Given that the file sizes are exactly the same, I'd be suspicious about the state of the disk.

pvignaud Thu, 02/26/2009 - 16:05

Yeap!

I've done this and it's working again.

Correct, on this one, I'm only running CS + RME.

The only thing that I can think about is, this afertoon I ran an RME detailed device report with attachment (pdf).

The server is brand new, 3 disks in RAID5.

Patrick.

Joe Clarke Thu, 02/26/2009 - 16:23

Just because something is new doesn't mean it's not broken. If you have any disk diagnostics, you might consider running them just to be sure.

pvignaud Thu, 02/26/2009 - 16:48

Correct.

You know what. I ran a RME detailed device report on all my routers and a script at the same what does a cwcli invreport in a csv format.

Do you think that it could enter in conflict in some kind at the same time ?

Patrick.

Correct Answer
Joe Clarke Thu, 02/26/2009 - 16:50

No. There is nothing you can do within LMS that would cause this corruption.

Actions

This Discussion