H.323 slow start problem

Unanswered Question
Feb 26th, 2009
User Badges:

I work with Cisco AS5350XM GW , version 12.3 (12r)PI6b.

I tried to make a call scenario with protocol H.323 only from TS trough Cisco gateway back to same TS. The call scenario with h.323 fast start was successful, but when I switched to slow start, Cisco gateway did not respond on h245 massage and release the call.


dial-peer 12 voip

destination-pattern 33......

translate-outgoing 12

voice-class h323 1

codec g711alaw

session target ipv4:x.x.x.x

dtmf-relay rtp-nte h245-alphanumeric


where

voice class h323 1

call start slow


thank in advance


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Nicholas Matthews Thu, 02/26/2009 - 18:37
User Badges:
  • Red, 2250 points or more

When you say 'TS', what does that refer to?


You may find these commands helpful for H323-H323 CUBE:


voice service voip

h323

h225 connect-passthru

h245 passthru all


CUBE is any time you're using the gateway to do H323-H323, H323-SIP, or SIP-SIP in case you weren't aware. It uses a special set of features and code, and you can find out more by doing a cisco.com search for "Cisco Unified Border Element". Reading the H323-H323 configuration guide may be helpful to understand some of the concepts.


Also, the version you listed is more likely the Rommon version than the actual version of code. Generally if the version has an 'r' in it, you're looking at the rommon code.



hth,

nick

migi00000 Fri, 02/27/2009 - 00:50
User Badges:

hello,

thank You for answer but it didn't help me. TS=telephony server of other vendor.

Cisco gateway can handle h245 & h225 message because it transmit it correctly with fast start=ON.

Behavior with slow start should be similar, but from some reason it isn't.

Does anyone know why?

Nicholas Matthews Fri, 02/27/2009 - 05:25
User Badges:
  • Red, 2250 points or more

You're right, it should work.


What is the order of messages you get?


Ex:


-> SETUP

<- SETUP

<- PROCEEDING

-> ALERTING

<- ALERTING

-> TCS

<- TCS

-> TCS

<- TCS

-> CONNECT

<- CONNECT

...

etc

migi00000 Sat, 02/28/2009 - 06:26
User Badges:

messages order:

TS Cisco

---->SETUP

<----SETUP

---->TCS

---->MSD

---->CALL PROCEEDING

<-----PROGRESS

---->CONNECT

---->TCS

---->MSD

<----RELEASE(resource unavailable)


as You can see Cisco doesn't sent any TCS or MSD message.

if You what I can send You e-mail with whireshark traces.



Nicholas Matthews Sat, 02/28/2009 - 08:55
User Badges:
  • Red, 2250 points or more

Do you have a firewall or any NAT in this scenario? It's very possible that the router is expecting one port but it's coming on another and it disregards the H245 messages.


-nick

migi00000 Wed, 04/08/2009 - 06:48
User Badges:

hello,


call scenario is:

call initiate from telephony server through cisco GW back to telephony server.


I try to configure slow start again, but problem is the same.

When I try fast star call all massages that sniffing in wireshark are normal, but Fast star works correcty only with command:

session target loopback:rtp

applied on dial-peer.

When I try slow start call with this commend, cisco don't recognize slow start even it is turn on, so i have to use command:

session target ipv4:X.X.X.X

but now cisco dont't recognize incoming TCS, MSD message and release a call.

Somehow I Cisco need to recognize this messages (TCS, MSD)and answer on it.

Can You, help me?


thanks in advance

Actions

This Discussion