NSS4000 running in degraded mode (RAID 5)

Unanswered Question
Feb 27th, 2009


We have a NSS4000 Linksys 4 bay gigabit NAS. The trouble is that when i created an array (4 drives 500GB Raid level 5) and started some system integrity tests, like failing one of the four drives, the system in about 3 minutes detected that array is in degraded mode. Later in system log i saw this "2009-02-21 11:25:11 Degraded Mode Management has stopped RAIDA :)Later i inserted the new disk and the system started the rebuild array operation in system log i saw this

"2009-02-21 11:33:32 RAIDA is running in Degraded Mode" seems normal, but when i tryied to acces one of my shared volumes on my computer system says invalid home directory for my created users or groups it meens i lost all the data, all the shares that i have created.

The same information i get when the rebuild whas finished. So it meens when system is in natural fail the whole array is down and all data is lost?  Why I could not access data during rebuilding proccess?

thanks a lot in advance,


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
doishi Fri, 02/27/2009 - 15:14

You should be able to access data in degraded mode.  But the NSS does have a setting for how long degraded mode can be used.  This is to protect data loss as the degraded RAID is no longer protected against hard drive failures.  The default for this setting is "disabled".

Degraded mode grace period.bmp

You can restart a RAID in the Storage>RAID menu and clock "Add" on the drive that was repalced.


If this doesn't solve your issue, a support call may be requried to go through the details of this issue.


This Discussion