UC520/FXO:cann't see the caller number

Unanswered Question
Feb 27th, 2009


I configure an UC520 with one FXO connections for test.

The problem is when i trying to call from outside for example from mobile, i cann't see the caller number only "Anonymous"

Can you help me ?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Marcos Hernandez Fri, 02/27/2009 - 06:06

First step is to make sure that the CO trunk is enabled for Caller ID. Call your phone company and ask them or simply connect a regular phone to the line (a phone with a display), call the number and check for CLID.


Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

mCiscotelecom Fri, 02/27/2009 - 08:39


Thanks for your response.

This function is enable, i try it with a regular phone.


mCiscotelecom Fri, 02/27/2009 - 09:26

Belgium provider Belgacom

i have this config :

voice-port 0/2/0
trunk-group ALL_FXO
connection plar opx 026449623
description Configured by CCA LignePstn-Custom
caller-id enable


Marcos Hernandez Fri, 02/27/2009 - 09:39

Please enter these commands:


voice-port 0/2/0

cptone BE


no shutdown


Let me know,

Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

mCiscotelecom Fri, 02/27/2009 - 10:00

Done nothing change i can receive the call but no caller-id.

Ok i receive the caller-id when i delete this command all is ok now:

cptone BE

Do you know why ?


Marcos Hernandez Sat, 02/28/2009 - 17:47

The commands provided in your configuration, plus the call progress tone command that I recommended should be enough for localizing the FXO port for Belgium. At this point, I would advise that you contact Belgacom and ask them how exactly are they implementing caller id for your trunks. This document is very useful for understanding how caller ID is implemented in Cisco IOS devices:


Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

Moderator Tue, 03/03/2009 - 06:24

Hi Mohamed,

If we were able to resolve your issue, could you please take a moment to mark the thread as answered? It will help out our other members who are trying to find answers to the same question.

Thank you,

Cisco Moderation Team


This Discussion

Related Content