Tandberg Gatekeeper, CUCM, IP Phone and Tandberg Video endpoint

Answered Question
Feb 28th, 2009
User Badges:
  • Bronze, 100 points or more

I have this setup on the network. A Tandberg gatekeeper configured to the CUCM with a trunk. users with any voip phone can call the endpoints but the calls are established without video even though this phones have Cisco video advantage with cameras. How can I make the Cisco phones make video calls to this Tandberg video end points (vise versa).


Any input appreciated.

Correct Answer by billybjo1 about 8 years 3 months ago

But if you create a location/region for the trunk, you can avoid that problem.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (3 ratings)
Loading.
rhugo Tue, 03/10/2009 - 05:54
User Badges:
  • Bronze, 100 points or more

You need an MCU, my friend to separate the voice and data streams.

babatunde_sanda Tue, 03/10/2009 - 07:44
User Badges:
  • Bronze, 100 points or more

Thank you very much for the input. You see; at the location where I have the tandberg endpoints, I can make video calls to the endpoints from cisco video advantage connected to an IP phone. Do you have any theory for this? I totally agree with you on the MCU though. I wil start investigating that.


To include. Do I need the MCU even if the conference call is only between two user (endpoints)? Documentations I have been reviewing say three or more conference calls.


Thanks.


billybjo1 Tue, 03/10/2009 - 08:17
User Badges:

You only need an MCU for 3 or more parties in a conference. Have you checked the location/region bandwidth/codec settings for the trunk. Those values would need to be correct in order to permit the video call. Also you may need to set the bandwidth to double of what you actually require. Also do you see and debugs in the GK for call attempts and reason for failing.

babatunde_sanda Tue, 03/10/2009 - 08:46
User Badges:
  • Bronze, 100 points or more

Thanks for the input. I have the g729 configured for the inter location and g711 for local (intra) codecs. in the trunk config I have g711 for "codec for outbound faststart". I will change that and test (thanks for this hint.). Currentlly in CUCM I have it set to video call bandwidth of 384kpbs for the inter locations. That should be sufficient what do you think? I will get back once I test the codec change.


billybjo1 Tue, 03/10/2009 - 08:51
User Badges:

I would suggest setting to G711 for the inter-region between the trunk and IP phones. And doubling the VC bandwidth to 768 because of the way GKs work.

babatunde_sanda Tue, 03/10/2009 - 08:56
User Badges:
  • Bronze, 100 points or more

If thats the case, I already have G711 set in the trunk. I was thinking about setting it to G729 which is what I have for the inter (between) location. As for the video call bandwitdth. I might have to hold off on that cause it will require a restart of the devices in that region and I have qiute a few in there.


I will still go ahead and try changing the codec as i wanted in the trunk config just to see. Any other suggestion? Thank you.


billybjo1 Tue, 03/10/2009 - 10:22
User Badges:

I had the same problem and it was because I had B/W at 384 instead of 768 or more, GKs need double for allocation purposes. You should be able to establish this anyway by making a test call and examine the CCM trace, you will see a message about not enough bandwidth if that is the case.

babatunde_sanda Tue, 03/10/2009 - 10:33
User Badges:
  • Bronze, 100 points or more

Thanks for that info. This is where I am having some difficulty. You see the endpoints are not registered directly to CUCM. They are registered to a tandberg gatekeeper which in turn has the configured trunk to the cucm. And I will admit I have limited knowledge about this tandberg gatekeeper. I will try turning on the trace and see. Is your topology the same as mine?

billybjo1 Tue, 03/10/2009 - 10:37
User Badges:

Well if I understand your notes correctly, your problem is when making a call from a VTA (Ip Phone). If yes, then the details will be in the CM trace regardless of the GK, and that is where I would start looking. But if I was you, I would change the B/W as suggested. For the sake of a reset, it could save you a lot of time. What I tend to do is always put the trunk into its own region/device pool so resets can be made without effecting internal devices.

babatunde_sanda Tue, 03/10/2009 - 10:42
User Badges:
  • Bronze, 100 points or more

Reseting/restarting the trunk config is not the problem. I have done that severally. If you change the codec/bandwidth in the region for a location, you have to restart the the devices in that region. That is the problem.

Correct Answer
billybjo1 Tue, 03/10/2009 - 11:00
User Badges:

But if you create a location/region for the trunk, you can avoid that problem.

babatunde_sanda Tue, 03/10/2009 - 11:25
User Badges:
  • Bronze, 100 points or more

I think I get the picture. Thanks. I will update the bandwitdth and see. I am working on implementing your suggested config for the region and location.

Actions

This Discussion