MPLS LDP Neighbor problem

Unanswered Question
Feb 28th, 2009
User Badges:
  • Gold, 750 points or more

I cannot establish simple LDP session between P and PE2. LDP neighbor is up between PE1 and P router fine but not between P and PE2. when i use mpls ldp discovery, i get no route on PE2. Does anyone know what the problem is.


PE1

mpls label protocol ldp

interface Ethernet0/0

ip address 192.168.1.1 255.255.255.0

half-duplex

mpls ip



P Router


ip cef

mpls label protocol ldp


interface Ethernet0/0

ip address 192.168.1.2 255.255.255.0

half-duplex

mpls ip


interface Ethernet0/1

ip address 192.168.2.2 255.255.255.0

half-duplex

mpls ip



PE2

mpls label protocol ldp

interface Ethernet0/0

ip address 192.168.2.1 255.255.255.0

half-duplex

mpls ip


PE2#sh mpls ldp discovery

Local LDP Identifier:

192.168.2.1:0

Discovery Sources:

Interfaces:

Ethernet0/0 (ldp): xmit/recv

LDP Id: 192.168.1.2:0; no route


is MBGP needed between P and PE's? Also do i need to setup anything else between P and PE's?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.3 (3 ratings)
Loading.
mohammedmahmoud Sat, 02/28/2009 - 13:08
User Badges:
  • Green, 3000 points or more

Hi,


This is simply because the LDP ID of the P router (192.168.1.2) is not reachable on PE2 (this is what is meant by the "no route" in "LDP Id: 192.168.1.2:0; no route" from your output), this should be simply resolved after you enable a routing protocol in your network. As a recommendation always set the LDP ID manually via the "mpls ldp router-id" command in order not to leave it to the coincidence.


I hope that I've been informative.


BR,

Mohammed Mahmoud.

Harold Ritter Sat, 02/28/2009 - 13:19
User Badges:
  • Cisco Employee,

Just to add to what Mohammed is saying, it is usually consider best practice to create a loopback interface on all routers and set this loopback interface as the LDP RID.


mpls ldp router-id loopback0


Regards

francisco_1 Sat, 02/28/2009 - 15:46
User Badges:
  • Gold, 750 points or more

thanks guys.


Working now. Apart from setting up ldp neighbor relationships using LDP for label distribution across the MPLS backbone and MBGP between the PE's , What other configs is done within the MPLS backbone between PE's and P routers in a real MPLS network?



Harold Ritter Sat, 02/28/2009 - 17:28
User Badges:
  • Cisco Employee,

Francisco,


It can be really simple or really complicated but normally you would have an IGP, LDP (and/or RSVP for MPLS TE), BGP VPNv4, Route Reflectors.


In addition, you can also do label filtering to force LDP to only advertise labels for loopback interface addresses (a label is advertised for all routes except BGP routes by default) as follow.


no mpls ldp advertise-labels

mpls ldp advertise-labels for 1

!

access-list 1 permit 192.168.100.0 0.0.0.255 /* assuming all loopback interface ip addresses are in the 192.168.100.0-255 range */


Regards

Mohamed Sobair Sun, 03/01/2009 - 02:22
User Badges:
  • Gold, 750 points or more


Hi,


Absolutely you mean MP-BGP, not MBGP , The two terms has totally different meaning and concept.


The MBGP is multicast BGP used to route Multicast across domaains (Across AS).


The Multiprotocol BGP is used to carry labeled VPNv4 , Multicast, IPv6, labeled IPv6 and exended community attribute.


You dont need MP-BGP to have your LDP session activated. as denoted, its recommended to force the Loopback0 to be ur LDP session identifier and have your IGP correctly setup and MPLS enabled on that link.



HTH

Mohamed

francisco_1 Sun, 03/01/2009 - 04:19
User Badges:
  • Gold, 750 points or more

Harold,Mohammed,Mohamed,


Thanks for your imput to this discussion. I have rated your comments.


Francisco.

Actions

This Discussion