CUP7.0 and OCS 2007 RCC Issue

Unanswered Question
Feb 28th, 2009

Hi Guys,

I have integrated OCS 2007 to CUP 7.0(2)

I have MOC working okay and CUPC working with soft phone and desktop control. But after I integrated OCS to CUP, I cant do Call control from MOC to my desk phone. After I enabled tracing on MOC, the folloing erroe is what I get from OCS...

Please help. I have read through Michael's book and I must say it is really nice. I have checked everthing in the book..

ms-diagnostics: 1011;reason="Ms-Diagnostics header not provided by previous hop";source="AD2003.generis.com";Domain="cups7.generis.com";PeerServer="172.16.5.12"

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Ayodeji oladipo... Sun, 03/01/2009 - 01:36

Michael,

No, I dont have a load balancer. I am using standard edition server.

I did start a debug session in OCS, then attempted to place a call, and I saw the same error.

htluo Sun, 03/01/2009 - 07:22

If you don't have a balancer, things should be easier.

Make sure the CUPS server's IP address (it has to be IP, not DNS name) was in OCS "host authorization" tab). Restart Front End services after making changes.

In OCS debug session, you may set a filter to the MOC user's URI (such as [email protected]).

Exit and re-launch MOC. You should see some error messages in debug session.

Look at the incoming messages. See if there's anything obvious (such as "unauthorized").

If nothing obvious, search for keyword "invalid".

Michael

Ayodeji oladipo... Sun, 03/01/2009 - 09:41

Michael,

I will carry out your suggestions shortly, in the mean time this is the log I got from MOC.

The call-id is 6d036ca44e984e17be7de730b9b0c0a5

I can confirm that I am using CUPS Ip address in OCS's routing. I also noticed that there were no files in sip proxy logs when i attempted to get them.

I did notice that CUPS is not responding to invite from OCS. I get sip 2.0/480 temporarily unavailable.

htluo Sun, 03/01/2009 - 10:33

"480 temporarily unavailable" means CUPS was having problem talking to CTIManager.

Check the following:

1) On CUPS > Application > Deskphone Control > Settings, do you have the correct IP for CTIManager?

2) Does the "application username" and "password" match with CUCM?

3) Does the "application user" has "Standard CTI allow control all devices" on CUCM?

4) Can CUPS talk to CTIManager (port 2748)?

Thanks!

Michael

Ayodeji oladipo... Sun, 03/01/2009 - 10:42

Michael,

I dont why this is the problem because CUPC desktop control works just fine and I believe this has to use the CTI manager too. The only thing i noticed is that for my CUPC desktop control to work, I had to use "default_cti_tls_profile_synced 000" for my CTI gateway profile. When I used tcp, I couldnt control the desk phone. Could be this be a problem as I am using TCP protocol for OCS routing?

Ayodeji oladipo... Sun, 03/01/2009 - 11:01

Michael attached is the print screen from my OCS config and user config. Also atached is my print screen of my desktop troubleshooter which confirsm that my CUCM user name and password as well as IP are all correct

Ayodeji oladipo... Sun, 03/01/2009 - 11:03

Michael attached is the print screen from my OCS config and user config. Also atached is my print screen of my desktop troubleshooter which confirsm that my CUCM user name and password as well as IP are all correct

Yes, it does have "Standard CTI allow control of all devices and standard CTI enabled"

Attachment: 
Ayodeji oladipo... Sun, 03/01/2009 - 12:04

Michael, after almost 24 hrs of battling with MOC RCC and CUPS, I finally got it working. What I did differently, honestly I do not know. All I know is that I rebooted all the servers, CUPS and OCS and then changed from manula logging to automatic loggin and bingo ! I heard my phone ring! The feeling is great!

htluo Sun, 03/01/2009 - 12:40

Restart SIP Proxy might do the trick as well.

CUPC desk phone control was authenticated with end user credentials.

MOC desk phone control was authenticated with application credential. Whenever you make the changes on "Deskphone Control" page, you'd better restart SIP proxy to take effect.

Michael

Tommer Catlin Mon, 03/02/2009 - 08:17

After you configure your OCS server, you need to restart all services for it to work. If 5060 is not listening on the OCS server, you have to add this in AND reboot the server, or when CUPS goes to talk to OCS, OCS will not listen.

For whatever reason, rebooting of CUPS also clears up issues. Also depending on what version you are on, use the following:

7.x = 7.03 (fixes CTI issues with the latest)

6.x= 6.05

glad it works! Mikes the man!

Actions

This Discussion