priority of hsrp

Answered Question
Feb 28th, 2009
User Badges:

Hi,


I enable the HSRP on two switches. the config are


!switch1


hostname hkgw01

!

interface GE 1/0/23

switchport mode trunk

switchport trunk encapsulation dot1q

!

interface vlan10

ip address 192.168.10.1 255.255.255.0

standby 1 ip address 192.168.10.10

standby 1 priority 300

standby 1 preempt

standby 1 track GE 1/0/23 5



!switch2


hostname hkgw02

!

interface GE 1/0/23

switchport mode trunk

switchport trunk encapsulation dot1q

!

interface vlan10

ip address 192.168.10.2 255.255.255.0

standby 1 ip address 192.168.10.10

standby 1 priority 290

standby 1 preempt

standby 1 track GE 1/0/23


For normal condition, the hkgw01 is active for vlan 10. If the interface GE 1/0/23 of hkgw01 is down. the priority of hkgw01 should be 300 - 5 = 295. hkgw01 is still the active router.


I have two approaches to solve it, not sure which one is better. please advice.


first approach

- change the config of hkgw01 to "standby 1 track GE 1/0/23"


second approach

- change the config of hkgw01 to "standby 1 track GE 1/0/23 30"


rdgs



Correct Answer by Giuseppe Larosa about 8 years 5 months ago

Hello Anita,

to take advantage of tracking is enough to have a difference in HSRP priorities less then the tracking decrement.


To be noted that maximum configurable priority should be 255.


Hope to help

Giuseppe


Correct Answer by mahmoodmkl about 8 years 5 months ago

Hi


The second approach will be fine and work.


Thanks

Mahmood

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
mahmoodmkl Sat, 02/28/2009 - 21:29
User Badges:
  • Gold, 750 points or more

Hi


The second approach will be fine and work.


Thanks

Mahmood

Correct Answer
Giuseppe Larosa Sun, 03/01/2009 - 04:28
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Anita,

to take advantage of tracking is enough to have a difference in HSRP priorities less then the tracking decrement.


To be noted that maximum configurable priority should be 255.


Hope to help

Giuseppe


Actions

This Discussion