configure phone display for sip voicemail

Unanswered Question
Mar 1st, 2009

cisco 2651XM router

IOS: c2600-adventerprisek9-mz.124-15.T8.bin

sip trunk registered and working.

cisco 7940G ip phone with firmware P00308000400

my sip trunk is working fine, I can make and receive pstn calls and I can dial *123 and pick up my voicemail. But my sip provider says I should see a text a message in the phone display when there are messages waiting for me and I don't see any notification on my 7940G phone. But if I use Xlite softphone on my PC it shows a little envelope icon so I know the sip service is working ok. How do I get my 7940G to notify me of waiting messages?

thanks for any help.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Sun, 03/01/2009 - 17:48

Can you take a trace on xlite to see how the ITSP sends MWI ? There are different options to configure in CME and at least one should know what they use. Probably it's unsolicited but a trace would help anyway.

tonyspcrepairs Mon, 03/02/2009 - 06:43

thanks for your response. I ran wireshark while triggering the xlite soft phone andf the only entry I could see that might be relevant to mwi was:

(source)77.75.1.10 (dest)172.16.1.14(my pc) (protoc0l)SIP Request: NOTIFY sip:[email protected]:11718

so I can see from this they're sending the mwi from 77.75.1.10 using port 11697 to my ip address 82.68.125.106. Do I need to enter these numbers into my cli somewhere?

thanks for any further advice.

ps: how does the 7940G notify of waiting messages? Is it the light on the handet? Is it an icon in the phone display?

Steffen.Baier Mon, 03/02/2009 - 07:46

Btw: Sip Firmware 8.11 is out since Feb 2009 so that may fix your issue...

I assume you are running Sip on your 7940..?

From another fourm:

Message Waiting Indication (MWI)

Message Waiting Indication works "out-of-the-box", which is quite remarkable given the fact that the Cisco phones are not compliant with the SIP RFCs in this area. The Cisco SIP phones do not send a SUBSRIBE request to sipX in order to subscribe to MWI notify events from the Media Server. Instead they expect an unsolicited NOTIFY when the message state changes. Let me be clear: This is not in accordance with the SIP RFCs.

They mention something about Option "101" so possibly playing with your SIP_MAC.cfg and changing it to:

; Enable Message Waiting Indicator (MWI)

messages_uri: "101"

Steffen

tonyspcrepairs Mon, 03/02/2009 - 08:09

thanks for your reply but my phone is running on sccp vP00308000400, not sip. The telephony service is running on the IOS in the router.

Actions

This Discussion