dot1q encapsulation on a WS-6148

Unanswered Question
Mar 2nd, 2009

Running IOS 12.2(18)SXD6 on a 6509

Have gigabit ethernet modules 6148, and trying to trunk a port. There is no option to set encapsulation for dot1q. Apparently this is the scenario when only ISL is supported by the module. Is there a workaround/version upgrade so that dot1q is supported by this module?

thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Bobby Thekkekandam Mon, 03/02/2009 - 09:14

dot1q should definitely be supported here. Can you post some output of what you are seeing that would lead you to believe otherwise? (config for interface in question, and the output of "switchport trunk encapsulation ? )

-Bobby

jovaughan Mon, 03/02/2009 - 09:19

thanks for your reply

here is the interface config thus far

interface GigabitEthernet9/1

no ip address

switchport

switchport trunk allowed vlan 1-1005

switchport mode trunk

spanning-tree portfast disable

and output for config:

core0.ny-6509(config-if)#switchport trunk ?

allowed Set allowed VLAN characteristics when interface is in trunking mode

native Set trunking native characteristics when interface is in trunking

mode

pruning Set pruning VLAN characteristics when interface is in trunking mode

I read somewhere that there is no encapsulation option when the switch supports only ISL or dot1q. Apparently this one is ISL because the trunking is not working.

jovaughan Mon, 03/02/2009 - 09:27

Ah, apparently spanning tree is required to be enabled. Once we enabled it, it started working. We still don't have the option to specify encap, so dot1q must be the default.

Thanks

Actions

This Discussion