Corporate Directory

Unanswered Question
Mar 2nd, 2009

Hi All,

I am using CUCM 7.0. when I press corporate directory, it says "Error, Contact Administrator", I've call TAC and they said change the server name to the IP address. is there any way to fix this problem without changing the name to IP address?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
thisisshanky Mon, 03/02/2009 - 10:52


Changing name to ip addresse is recommended, unless you have DNS enabled so that phones can resolve that name of pub / sub to an ip address.

mattashton Wed, 04/29/2009 - 03:14


I am having the same problem - can you/anyone tell me if and how you resolved the issue,



Eldho E Kuriakose Wed, 04/29/2009 - 03:17

In CM administrartion page

system>enterprise parameter>URL Directories ...change the hostname to ip

also for URL Authentication and URL Services

mattashton Wed, 04/29/2009 - 05:22

Yes - I have already done the hostname to ip address change and the url is fine, any further suggestions.....?

montecotb Wed, 06/17/2009 - 06:00

Hi all,

If you look carefully on the help regarding the url on the enterprise parameters, it just concerns the model 7940/7945/7960/7965/7970. If you are using any other models, the corporate directory access is managed by an IP Phone Service. (like the missed calls, received calls, etc...)

I have facing the same issue. Which model of IP Phone are you using and what are the firmwares used?



robbie.teo Thu, 09/17/2009 - 22:10


I having the same issue too but only with 7911 model the rest no issue

virverma Thu, 09/17/2009 - 22:21

Are you using the DNS name for the CallManager or the IP address


If you have the DNS name then can you change it to the IP address?

Is this LDAP integrated?

If so please re-run the AD plug-in.

Paul Reck Sun, 11/15/2009 - 20:46

Hello all,

I recently ran into a similar problem on CUCM 7.0 with the Corporate Directory. I had everything running with IP, no DNS and the error continued "Error, Contact Administrator". I found a solution to the problem by editing the Corporate Directory URL under IP Phone Services.

I removed the Application:Cisco/CorporateDirectory and replaced it with http://X.X.X.X:8080/ccmcip/xmldirectoryinput.jsp (X.X.X.X being the IP Address of the publisher in this case)

saved, updated the subscriptions, reset the phones in case the URL was cached and it began to work.

Hope this helps anyone else out there who's still running into this.


HARISH S Wed, 12/03/2014 - 02:16

Hi Alex ,


old post .For me I faced the same issue for my 7971 Phone .From Directories Tab I was not able to use Personal Address Book and Corporate Address Book .

It gave  "Error, Contact Administrator"

I checked Enterprise Parameters and there was no DNS Reliance. 


I deleted the ITL file on the Phone and finally both Personal Address Book and Corporate Address Book started working.





This Discussion