Stop accepting further calls - mtp & transcoder

Unanswered Question
Mar 3rd, 2009
User Badges:

Hi eXpert,

I want to stop a VG3845 for maintenance but there are always calls managed because it performs mtp and trasconding services on the network.

Is there a way to tell this router to "complete" engaged phone calls but stop accepting further calls ? I don't want to tear down calls in progress and there are other redundant routers, so no problems with future calls.

Many thanks in advance

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2 (1 ratings)
Jaime Valencia Tue, 03/03/2009 - 04:44
User Badges:
  • Cisco Employee,
  • Hall of Fame,


unfortunately no, the status for the MTP and XCODER is handled by SCCP

so it's either sccp or no sccp

there's no way to tell it handle this and then stop



if this helps, please rate

_cisco4ever Tue, 03/03/2009 - 05:10
User Badges:

sure, but looking to the Dsp, is there no command to force hardware to change its behaviour only after clearing resources ? I mean, for example, if I try to set maximum session of transcoder very low, it changes immediately dropping calls or not ? So, this is only an example but I'm sure you understand what I mean, perfectly.

thank you

Nicholas Matthews Tue, 03/03/2009 - 05:50
User Badges:
  • Red, 2250 points or more

I don't think you can do this gracefully.

You can try removing the MTP from any related MRG/MRGLs, or at least placing it at the very bottom priority. This may require a reset of the MTP, however. I can't say for certainty on this.

This is what I would try:

1) Removing the MTP from the MRG and putting it in a new MRG that no device has a reference to.

2) If that requires a reset, move it to the bottom of the list and add a new MTP resource the MRG it is in.

3) Try changing the max sessions command to 1.

I know that option 2 should prevent you from resetting it. Not sure about options 1 and 3.

And no, there is no DSP level command to stop accepting new connections while servicing old ones.




This Discussion