configring Qos & ratelimiting

Unanswered Question
Mar 3rd, 2009

I have 10Mbps internet leased line and i want to split up the internet to diffenrent projects (every project will be given one public IP, which are behind router).

If i configure ratelimiting or traffic shaping commands i can not fully utilize the bandwidth. If one project is not utilising the bandwidth then other project should use that bandwidth.

I am not able to decide in which way i configure bandwidth management.

can anybody suggest me.

thanks in advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joseph W. Doherty Tue, 03/03/2009 - 03:32

On your router, you can use CBWFQ, outbound, to proportion bandwidth to each project a minimum share of bandwidth. Any bandwidth not being used will be allocated to other projects' bandwidth.

e.g.

policy-map CBWFQ

class project1

bandwidth percent 20

class project2

bandwidth percent 5

.

.

For inbound, you can do the same if you control the far side of the WAN link. If you don't, and the ISP won't cooperate, there's little you can do.

Inbound downsteam rate limiting will often still allow the upsteam WAN link to be come congested although with TCP traffic, TCP will slow itself as it sees drops. Inbound downsteam traffic shaping is even worst in this situation in that TCP inbound stream will only see the drops when there's much inbound congestion.

For TCP, you can shape outbound ACKs, but this too is very inexact.

Otherwise, if most of your traffic is TCP, your best option would be a 3rd party appliance that can spoof a receiver's TCP receive window size.

psureshrao Tue, 03/03/2009 - 07:32

I am concentrating on the outbound traffic only, i dont care about the incoming traffic (which is coming from ISP).

If i dont mention the outside IP's in access-list of classmap, outside packets will not be matched and they can use my total available bandwidth! am i right?

I have small doubt here.

If project1 is having reserved 5 mbps and project2 is reserved for 2 mbps and project2 is utilising some bandwidth of project1 and suddenly project1 utilisation is getting higher, then what exactly happens. will it reset the queue of projct1 based on classmap or will it wait project2 queue to be finished.

anyway thanks for the reply.

I will check out this option let you the status.

Joseph W. Doherty Tue, 03/03/2009 - 09:26

"If i dont mention the outside IP's in access-list of classmap, outside packets will not be matched and they can use my total available bandwidth! am i right?"

Unclear (to me) what you're asking.

"If project1 is having reserved 5 mbps and project2 is reserved for 2 mbps and project2 is utilising some bandwidth of project1 and suddenly project1 utilisation is getting higher, then what exactly happens. will it reset the queue of projct1 based on classmap or will it wait project2 queue to be finished. "

Project1 will take back bandwidth from project2 but project2 should still be able to obtain at least its 2 Mbps.

For instance, if only project2 was active, it could use all 10 Mbps. If project1 then becomes active, and it could use all 10 Mbps too, the 10 Mbps should be split in the ratio 5:2. (I.e. both could get a bit more than their minumums.)

psureshrao Thu, 03/05/2009 - 01:43

I mean, i simply give service policy for output packets on my wan interface.

I am going to configure like this:

policymap bandwidth

classmap project1

bandwidth percent 50

match access-group 100

classmap project2

bandwidth percent 20

match access-group 101

classmap project3

bandwidth percent 30

match access-group 102

Is that Ok

Joseph W. Doherty Thu, 03/05/2009 - 04:21

Syntax is off. Also, when using defined percentages, you can only sum to max-reserved (normally 75%). Remaining percent allows summing to 100.

This might be a bit closer.

class-map project1 match-any

match access-group 101

class-map project2 match-any

match access-group 102

class-map project3 match-any

match access-group 103

policy-map bandwidth

class project1

bandwidth remaining percent 50

class project2

bandwidth remaining percent 20

class project3

bandwidth remaining percent 30

interface Ethernet1

service-policy output bandwidth

PS:

BTW: There's always a class-default, even when not explicitly defined. As long as your defined classes match most of the traffic, it shouldn't be an issue.

Also using numbered ACLs is fine but I prefer to use named ACLs. Makes it easy to relate them.

e.g.

class-map project1 match-any

match access-group project1

Actions

This Discussion