IPM keeps on failing to create collectors ("Config Failed")

Unanswered Question
Mar 3rd, 2009

Hello,

we are trying to setup IPM collectors which always fails with the status "Config Failed". We tried different combinations of operations and different source/target devices. Always with the same result. Not one collector could be configured successfully until now.

From the devices list, all of our currently managed devices are selectable, IOS versions used are for example:

WS-C3550 12.2(25)SEE2

CISCO3725 12.4(15)T5

These devices I validated to have ip sla enabled by checking the output of the commands "show rtr application" / "show ip sla application".

In the logfile IPMProcess.log I keep finding the following SnmpResponseNoAccess error message:

========================================

[ Tue Mar 03 10:23:10 CET 2009 ],ERROR,[STL-test3_<DEVICENAME>_DefaultIpEcho],com.cisco.nm.ipmng.collectormgr.state.ConfigureCollector,executeRequest,119,Unknown error when trying to configure the collector test3_<DEVICENAME>_DefaultIpEcho

[ Tue Mar 03 10:35:46 CET 2009 ],ERROR,[STL-test4_<DEVICENAME>_DefaultIpEcho],com.cisco.nm.ipmng.dal.SnmpDeviceAccess,setInDevice,712,Error during snmp-set to <IPADDRESS>com.cisco.nm.lib.snmp.lib.SnmpException: SnmpResponseNoAccess on <IPADDRESS> while performing SnmpSet at index = 0

at com.cisco.nm.lib.snmp.futureapi.SnmpFuture.value(SnmpFuture.java:195)

at com.cisco.nm.ipmng.dal.SnmpDeviceAccess.setInDevice(SnmpDeviceAccess.java:681)

at com.cisco.nm.ipmng.dal.SnmpDeviceAccess.configureInDevice(SnmpDeviceAccess.java:945)

at com.cisco.nm.ipmng.dal.SnmpDeviceAccess.set(SnmpDeviceAccess.java:2170)

at com.cisco.nm.ipmng.dal.DeviceAccess.set(DeviceAccess.java:216)

at com.cisco.nm.ipmng.dal.DeviceAccess.set(DeviceAccess.java:223)

at com.cisco.nm.ipmng.collectormgr.state.ConfigureCollector.executeRequest(ConfigureCollector.java:92)

at com.cisco.nm.ipmng.stl.RequestStatus.executeRequest(RequestStatus.java:55)

at com.cisco.nm.ipmng.util.Task.run(Task.java:51)

at java.lang.Thread.run(Thread.java:595)

========================================

(I replaced names and ip addresses with <DEVICENAME> and <IPADDRESS>)

We use SNMPv3, and within other applications of LMS there are no problems with the devices.

Can someone point me to what the cause for this might be?

Thank you!

Regards,

Andreas

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
a.foerster Tue, 03/03/2009 - 08:37

We found the problem: We didn't configure the right SNMP view on the devices.

Actions

This Discussion