Cisco 7941 firmware doesn't load

Unanswered Question
Mar 3rd, 2009


I had an issue with Cisco 7941 (CUCM 6.1) and got the advice to upgrade the firmware to the latest one.

I installed the new firmware on the CUCM and restarted the Cisco TFTP server. I resetted the Device Pool but the phones didn't load the new firmware.

I performed the following steps:

1) Reset the phone manually to factory defaults, but it didn't load the new firmware.

2) Under Device Default, I can see the new firmware but the phone doesn't load it.

3) I typed the name of new firmware under firmware load information field on the phone, but it didn't help either.

I hope someone can guide me to solve this issue. I restarted the CUCM twice but all in vain.




I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
mightyking Tue, 03/03/2009 - 12:20


Try the following procudre which removes all existing config including any old firmware from the phone and upgrades to the latest available version provided by your 6.1 CUCM.

1)Unplug the cable from the phone

2)Hold the # key and replug the cable back

3)Do not release the # key and hold it for about 10-15 seconds

4)Wait until the lines start flashing

5)As soon as the lines flash, release the # key and dial the following digits using the phone keypad (1,2,3,4,5,6,7,8,9,*,0,# in the order. You have 10 seconds to dial all digits. If you fail to dial within 10 seconds, you may need to start over.

This a factory reset and it does the magic. The phone releases the old firmware and downloads the new one.

The upgrade procedure may take up to 5-7 minutes for each phone.

Good luck


ysanadiga01 Tue, 03/03/2009 - 12:30

Hi MK,

Thanks for your reply.

>>> 1) Reset the phone manually to factory defaults, but it didn't load the new firmware.

I already did that but it didn't help.



ysanadiga01 Tue, 03/03/2009 - 13:15

Old firmware: SCCP41.8-3-4SR1S

New firmware: SCCP41.8-4-3S

I also tried upgrading to the following firmware but didn't work either:



mightyking Tue, 03/03/2009 - 13:42

Is this the file that you're trying to upgrade to?


rob.huffman Wed, 03/04/2009 - 06:10

Hi Sana,

Just to add a note to the great tips from MK.

Can you please try again using this procedure. Make sure that you verifiy Step - check MD5 Checksum;

When using Cisco Unified CallManager Release 5.0 or later

For Cisco Unified CallManager 5.0, you must do all software installations and upgrades by using the Software Upgrades menu options. The system can upload and process only software that Cisco Systems approved. You cannot install or use third-party or Windows-based software applications that you may have been using with a previous version of Cisco Unified CallManager with Cisco Unified CallManager 5.0.

Using your web browser, login to the Cisco IPT Platform Administration web page

Under the Software Upgrades menu, select Install/Upgrade.

Fill in the appropriate values in the Software Location section for the file you downloaded above, and click Next.

In the Available Software drop-down box, select the file you downloaded above, and click Next.

After validating the MD5 has the correct value, click Next.

In the Warning box, verify you have selected the correct firmware, then click Install.

Check that you received a Success message.


This is the path, via Software Downloads;

Voice and Unified Communications > Cisco Unified IP Phone 7941G > Skinny Client Control Protocol (SCCP) Software > 8.4(3)


Hope this helps!


PS: If done properly, you shouldn't need to factory default any phones.

ysanadiga01 Wed, 03/04/2009 - 12:12

Hi Rob,

Thanks for your reply.

I've done a number of firmware upgrades but this is the only time that I'm having this issue.

If it was only one device then I would have said that may it's due to hardware defect, but all the 25 devices can't load the new firmware.



pavelsh_ucs Wed, 08/12/2009 - 08:52


I have the same issues. 30 phones with this bug

Did you solve your problem?


Paolo Bevilacqua Wed, 08/12/2009 - 11:04

When "unsolvable" problems are met, Cisco TAC must be involved.

It is their job to determine if user actions are incorrect, or there is a bug.

pavelsh_ucs Wed, 08/12/2009 - 11:09

Cisco TAC said:

1. Restart tftp server. (For what?) Done. Not solved

2. Update firmware files on cucm (For what?) Done. Not solved.

3. Write out cucm version. Write - Not solved.

That's all. I don't get any response from him.

I have a broken phones. I think I will RMA it.


This Discussion