Trunk port in "err-disable state"

Unanswered Question
Mar 3rd, 2009


In a remote office I have a 3650 and from it's 0/24 port there is a trunk to a Nortel switch. The Nortel switch has no managment (just out of the box). Anyway from time to time the trunk will shutdown and get this error:

sh log | inc 0/24

1w6d: %PM-4-ERR_DISABLE: loopback error detected on Fa0/24, putting Fa0/24 in err-disable state

Somebody suggested the possible reasons can be a link flapping, UDLD just to mention twom but these mean nothing to me :)

Any ideas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Edison Ortiz Tue, 03/03/2009 - 12:42

The message means the switch saw its own keepalive coming via a different port. This is a sign that multiple ports from the 3560 are connected to the Nortel switch.

Since this switch has no management, I recommend plugging just one port from the 3560 to the Nortel switch in order to avoid any loops.

See the explanation on this link regarding 'loopback error'




whiteford Tue, 03/03/2009 - 13:04

Thanks, but if I do a show ip int bri, the 3650 only shows 0/1 and 0/24 as up, 0/1 is the WAN port and 24 the trunk.

Leo Laohoo Tue, 03/03/2009 - 13:09

Try "sh interface 0/24 status" or "sh interface status err-disabled".

Edison Ortiz Tue, 03/03/2009 - 13:10

You can disable keepalives on the port connected to the Nortel switch.

You need to upgrade to 12.2SE in the 3560 switch.


This Discussion