SPA941 - DST not working

Unanswered Question
Mar 3rd, 2009

Hi,

I have a SPA941 running with the latest firmware 5.1.8. DST is not working. Time is one hour behind. This was also a problem with the SPA-9x2 phones before and was corrected with a new firmware. Is there a fix for this?

Regards,

Ryan

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Alberto Montilla Wed, 03/04/2009 - 03:21

Hi Ryan;

No need for new firmware, just change the DST rule to:

start=3/2/7;end=11/1/7;save=1

Regards;
Alberto

ryan-glenn Wed, 03/04/2009 - 14:36

Hi Alberto,

Daylight Saving Time Rule for my SPA941 is start=10/-1/7;end=3/-1/7;save=1

I'm in Australia so DST starts on Oct and ends March.

I even tried start=10/5/0/2;end=4/5/0/3;save=1 to specify the exact starting date and end date. Both parameters does not work as the time is still one hour behind. We have similar issues with DST before on SPA922, 942, and 962 and was corrected on the 5.2.8 firmware.

Regards,

Ryan

Patrick Born Thu, 03/05/2009 - 15:51

Hi Ryan,

The bug that was fixed in the SPA9x2 phones was related to the fact that the southern hemisphere uses opposite start and end dates to the northern hemisphere.

The work around is to use a start date of March and an end date of October and then save=-1 [save equals minus 1]

The following should do the trick :

start=3/2/7;end=11/1/7;save=-1

Please let me know if this works for you.

Regards,

Patrick

-----------

ryan-glenn Thu, 03/05/2009 - 17:12

Hi Patrick,

I tried that one but it does not fix the DST. Time is still 1 hour behind.

Regards,

Ryan

Patrick Born Fri, 03/06/2009 - 08:53

Hi Ryan,

The setting of: start=3/2/7;end=11/1/7;save=-1 will  become effective on the 3rd month, after the 2nd, on a Sunday.

So on Sunday March 8th, the phone will be running the new time.

Regards,

Patrick

-----------

ryan-glenn Sun, 03/08/2009 - 18:31

Hi Patrick,

I tried that setting "start=3/2/7;end=11/1/7;save=-1" and time is now showing 2 hours behind. It does not fix the problem.

Regards,

Ryan

Patrick Born Mon, 03/09/2009 - 09:29

Hi Ryan,

It feels like we're going in circles, I apologize.

I configured a SPA941 in my lab and loaded it with 5.1.8.

I configured the Primary NTP Server using the NTP server that you use in the configuration that you shared with me.

My time was off by 1 hour, we moved to DST yesterday.

I modified the DST to what Alberto originally suggested: start=3/2/7;end=11/1/7;save=1

This change made the SPA941 display the correct DST time.

I looked through your configuration and see that you use GMT+10, somewhere east Australia, I guess.

I changed my phone to GMT+10 and it says the time is tomorrow 3:19 AM.

I searched for the time in east Australia, it's currently 3:19 AM March 2009.

This makes me want to say that all is well with the NTP server, and the phone's configuration.

So, in order to better help you, please tell me:

1. What is the goal of your testing?

2. How exactly are you testing? [lots of detail is better]

I'll replicate your testing and help you reach a solution.

Regards,

Patrick

-----------

ryan-glenn Mon, 03/09/2009 - 15:48

Hi Patrick,

On your previous post-

>The setting of: *start=3/2/7;end=11/1/7;save=-1* will  become effective on the 3rd month, after the 2nd, on a Sunday. So on Sunday March 8th, the phone will be running the new time.

This setting (save=-1) shows the time 2 hours behind. When I change the setting to (save=1), it's now displaying the correct time. This setting start=3/2/7;end=11/1/7;save=1 will only take effect on March and will End in November. Our DST here in Australia started last year Oct 2008 (not this March) and will end in March 2009 so this setting is not applicable to us. When I use the correct setting start=10/-1/7;end=3/-1/7;save=1 it does not work. It seems like the phone is not liking DST setting that starts on the current year and ends on the following year. What we want to achieve is for DST to work on our SPA941. We would like the SPA941 to display the correct DST on Oct of the current year to March of the following year like our SPA 9x2 phones.

Hope this clear things out.

Regards,

Ryan

igormrbean Tue, 03/10/2009 - 08:05

Same here

SPA941 using firmware 5.1.8

We are in Eastern timezone (-5EST) New-York.

So the timezone is set to -5

Now, in summer, we need to set time to +1 (-4)

My phone stills shows -5

NTP is setup are working

Marc

Moderator Wed, 03/11/2009 - 08:06

Hi Marc,

Did you try any of the recommendations shown above? If they didn't work, please let us know.

Thank you,

Cisco Moderation Team

ryan-glenn Wed, 03/11/2009 - 16:13

Hi Patrick,

I think i found a work around on the SPA941 DST.

The rule in Australia (Syd) should be start=10/-1/7;end=3/-1/7;save=1but this does not work.

I tried inverting it to start=3/-1/7;end=10/-1/7;save=-1 but need to set GMT+11 (one hour offset added, instead of what should be here GMT+10)

Regards,

Ryan

Moderator Thu, 03/12/2009 - 09:57

We are currently testing this issue in our lab to get you a solution. We'll get back to you as soon as possible.

Thanks for you patience,

Cisco Moderation Team

Patrick Born Thu, 03/12/2009 - 14:05

Hi Ryan,

Very resourceful solution. Thanks for sharing. Hopefully I'll be able to offer something shortly.

Regards,

Patrick

-----------

Patrick Born Fri, 03/13/2009 - 11:17

Hi Ryan and Marc,

I configured a private NTP server in my lab, ran a sniffer on the network, manually manipulated ntpd's time, restarted ntpd, and rebooted the SPA941 [many, many times]

Engineering are going to review the SPA9x1's DST code.

I'll let you know when a fix is available or the status changes.

Regards,

Patrick

----------

Patrick Born Mon, 03/16/2009 - 07:42

Here's the official work-around:

There are three parts to the work-around:

1. Increase the phone's timezone by one. Example, if your phone is normally GMT+10:00, change to GMT+11:00

2. Use the following Daylight Saving Time Rule on the phone: start=3/1/7/2:00;end=10/1/7/2:00;save=-1
     This will cause the phone to be one hour ahead during summer in the southern hemisphere, October to March.
     The phone time is adjusted during winter in the southern hemisphere, March to October, with the save=-1

3. Disable automatic provisioning by the SPA9000 else custom DST rule and time zone will be overwritten by the SPA9000: https://www.myciscocommunity.com/docs/DOC-4777

Please let me know if this works for you.

Regards,

Patrick

-----------

igormrbean Mon, 03/16/2009 - 08:11

Hi Patrick,

Thanks for the update.

I'll try this workaround.  Is this gonna be fixed anyway in future firmware update ?

Marc

Patrick Born Mon, 03/16/2009 - 13:40

Marc,

I checked with the product manager and he is evaluating the issue. At this time I do not know if/when a fix will be available. I will report back as soon as I have new information.

Regards,

Patrick

-----------

Patrick Born Thu, 03/12/2009 - 14:03

Marc,

I have configured a "private" NTP server in my lab and am testing settings and will report back as soon as I have something useful.

I appreciate you letting me know that you have a DST problem with your phone.

Regards,

Patrick

----------

Actions

This Discussion