hostnames or DNS names in DCR

Unanswered Question
Mar 4th, 2009

Hello,

I have installed LMS 3.1. I provided device discovery using CDP. I have the following settings for device discovery: Preferred DCR display name - hostname and Preffered Management IP - Resolve by Name. But in the DCR I only see the IP adddresses of these devices not their hostnames or DNS names:-( I have configured two DNS addresses in Windows network card settings. How I can change the display name automatically for all devices? I know that I can use CS-Device and Credentials - Device Management, but it is for manually changing and it has to be done one device per time. Thank you.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Wed, 03/04/2009 - 20:16

You first need to make sure the Java can properly resolve the devices' IP addresses to hostnames. Take the IP addresses showing in DCR, and run nslookup on them. Make sure they resolve to a hostname. Then, run nslookup on that hostname, and make sure it resolves.

Admittedly, this is not the best way of doing this test. There is a tool that ships with LMS called resolver.pl, but due to a bug, it does not properly resolve IPs to hostnames.

Once you're absolutely sure that the IPs are correctly resolving to hostnames, then run a new Discovery. If you have chosen the option to update the DCR display names, then that should happen for you automatically.

ROMAN TOMASEK Wed, 03/04/2009 - 20:26

Hi,

from which application I have to provide nslookup test?? From cmd in Windows or from java console?? Thank you.

I thought that java is not used for device discovery in LMS 3.1.

Joe Clarke Wed, 03/04/2009 - 20:28

From the Windows server's DOS prompt. Practically all of LMS is written in Java. It's mostly executed on the server side.

ROMAN TOMASEK Fri, 03/13/2009 - 07:47

Hello, I'm sorry for my delay. I tried to use nslookup for test of transaltion between IP addresses and device names. For some devices this test was successful, for some devices this test was failed:-( See Attachment. I tried to use discovery again, but I see only IP addresses for all devices, not hostnames or DNS names in device list:-( Thanks

Attachment: 
Joe Clarke Fri, 03/13/2009 - 08:49

Try adding one device to C:\WINDOWS\system32\drivers\etc\hosts, and see if the resolution works correctly with Discovery then. The DNS timeout may be tripping up Discovery.

mohd_ghalib Mon, 03/16/2009 - 02:06

Hi jclarke, I am also facing the same problem here. But what I can see is that in Device Fault Manager the ip addresses of the devices are resolved and host names are displayed properly, while it does not display in other applications like RME. Could you advice why this happens and how can I get this rectified. The LMS Version I use is 3.0.

Also I have another issue with my application which started appearing today. I cannot execute any jobs. It throws an error message "JRM Service could be down. Check whether JRM services are running" This appears in all the applications like RME, CM and Common Services.

When checked in "Common Services -> Server -> Admin -> Processes it shows JRM is running normally. Tried restarting the service, and also stopped and restarted all the Ciscoworks Services from Windows services.msc

but no luck.

The Java I have installed in the server is Sun Java Version 6.0.110

I checked the status from the command line and the below output I got.

E:\>cwjava -cw E:\Progra~1\CSCOpx com.cisco.nm.cmf.jrm.jobcli

org.omg.CORBA.OBJECT_NOT_EXIST:

Could not locate the following Object:

repository id : IDL:jrm/JrmServiceManager:1.0

object name : JrmServiceManager_ciscoworks

host name : ciscoworks

vmcid: 0x0 minor code: 0 completed: No

Could you please help with this? Thanks in advance!!

Attachment: 
mohd_ghalib Mon, 03/16/2009 - 23:36

sure..I will start a new thread for the services issue. But could you help me with the DNS part? As I said I can see the hostnames are resolved in DFM, but when I check the DCR device list directly or from other applications the IP address is not getting resolved and in the hostname field also IP is displayed. The version detail of the ciscoworks I use is as below:

LMS3.0

DFM3.0

RME4.1

Joe Clarke Tue, 03/17/2009 - 09:08

This thread was started by a different user. Please start your own threads for your issues.

Actions

This Discussion