Load sharing/loadbalencing ADSL links

Unanswered Question
Mar 5th, 2009
User Badges:

Hi all

I have a internet router with 4 ADSL ports.Is there any method or seperate device to load balance or load share between these links.Thanks in advance.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Giuseppe Larosa Thu, 03/05/2009 - 14:10
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Anvar,

the routing part is relative easy:


four default static routes make the job


ip route 0.0.0.0 0.0.0.0 dialer1

ip route 0.0.0.0 0.0.0.0 dialer2

ip route 0.0.0.0 0.0.0.0 dialer3

ip route 0.0.0.0 0.0.0.0 dialer4


the most difficult part is to use NAT:

when accessing the internet private ip addresses need to be translated


given a 19268.10.0/24 internal lan you can use route-map based NAT


int fas0/0

ip nat inside


int dialer 1-4

ip nat outside


you can map 1/4 of hosts on each link


route-map nat-link1 permit 10

match ip address 1

set interface dialer1


route-map nat-link2 permit 10

match ip address 2

set interface dialer2


and son


where

access-list 1 permit 192.168.10.0 0.0.0.63

access-list 2 permit 192.168.10.64 0.0.0.63

access-list 3 permit 192.168.10.128 0.0.0.63

access-list 4 permit 192.168.110.192 0.0.0.63


ip nat inside source route-map nat-link1 interface dialer1 overload

ip nat inside source route-map nat-link2 interface dialer2 overload

ip nat inside source route-map nat-link3 interface dialer3 overload

ip nat inside source route-map nat-link4 interface dialer4 overload


Hope to help

Giuseppe


anva12345 Fri, 03/06/2009 - 00:02
User Badges:

Thanks very much Giuslar for the quick response.is it possible to bundle these links together and act as a single link


Giuseppe Larosa Fri, 03/06/2009 - 05:06
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Anvar,


>> is it possible to bundle these links together and act as a single link


yes with multilink PPP over ATM but all DSL links must be from a single provider and you need to work with them to make it working


see


http://www.cisco.com/en/US/docs/ios/qos/configuration/guide/mlppp_over_dial.html


Hope to help

Giuseppe


anva12345 Fri, 03/06/2009 - 11:24
User Badges:

Thanks Guiseppe for the link.


In the first case(witout multilink) is it possible to configure in such a way that even if one DSL link fails corresponding network be routed thru another ADSL link

adamclarkuk_2 Fri, 03/06/2009 - 11:29
User Badges:
  • Silver, 250 points or more

Hi


As you have used the interface in the 'ip route' statement, when the interface goes down, the route will disappear from the routing table giving you what you have asked for.

anva12345 Fri, 03/06/2009 - 11:38
User Badges:

Hi adamclarkuk

But each network is PATed to only one dialer interface and in the route map for this network destination is one dialer interface.In this scenario this will work?please clarify.

adamclarkuk_2 Fri, 03/06/2009 - 11:48
User Badges:
  • Silver, 250 points or more

Your right, I missed the route-maps in the config example. hmmmm, then I am not sure.

Giuseppe Larosa Fri, 03/06/2009 - 13:18
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Anvar,

very good note:

the solution I proposed needs to be tuned to achieve fault tolerance (if possible).


I have to think about it.


Hope to help

Giuseppe


Actions

This Discussion