SPA900 Caller ID problems

Unanswered Question
Mar 6th, 2009
User Badges:

I have a SPA9000, SPA 400 configured with 4 handsets and sip account. The software version of the SPA9000 is 6.1.5 and of the SPA400. The firmware version of the SPA 400 is 1.1.2.2


I'm very happy with call quality etc having spent some time tweaking the settings. The problem I'm having is caller ID. Having received various settings from the reseller, the caller ID now works occasionally - approximately about 1 in 7 times.


Does anyone have any suggestions on how to improve this further. I located in Ireland


Thanks

Michael

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Patrick Born Fri, 03/06/2009 - 13:10
User Badges:
  • Cisco Employee,

Hi Michael,


I am aware of the problems you're experiencing with Caller ID in Ireland. We're actively working on the issue.

Please contact me at paborn at Cisco.com so that I can work closer with you.


Regards,



Patrick

----------

Patrick Born Tue, 04/07/2009 - 06:58
User Badges:
  • Cisco Employee,

Michael,


We've been working on the caller id issue in the background with Cisco Ireland.

I now have new firmware that resolves the caller id problem in Ireland and will send you the firmware for testing.


I appreciate your patience and apologize that the fix has taken so long.


Regards,



Patrick

----------

1090badger Tue, 04/07/2009 - 07:38
User Badges:

Thanks Patrick,


I know that these problems can take a while to resolve. Its great that you have put in the time and got to the bottom of it. I have upgraded the firmware that you sent and so far so good, it all seems to be working perfectly.


Thanks,


Michael.

Patrick Born Tue, 04/07/2009 - 07:49
User Badges:
  • Cisco Employee,

Michael,


You just made my day. Thanks for letting me know that your caller id is now functional.


Regards,



Patrick

-----------


Hi,


I apologize if I interferes but I have the same problem with CallerID,

but from Italy. I have 3 spa-system configured and updated (SPA400 1.1.2.2 SPA9000 6.1.5 SPA941 5.1.8 spa942 6.1.5a) connect to

telecom italia analog line and CallerID don't work. Do you have a

modified firmware for my problems?.


Thanks for Support

Thomas



Patrick Born Tue, 04/14/2009 - 09:13
User Badges:
  • Cisco Employee,

Hi Thomas,


I'm aware of SPA400 caller id problems in Italy. We're currently actively working on resolving this.

Please contact me at paborn at Cisco.com so I can work closer with you.


Regards,



Patrick

----------

Patrick Born Thu, 04/23/2009 - 14:48
User Badges:
  • Cisco Employee,

Hi Paolo,


We're actively working on identifying the root cause of caller id issues in Italy. I will contact you as soon as I am able to share a firmware update with you.


Regards,



Patrick

----------

Patrick Born Fri, 04/24/2009 - 09:29
User Badges:
  • Cisco Employee,

Update for the community:


I've sent Paolo test firmware and instructions for installing on the SPA400.

Paolo will install and test as his schedule permits.


Regards,



Patrick

----------

Patrick Born Fri, 04/24/2009 - 11:21
User Badges:
  • Cisco Employee,

Hi Thomas,


Thanks for the offer. I've sent you some test firmware and instructions.


Please let me know of any progress.


Regards,



Patrick

-----------

matitti2000 Wed, 05/13/2009 - 03:46
User Badges:

Hello, Patrick


Can I Test the beta firmware in my structure


Regards,


Massimiliano

Patrick Born Wed, 05/13/2009 - 04:23
User Badges:
  • Cisco Employee,

Hi Massimiliano,


Please contact me at paborn at Cisco.com so we can determine if it is appropriate.


Regards,



Patrick

-----------

I've found a working solutions for me (italy, telecom).


Without the new beta firmware this is the setting I've mod:


From SPA400:


TAB Setup ==> Voice ==> Set "Caller ID/CP Tone Method" to North American From


SPA9000:


TAB Voice ==> Regional  ==> Miscellaneous ==> Set "Caller ID Method" to Bellcore


TAB Voice ==> Regional  ==> Miscellaneous ==> "Caller ID FSK Standard" to V.23


Good luck to all.

Patrick Born Wed, 05/13/2009 - 06:07
User Badges:
  • Cisco Employee,

Hi Paolo,


Great news. Thanks for sharing your success with the community.


It would be great if you could capture and share a screen shot of the relevant pages that you modified. This way others who search on SPA400 Italy caller id will locate your success story.


Regards,



Patrick

-----------

Hi,


in my system new beta firmware work ok and caller id are ok in 2 systems:


N.1 spa9000 + 4 x spa941 + 2 x spa400 (one analog line in ISDN NT1 Plus from Telecom Italia and one in GSM adapter)


N.2 spa900 + 4x spa942 + 1 x spa400 in PSTN line from telecom italia.


if i configure with bellcore work only via GSM adapter and PSTN line not analog line of ISDN NT1 Plus.


bye

Thomas

matitti2000 Wed, 05/13/2009 - 10:30
User Badges:

Ok Paolo


Thank you for settings, whit North American (default) it's Ok,


but in


Call progress tone detection


Repeat count is 1 for me and not 2


Thanks


Bye

The call progress tone detection is only for:

"The number of times that the cadence needs to repeat to be considered as a valid CP tone" (from the manual)

I think isn't a significant value for the caller id but only for the detection of a valid tone or not.


Now the base functionality is ok, but with my caller id setting when an incoming call arrive I see on display:


If the caller isn't in the Personal Directory:

No Name - "Name of Port ID 1"(in my case "ISDN_1") - caller number


If is in Personal Directory:

"Name" (saved in Personal Directory) - caller number


Is the same for you?


Thanks

I think can work, but before I'll wait for an explain from Patrick (if he can) to the available options:


- PAID

- RPID

- FROM


All phones are in a production enviroment and I can't make test everytime I want.


The only thing I've found about Caller ID header (from manual) is:

"Provides the option to take the caller ID from PAID-RPIDFROM, P-ASSERTEDIDENTITY, REMOTE-PARTY-ID, or FROM header."




And on an unofficial forum I've found:

"Caller ID Header responsible for Caller Id source"


With this little information I think the caller id header cannot work to mod the information visualization on the phone.


Regards

Patrick Born Tue, 05/19/2009 - 08:52
User Badges:
  • Cisco Employee,

Hi Paolo,


"ISDN_1" can be changed to whatever you prefer: SPA400 web-ui > Setup tab > SPA9000 Interface tab > Port ID > Port ID N: [replace ISDN_1 with 7775551212 or anything you'd prefer]


Regards,



Patrick

----------

I've set up ISDN_1 on the Port ID 1, i need this setting, but only in case of malfunctions on phone line.

Every port ID have a description with the attached line, I've not to troble and loose time in case of problems.


The only thing I need is not view ISDN_1 on phones display, but this isn't an important setting.


If isn't possible remove it is better, if no it's ok too.


Regards

Paolo

sistemia.com Tue, 06/09/2009 - 11:25
User Badges:

Hi Patrick,


I've the same problem in Italy with a N°1 SPA9000 [fw 6.1.5] + N°1 SPA400 [fw 1.1.1.2] (Line 1&2 in ISDN NT1 plus TELECOM) + N°1 SPA942 + N°1 WIP330.

In this environment the Paolo's workaround solution is not working for me. The Call ID is missing (anonymous call)

Can you send me the beta fw to try to solve the issue ?


Thank you for attention.


Fabio.

Patrick Born Tue, 06/09/2009 - 14:42
User Badges:
  • Cisco Employee,

Hi Fabio,


The updated firmware for the SPA400 is currently undergoing regression testing. Provided the firmware passes all tests, it should be available as version 1.1.2.3 by June 19, 2009.


Regards,



Patrick

-----------

dcdataciscologin Wed, 09/02/2009 - 01:48
User Badges:

Hi Patrick,


Im using the SPA400 with 4 GSM analogue gateways and connecting to an Asterisk based system, Im using Elastix.

I have the caller ID problem which I think has been discussed previously. Incoming calls show the caller ID name on the Snom phones and not the Caller ID number. I have overcome this by configuring a module in FreePBX called "Set Caller ID" which basically blanks the Caller ID name and overwrites it with the Caller ID number. ${CALLERID(num)}


This is what it looks like in the Asterisk log

"Changing Callerid from "No Name - FXO_Port_ID_2" <083*******> to CALLERID(name): | CALLERID(num)



I had a look at your document, https://www.myciscocommunity.com/docs/DOC-7414 , Im in South Africa so I set the caller ID method to European FSK which stops caller ID from working. Mine works fine if I leave it on North America. Im using Firmware 1.1.2.2 , I wasnt sure if the documented settings would only work for 1.1.2.3 Is there a release date for 1.1.2.3 as Im a bit nervous about using the Beta release you posted previously on a production system.


I have another issue which is on outgoing calls. To hide the caller ID on the GSM Premicells you can prefix the number with #31#, this works fine if I connect an analogue phone directly to the Premicell. When I try do this through the Asterisk and SPA 400 its not working. I can see in Asterisk that it is actually dialling #31#NUMBER but it just gets an engaged tone, Asterisk is not generating this behaviour.

[Sep  2 09:53:39] VERBOSE[19953] logger.c:     -- Called spa400p1/L1#31#082*******


I can only presume that the SPA400 is trying to intepret the #31# as something else. Do you think the SPA400 would be trying to inteprit the #31# as something else and is there a way to disable it. I have attached my current settings.

Patrick Born Wed, 09/02/2009 - 05:17
User Badges:
  • Cisco Employee,

Hi dcdataciscologin,


I wasnt sure if the documented settings would only work for 1.1.2.3 Is there a release date for 1.1.2.3 as Im a bit nervous about using the Beta release you posted previously on a production system.

The documented settings should work with the current 1.1.2.2 and should also work with future releases. I don't have a release date for 1.1.2.3 yet.


Do you think the SPA400 would be trying to inteprit the #31# as something else and is there a way to disable it.

The SPA400 could well be trying to interpret #31# as something else. We use # in all of our devices to indicate the end of a dial pattern in order to trip any dial-timers that are running.


The main problem is that the SPA400 was designed to work with the SPA9000. We didn't expect anyone to want to use it with any other type of call-control.


We have since designed the SPA2102, SPA3102, SPA8000, and now the SPA8800 to work with any call-control. You'd have more success using the SPA8800 instead of the SPA400.

Here's an Application Note on deploying the SPA8800 with Asterisk: https://www.myciscocommunity.com/docs/DOC-7654


I wish I had a better answer for you, I know it's frustrating to have a product and then discover that a more suited product is available.


Regards,



Patrick

----------

biggles69 Sun, 03/07/2010 - 12:44
User Badges:

Has anybody been able to get the SPA9000 & SPA400 working with caller ID in the UK?


If so, can anyone provide settings that work for both devices. I cannot get it to work even with the beta firmware on the SPA400, my line is an NTL line.


Thanks,


Adam

mdolimont Mon, 03/08/2010 - 06:57
User Badges:
cvaccari Wed, 03/10/2010 - 08:47
User Badges:

Hi Paolo,

I tested the beta firmware (1.1.2.3) and yes the caller-ID works using the north american caller ID method in the spa400's voice section and the bellcore - V.23 parameters in the spa9000's regional settings.

Let me know if you need additional help.


Chris

mdolimont Tue, 06/09/2009 - 14:50
User Badges:

you can resolve the issue with ISDN NT1+

using call ID method american bellcore, and improved the connection cable wrap together all line...
if you have more noice on line you must use another shrewdness ;-)

zeljkodraskovic Tue, 05/19/2009 - 04:17
User Badges:

Dear Patrick,


As I also have problem with callerid feature in Montenegro, I am asking to send me beta firmware so I can try with that one



Best regards,


Zeljko

Patrick Born Tue, 05/26/2009 - 14:26
User Badges:
  • Cisco Employee,

Hi Zeljko,


I have sent you a copy to your personal email.


Thanks for your interest in helping me test this firmware.


Regards,



Patrick

----------

zeljkodraskovic Fri, 05/29/2009 - 02:53
User Badges:

Hi Patrick,


just to share my findings with community.


I've upgraded SPA400 to beta firmware and I've got a callerID presented. But I managed to have it only by using NorthAmerican (default) setting as suggested several posts above



Thanks,


Zeljko

Patrick Born Fri, 05/29/2009 - 04:32
User Badges:
  • Cisco Employee,

Hi Zeljko,


Thanks for sharing the success story.

What setting did you try to use for the SPA400?

Does your country perhaps use the same caller id standard as is used in North America?


Regards,



Patrick

-----------

zeljkodraskovic Fri, 05/29/2009 - 04:50
User Badges:

Hi Patrick,


In Montenegro callerID standard (as given by law) is European FSK. Using SPA3102, CID is detected using that settings only.

But on SPA400, callerID started to show up only by using beta firmware and NorthAmerican settings.


Regards,

Zeljko

Patrick Born Fri, 05/29/2009 - 07:00
User Badges:
  • Cisco Employee,

Hi Zeljko,


Thanks for the information. I've shared it with the author of the test firmware.


Regards,



Patrick

----------

mdolimont Sun, 06/07/2009 - 07:03
User Badges:

The real spa400 problem is to manage call-ids when the in-lines are of a different providers...


for example:


the spa400 have 4 fxo ports, If I connecting telecom from ISDN adapter on port 1 and 2,

on port 3  I connect gsm and on port 4 another analogue line or BT from or voip adapter,

the problem shows up....


(the lines orders doesn't really matter, i wrote it just for example,

the problem shows up with lines of different kind in any port)


The issue appears even with the latest 1.1.2.2 and beta firmware.
So i don't think it's a firmware bug but it should be a hardware issue.

I also think that there is buffer issue cause the conversation quality isn't the best one.


I reached this conclusion cause I made a filter that solve the issue when linked to the spa400,

I tested it with good results and good responses from my colleagues in Italy, UK and FR...

breath_mone Tue, 06/09/2009 - 15:08
User Badges:

Hey,

i have the same problem, as many other, it seems, here in Italy and even some UK friends.
Using the spa400 with an analogic telecom line and a gsm results in the spa400 not showing the call-ids.

Can you send me the beta firmware to see if it solves the issue?

Thank you.

Patrick Born Tue, 06/09/2009 - 15:53
User Badges:
  • Cisco Employee,

Hi mdolimont,


Please consider sharing with the community, your solution.


Regards,



Patrick

----------

Actions

This Discussion