2600 not able to add vlan envapsulation

Unanswered Question
Mar 6th, 2009
User Badges:

I have a 2600 and I am trying to configure subinterfaces on a f0/0 port. I read that my code supports vlan encapsulation but when I try to add encapsulation 802.1d to the interface the command is non-existant. Here is the show ver and the error message:

System image file is "flash:c2600-io3-mz.123-26.bin"


cisco 2621 (MPC860) processor (revision 0x600) with 59392K/6144K bytes of memory

.

Processor board ID JAD05370MLQ (1938564210)

M860 processor: part number 0, mask 49

Bridging software.

X.25 software, Version 3.0.0.

2 FastEthernet/IEEE 802.3 interface(s)

2 Serial(sync/async) network interface(s)

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

Router(config-subif)#encapsulation 802.1d

^

% Invalid input detected at '^' marker.


Router(config-subif)#ip address 10.1.1.1 255.255.255.0


% Configuring IP routing on a LAN subinterface is only allowed if that

subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q,

or ISL vLAN.


Router(config-subif)#


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
jasosan22 Fri, 03/06/2009 - 07:37
User Badges:

My bad. typed in d insead of q. but still

Router(config-subif)#enc?

% Unrecognized command

Router(config-subif)#?

Interface configuration commands:

arp Set arp type (arpa, probe, snap) or timeout

backup Modify backup parameters

bandwidth Set bandwidth informational parameter

bgp-policy Apply policy propagated by bgp community string

bridge-group Transparent bridging interface parameters

cdp CDP interface subcommands

default Set a command to its defaults

delay Specify interface throughput delay

description Interface specific description

exit Exit from interface configuration mode

glbp Gateway Load Balancing Protocol interface commands

ip Interface Internet Protocol config commands

keepalive Enable keepalive

llc2 LLC2 Interface Subcommands

glen.grant Fri, 03/06/2009 - 07:38
User Badges:
  • Purple, 4500 points or more

Should be configured something like this.


7500(config)#int fast 5/1/1.1

7500(config-subif)#encapsulation dot1Q 1 native

7500(config-subif)#ip address 10.10.10.1 255.255.255.0

7500(config-subif)#exit

7500(config)#int fast 5/1/1.2

7500(config-subif)#encapsulation dot1Q 2

7500(config-subif)#ip address 10.10.11.1 255.255.255.0

7500(config-subif)#exit

jasosan22 Fri, 03/06/2009 - 07:41
User Badges:

Thanks but the encapsulation command doesn't exist. I verified that the router/code supports vlan encapsulation but it isn't allowing me to enter the encapsulation command.

John Blakley Fri, 03/06/2009 - 07:44
User Badges:
  • Purple, 4500 points or more

Are you try to use the encapsulation command on a fastethernet interface?


HTH,

John

Jon Marshall Fri, 03/06/2009 - 07:46
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

You don't have the right feature set. You have IP/FW/IDS which does not support 802.1q. IP Plus & Enterprise do. Have a look at Feature Navigator to select correct feature set for your needs -


http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp


Jon

Actions

This Discussion