Internal eigrp ,external eigrp

Answered Question
Mar 7th, 2009
User Badges:
  • Bronze, 100 points or more

Hi everybody!


I have few questions about eigrp.

My book says eigrp(internal) has AD=90

and eigrp(external) has AD=170

what is external eigrp?


thanks a lot!

Correct Answer by Jon Marshall about 8 years 3 months ago

Actually a better setup would be


ra (192.168.1.1/30) -> EIGRP -> (192.168.1.2/30) rb -> (192.168.2.1/30) IGRP -> (192.168.2.2/30) rd


ra

===


int s0

ip address 192.168.1.1 255.255.255.252


int loopback10

ip address 210.210.210.1 255.255.255.0


router eigrp 1

network 192.168.1.0

network 210.210.210.0

no auto-summary


rb

===


int s0

ip address 192.168.1.2 255.255.255.252


int s1

ip address 192.168.2.1 255.255.255.252


router eigrp 1

network 192.168.1.0

no auto-summary


router igrp 1

network 192.168.2.0

no auto-summary


rd

==


int s1

ip address 192.168.2.2 255.255.255.252


int loopback10

ip address 180.180.180.1 255.255.255.0


router igrp 1

network 192.168.2.0

network 180.180.180.0

no auto-summary


Jon

Correct Answer by Jon Marshall about 8 years 3 months ago

Sarah


For automatic redistribution to work you need to run the same AS for EIGRP and IGRP on the SAME router. So in your case what you are seeing is correct.


Try this on rd


interface Ethernet0

ip address 199.199.199.4 255.255.255.0

!

interface Serial0

ip address 200.200.200.4 255.255.255.0

!

interface Serial1

ip address 201.201.201.4 255.255.255.0

!

router eigrp 1

network 199.199.199.0

!

router igrp 1

network 200.200.200.0

network 201.201.201.0


What you should then see is the 199.199.199.0 network should appear on ra and rb.


Jon

Correct Answer by Richard Burts about 8 years 3 months ago

Perhaps we need to be careful about exactly what the book says and the context in which it says it. It has been quite a while since I have used IGRP but my memory is that redistribution was not automatic. But what was automatic was the metric used.


In general when you redistribute into EIGRP or IGRP you need to specify a default metric since the metrics in IGRP/EIGRP are not compatible with metrics of other protocols and there is not an automatic default metric (as there is in OSPF for example). But the metrics of IGRP and of EIGRP are compatible (not the same but compatible) and so if you configure redistribution between an IGRP process and an EIGRP process then there is no requirement to specify a default metric.


Perhaps you can describe exactly how you set up your test and what you did observe in the test?


HTH


Rick

Correct Answer by Richard Burts about 8 years 3 months ago

Zeeshan


An EIGRP external route is a route that was redistributed into EIGRP.


If the route was learned from a network statement then it is internal. And if it was learned from redistribution then it is external.


HTH


Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
Correct Answer
Richard Burts Sat, 03/07/2009 - 15:13
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Zeeshan


An EIGRP external route is a route that was redistributed into EIGRP.


If the route was learned from a network statement then it is internal. And if it was learned from redistribution then it is external.


HTH


Rick

sarahr202 Sat, 03/07/2009 - 15:26
User Badges:
  • Bronze, 100 points or more

Hi Rick!

if you don't mind could you explain the following:

My book says auto redistribution occurs between igrp and eigrp if they have same AS.

However, when i performed a lab i did not find any auto matic redistribution between igrp and eigrp having same AS.

thanks a lot!

Correct Answer
Richard Burts Sat, 03/07/2009 - 15:35
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Perhaps we need to be careful about exactly what the book says and the context in which it says it. It has been quite a while since I have used IGRP but my memory is that redistribution was not automatic. But what was automatic was the metric used.


In general when you redistribute into EIGRP or IGRP you need to specify a default metric since the metrics in IGRP/EIGRP are not compatible with metrics of other protocols and there is not an automatic default metric (as there is in OSPF for example). But the metrics of IGRP and of EIGRP are compatible (not the same but compatible) and so if you configure redistribution between an IGRP process and an EIGRP process then there is no requirement to specify a default metric.


Perhaps you can describe exactly how you set up your test and what you did observe in the test?


HTH


Rick

sarahr202 Sat, 03/07/2009 - 16:30
User Badges:
  • Bronze, 100 points or more

I will run the test again and post the output tomorrow . You guys have a good weekend!

thanks a lot!

sarahr202 Sun, 03/08/2009 - 08:58
User Badges:
  • Bronze, 100 points or more

Hi every body!

Here is my lab set up.


Three routers( 2500 series), rb,ra,rd are connected in triangular fashion.


ra is connected to rd via s1(200.200.200.1)

ra is connected to rb via s0 (202.202.202.1

-------------------------------

rb is connected to ra via s0,202.202.202.2

rb is connected to rd via s1 201.201.201.2

------------------------------------


rd is connected to rb via s1 201.201.201.4

rd is connected to ra via s0 , 200.200.200.4


please view the attached file for configurations.






Attachment: 
Correct Answer
Jon Marshall Sun, 03/08/2009 - 09:40
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Sarah


For automatic redistribution to work you need to run the same AS for EIGRP and IGRP on the SAME router. So in your case what you are seeing is correct.


Try this on rd


interface Ethernet0

ip address 199.199.199.4 255.255.255.0

!

interface Serial0

ip address 200.200.200.4 255.255.255.0

!

interface Serial1

ip address 201.201.201.4 255.255.255.0

!

router eigrp 1

network 199.199.199.0

!

router igrp 1

network 200.200.200.0

network 201.201.201.0


What you should then see is the 199.199.199.0 network should appear on ra and rb.


Jon

sarahr202 Sun, 03/08/2009 - 10:16
User Badges:
  • Bronze, 100 points or more

Thanks jon! Very much indeed 199.199.199.0 appeared in routing tables on ra and rb.


Thanks and have a nice weekend!

Correct Answer
Jon Marshall Sun, 03/08/2009 - 09:49
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Actually a better setup would be


ra (192.168.1.1/30) -> EIGRP -> (192.168.1.2/30) rb -> (192.168.2.1/30) IGRP -> (192.168.2.2/30) rd


ra

===


int s0

ip address 192.168.1.1 255.255.255.252


int loopback10

ip address 210.210.210.1 255.255.255.0


router eigrp 1

network 192.168.1.0

network 210.210.210.0

no auto-summary


rb

===


int s0

ip address 192.168.1.2 255.255.255.252


int s1

ip address 192.168.2.1 255.255.255.252


router eigrp 1

network 192.168.1.0

no auto-summary


router igrp 1

network 192.168.2.0

no auto-summary


rd

==


int s1

ip address 192.168.2.2 255.255.255.252


int loopback10

ip address 180.180.180.1 255.255.255.0


router igrp 1

network 192.168.2.0

network 180.180.180.0

no auto-summary


Jon

Actions

This Discussion