Misconfigured zoning and had to bounce ports, can someone explain?

Unanswered Question
Mar 8th, 2009
User Badges:

I am working in a lab, and had the following configuration:


HOST1-PORT1 connected to MDS1 in VSAN10

HOST2-PORT1 connected to MDS2 in VSAN 20

DISK1-PORT2 connected to MDS2 in VSAN10

DISK2-PORT2 connected to MDS1 in VSAN 20


MDS1 and MDS2 were connected via a FCIP tunnel.


I could see everything as expected in the fcns database. What I wanted to do was have HOST1 use DISK1 from over the FCIP tunnel and HOST2 use DISK2 over the FCIP tunnel.


What I accidently did, was zone as follows:

Zone10

HOST1 DISK1

Zone20

HOST2 DISK1


From HOST1 I could not see DISK1 (windows disk manager), I could see it from HOST2 however, was able to format it and work with it. Once I figured out that I had zoned that drive to two hosts, I immediately went to correct it. And by the way, Sansurfer on HOST1 did show it saw the drive, but windows disk tools did not see it.


So on the MDS, I removed the incorrect pwwn, added the correct one, and activated the zoneset. Still HOST1 could not see the drive. HOST2 however could now see its new (corrected) drive. HOST2's sansurfer topology map was actually still showing both PWWN's, not sure if that was just cached or not as the DISK1 was no longer zoned to it.


So I reboot each HOST. Still no go, HOST1 could not see the DISK1! BTW, I checked the active zoneset and MDS reported all members correct and visible. So then I bounced each VSAN......honestly because I wasn't sure what else to do, and that still did not fix the issue, I tried to tell the disk management to rediscover drives but to no avail. Finally, came the sledgehammer. I bounced the actual FC ports. This fixed the problem.


My question is, is this normal behavior? I thought when I rebooted the windows hosts, it would cause them to do FLOGI again which I thought would be same as bouncing the FC ports. Did bouncing the host ports have anything to do with this resolution? Or was it the bouncing of the DISK ports that was the fix? What situation did I get myself into that the drive could not be seen by windows even though it was zoned to it?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
inch Tue, 03/10/2009 - 01:23
User Badges:
  • Bronze, 100 points or more

Howdy,


Which switch was the primary of the particular vsan? Was the zoneset distributed properly? (these are just guesses without seeing any debug info).


I have seen in the past some qlogic cards on linux stay logged into the fabric when a server is rebooted (not powered off) until the qlogic kernel module is loaded where it logs out and then back in again.


I'm wondering if the windows driver see's that its already logged in and does not try to re-login?



bfeeny Tue, 03/10/2009 - 07:16
User Badges:

I don't recall which switch was the primary. I believe the zone was distributed properly. I wasn't sure that if you zone some devices, and then change zones around if it was common to have to bounce ports, but that is what I experienced. The active zoneset looked good, on both switches.


So if host1 is zoned to target1. And you change the zoneset so that now host1 is zoned to target2, doesn't a RSCN happen which notifies the host1 that there is a new target2? I wouldn't think rezoning would cause logout. I will play with it some more and see if I can get more data

inch Tue, 03/10/2009 - 14:20
User Badges:
  • Bronze, 100 points or more

Howdy,


It will send out a notify but you then have to tell the host to do something with it.


I can't really speak about windows and what it will do.


You _don't_ have to shut/no shut a port to get it to see devices - Something is wrong here.


Have you got a linux machine you can use? It will be easier to actually see whats going on :)

bfeeny Tue, 03/10/2009 - 14:28
User Badges:

Not in my current lab, but in the lab I am trying to build to improve on it I will. I will try to gather more data about what is going on with the scenerio.

inch Tue, 03/10/2009 - 14:37
User Badges:
  • Bronze, 100 points or more

turn on the fcanalyser and load it up in wireshark :)


Or, if you have a PAA-2, span it and then fire up wireshark :)

Michael Brown Tue, 03/10/2009 - 20:54
User Badges:
  • Cisco Employee,

I have seen Windows OS do some weird things like this. I have had to reboot the system when the HBA config tool saw the FC attached luns and they looked just fine in the tool, but Disk Manager would not pick them up.


I have traced, as Inch suggested, with a PAA-2 and MDS span, and issued a re-scan on the Windows Disk Manager panel...and the trace show nothing being sent by the port the Windows box was plugged into. I had to bounce the port on the MDS and I saw the Windows box issue all the normal bring up stuff and register with the FC nameserver...then it got all the devices in teh zone...then I expected a PLOGI from the HBA to the storage device....nothing.


That's when I rebooted and the trace showed the Windows box finally issue the PLOGI and PRLI to the storage device.


Bottom line, when I make changes to zoning for a Windows environment, I reboot.


Linux and Solaris seem to handle zone changes better. As for AIX 5.3...let's not go there :)


My 2 cents,

Mike

vicharem Thu, 09/24/2009 - 12:07
User Badges:

If you are sharing the same LUN to two or more Windows hosts, I believe you need to have clusters installed.

Actions

This Discussion

 

 

Trending Topics: Storage Networking